1. Jcpstrat's Avatar
    Im running Windows 8.1 and its has been running great but recently, 3 different times, my tablet failed to start and the screen displayed the following message:

    American Megatrends
    ASUS ME400C BIOS Revision 0601, Build Date 10/29/2013
    EC1 version: PAD-EC31C-0015
    WINKEY version: ME400C-ECFG_0103.ROM
    Read AtmelTouchFW Version failed, Recovery...

    After waiting awhile ... it sometimes will start. Several times I've had to do a restart a few times before it would start. I'm concerned one of these times it won't start.

    Anyone else noticing this issue. Just started this month!
    11-07-2014 06:52 PM
  2. stephen_az's Avatar
    That is a rather user unfriendly version of a fatal error message and it is hardware related. This is something you really need to take to Asus support....
    11-07-2014 08:34 PM
  3. Jcpstrat's Avatar
    Thanks for reply stephen_az ... I actually tried that tonight but from Asus's website I got 2 "Connection Failed" messages while trying to create a Case and no one answered the On-Line Chat I tried to start. Oh well ... maybe I should try during a weekday. :)
    11-07-2014 08:42 PM

Similar Threads

  1. My nokia 1020 has turned itself off and wont switch on or charge
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 11-07-2014, 01:22 PM
  2. Replies: 1
    Last Post: 11-06-2014, 07:38 PM
  3. Unlimited OneDrive storage starts rolling out to Office 365 subscribers
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-06-2014, 07:30 PM
  4. Anyone using MS Band/ Windows phone / Myfitnesspal / smart scale?
    By mistaclark in forum Microsoft Band & Band 2
    Replies: 4
    Last Post: 11-06-2014, 03:04 PM
  5. Why do I have a sad smiley on the start screen?
    By Deepak Pm in forum Nokia Lumia 520
    Replies: 1
    Last Post: 11-05-2014, 12:07 PM
LINK TO POST COPIED TO CLIPBOARD