02-22-2018 06:24 AM
586 ... 678910 ...
tools
  1. tushardhingra's Avatar
    if it showing qualcomm composite device then select my device is not detected then select manufacturer BLU-Select Model Blu win hd LTE. Now click on install software. click on continue.select the reason for recovery or click on continue without submitting.Now WDRT will check for the downloading package.If it already dowlnoaded then it battery icon will appear.Just continue the next steps.
    Even after battery icon it is asking me to do all this flashing mode stuff...although my phone is already in flashing mode...

    (may be my system is not recognising the phone in flashing mode)

    Update: Installed WDRT on my laptop running Windows 10 (previously I was trying on Windows 7) and copied the downloaded image to the required path...Now package is installing...Thanks for help everyone :)
    Last edited by tushardhingra; 04-08-2016 at 02:08 PM.
    abhijit pore likes this.
    04-08-2016 01:55 PM
  2. Alexunder93's Avatar
    Just using .167 version. Just WOW, even snappier than my Lumia 640.
    04-08-2016 02:00 PM
  3. tushardhingra's Avatar
    Just using .167 version. Just WOW, even snappier than my Lumia 640.
    Can't wait to see my BLU running Windows 10 :) :D
    04-08-2016 02:09 PM
  4. GrandGerminator's Avatar
    I am frmFrance and have also bought my Blu Win HD LTE from amazon.co.uk ! I bought it because this device should support win 10 !!! Today I am very disapointed if Blu or M$ confirm that the EU device will not have windows 10 mobile...
    J'tais a deux doigts de faire la mme chose ! Puis j'ai vu que Insider tait dispo sur les version Etasuniennes... Mais pas europenne du smartphone... Du coup je me suis tourn vers un 650... Que dis-je, un Moto X Play :-)
    04-08-2016 02:17 PM
  5. kashifsayed's Avatar
    some one who has downloaded both the files just do a CRC check and see if they are same
    04-08-2016 02:58 PM
  6. dorelse's Avatar
    Just using .167 version. Just WOW, even snappier than my Lumia 640.
    Can you confirm that its .167 vs. the .164 (US upgrade version)? That would imply there are additional patches included.
    04-08-2016 03:32 PM
  7. Alexunder93's Avatar
    Sorry for confusion. Is 164. I misswrote a number...
    04-08-2016 03:44 PM
  8. tushardhingra's Avatar
    some one who has downloaded both the files just do a CRC check and see if they are same
    Yes they are completely same except for name (Microsoft pulled the image from WDRT to change the name to avoid any confusion and again pushed it back in few minutes).
    04-08-2016 03:56 PM
  9. Alexunder93's Avatar
    The only problem found: Back button not working in Outlook. Can anyone confirm?
    win10swed likes this.
    04-08-2016 04:16 PM
  10. win10swed's Avatar
    Yes, I can confirm that not sure why
    sunhi3man likes this.
    04-08-2016 04:53 PM
  11. gabriel92's Avatar
    just flashed through WDRT, does hard reset fix outlook back button issue?
    04-08-2016 05:38 PM
  12. dorelse's Avatar
    just flashed through WDRT, does hard reset fix outlook back button issue?

    My back button works in Outlook. Honestly, the upgrade is very unstable without starting with a fresh phone, so I highly recommend a hard reset. (As much as I resisted initially...its needed.)
    gabriel92 likes this.
    04-08-2016 09:55 PM
  13. abhijit pore's Avatar
    Hello is anyone here from India having Airtel 4G sim now? Right now i have 4g speed issue. I mean it shows LTE but the problem is i am not getting the expected speed. I checked the 4g speed via 2 apps. First one is speedtest and the second is nPerf speed. Both the apps shows the result of app.16Mb/s download which is not right.Before upgrading to this firmware i used to get 30 to 55Mb/s speed. Don't know why But i again reverted to 8.1 using latest image. i thought it would be a problem of win 10. But even in 8.1 also having latest firmware 15013 i am getting the same speed.May be i have to inform airtel about this. Another thing is that i can't toggle between 4g 3g 2g settings. it only shows airtel mobile office
    04-08-2016 11:05 PM
  14. Alexunder93's Avatar
    Here in Romania 4G works good and the speed is good also. The onlything that needs to be fixed is Outlook and the scale for 200% text size + back button on exit.
    Also, I believe that limiting the phone to 3g only or other cellular settings are only made for lumias but windows itself doesn't have.
    abhijit pore likes this.
    04-09-2016 02:13 AM
  15. gabriel92's Avatar
    My back button works in Outlook. Honestly, the upgrade is very unstable without starting with a fresh phone, so I highly recommend a hard reset. (As much as I resisted initially...its needed.)
    Back button in Outlook works here after update to .164. However decided to do a hard reset.
    04-09-2016 06:13 AM
  16. patriklantos88's Avatar
    Hey guys! Any idea how to upgrade the phone to the Fast Ring versions of Win10 Mobile ? I installed Windows Insider app, and enrolled the device in the "Fast Ring", it downloaded a configuration update, but the version is still 10586.164, and it does not find any update.
    04-09-2016 07:57 AM
  17. Svetoslav Enkov's Avatar
    Hey guys! Any idea how to upgrade the phone to the Fast Ring versions of Win10 Mobile ? I installed Windows Insider app, and enrolled the device in the "Fast Ring", it downloaded a configuration update, but the version is still 10586.164, and it does not find any update.
    I think it is not included yet in the list of the supported phones Supported phones for Windows Insider Preview - Microsoft Windows
    Last edited by Svetoslav Enkov; 04-09-2016 at 08:12 AM. Reason: grammar editing
    04-09-2016 08:11 AM
  18. Maddy90's Avatar
    Hey guys! Any idea how to upgrade the phone to the Fast Ring versions of Win10 Mobile ? I installed Windows Insider app, and enrolled the device in the "Fast Ring", it downloaded a configuration update, but the version is still 10586.164, and it does not find any update.
    Fast Ring is only available now for those devices that came with Windows 10 Mobile pre-installed. Fast Ring builds (currently Redstone Build) are not yet available for those who upgraded to Windows 10 Mobile. Hopefully, Microsoft will open the Fast Ring for older devices soon.
    04-09-2016 08:16 AM
  19. patriklantos88's Avatar
    Ah, got you guys! Thanks for the heads up! :) Anyways, I'm loving Win10 on my BLU, how about the others ? It is pretty snappy!
    04-09-2016 08:19 AM
  20. Ankush V1's Avatar
    My back button in outlook still does not work after a reset . I think there are some bugs in wp10 that still need sorting out .
    04-09-2016 08:22 AM
  21. Svetoslav Enkov's Avatar
    Are you updated to 10586.164 - and the Outlook Mail and Calendar app too?
    04-09-2016 08:50 AM
  22. Svetoslav Enkov's Avatar
    https://en.wikipedia.org/wiki/Windows_Insider

    14291+ is allowed for BLU Win HD LTE, but still for X150Q model yet!
    04-09-2016 09:04 AM
  23. abhijit pore's Avatar
    Hey guys my windows central app of windows 10 moblie keep crashing whenever i tap on login into settings. Is anyone facing this issue?
    04-09-2016 09:16 AM
  24. abhijit pore's Avatar
    I just selected Insider release preview ring from Windows insider app. Then there was small insider preview configuration update was there. After restating the phone there was a two spinning gear and the update was successfully installed.Again i checked for the update then the phone was up to date.
    04-09-2016 09:19 AM
  25. Tarun047's Avatar
    Hey Abhijit any news about BLU win Jr lte 130e Windows 10 upgrade ??
    abhijit pore likes this.
    04-09-2016 09:58 AM
586 ... 678910 ...

Similar Threads

  1. BUGS: Running Window 10 Mobile on the BLU WIN HD LTE (x150q)
    By Codster314 in forum BLU Win HD LTE
    Replies: 64
    Last Post: 03-07-2017, 01:33 AM
  2. Best dpi percentage on w10m blu win lte?
    By JMX777 in forum BLU Win HD LTE
    Replies: 15
    Last Post: 07-01-2016, 10:58 PM
  3. Blu win HD Lte x150e - European version
    By Huzefa Khojaim Ragib in forum Windows 10 Mobile
    Replies: 1
    Last Post: 04-16-2016, 07:54 AM
  4. How do I know if my Lumia 640 supports LTE or no?
    By Windows Central Question in forum Microsoft Lumia 640
    Replies: 1
    Last Post: 03-18-2016, 12:00 PM
  5. Replies: 1
    Last Post: 03-18-2016, 10:59 AM
LINK TO POST COPIED TO CLIPBOARD