12-20-2017 04:39 AM
93 1234
tools
  1. dorelse's Avatar
    Not that this matters if you're a Blu owner, but I actually put mine back to 8.1 and have left it there. I couldn't get updates and it just wasn't super stable as well. It's now my backup to my backup (950) to my new Idol 4S. I still have soft spot for this phone as it was such a great device. Too bad they haven't put WM10 on a Vivo 5 or 5R. I need to sell a couple phones on the marketplace obviously. Lol. If you can swing the Idol 4S & you're on t-mobile, its worth it by a landslide. Such a night & day experience. (for example, Netflix is rock solid on it.)The 650 would be a very nice switch as well.
    11-28-2016 01:09 PM
  2. anthonyng's Avatar
    I just got a hold of my mother in law's x150Q and going through the process to put the latest anniversary, but noticed something odd from what's been reported here.

    I updated to the latest software with wdrt, then I installed windows insider, set to release preview and phone update said phone was up to date! Then I saw notes about upgrade advisor and did that but it's installing threshold 10586.73

    Didn't expect that, should I have just waited longer for the insider program to put me to anniversary update from 8.1?
    01-09-2017 01:33 AM
  3. anthonyng's Avatar
    And if I just waited a bit longer lol, 14393.594 downloading...
    01-09-2017 02:13 AM
  4. gabriel92's Avatar
    Hi, after enabling w10m upgrade through upgrade advisor then you should get 10586, and then 14393, so everything is alright, however could you tell what branch are you on? rs1_release_inmarket or rs1_release_inmarket_rim after the upgrade, or if you still haven't fully upgraded to the lastest rs1 build even before the upgrade? (you can check that in the about screen of the insider app).

    I am trying to get the culprit on the issue, and at least my device shows phone as being on rs1_release_inmarket_rim which is actually up to date (14393.448 mobile build) according to buildfeed.
    01-09-2017 10:42 AM
  5. anthonyng's Avatar
    Hi, after enabling w10m upgrade through upgrade advisor then you should get 10586, and then 14393, so everything is alright, however could you tell what branch are you on? rs1_release_inmarket or rs1_release_inmarket_rim after the upgrade, or if you still haven't fully upgraded to the lastest rs1 build even before the upgrade? (you can check that in the about screen of the insider app).
    Thanks for the confirmation

    I just checked what you asked and it shows rs1_release_inmarket

    I have 14393.594

    my mom in law's account was never an insider before if it makes any difference.
    01-09-2017 11:17 AM
  6. gabriel92's Avatar
    That's an interesting info, my x150e is on rs1_release_inmarket_rim which can explain lack of updates, however everything should be fine on rs1_release_inmarket.

    Since the last restore I think mine wasn't either, but insider after official release of rs1 doesn't work (at least for me).

    Thanks for the info!

    Can anyone else who doesn't get updates and are using rs1 confirm whether their devices are on rs1_release_inmarket or rs1_release_inmarket_rim?
    01-09-2017 12:00 PM
  7. anthonyng's Avatar
    Hmmm, the wrong layout for phone is a bit annoying for email, skype, ....
    01-09-2017 05:06 PM
  8. JMX777's Avatar
    That's an interesting info, my x150e is on rs1_release_inmarket_rim which can explain lack of updates, however everything should be fine on rs1_release_inmarket.

    Since the last restore I think mine wasn't either, but insider after official release of rs1 doesn't work (at least for me).

    Thanks for the info!

    Can anyone else who doesn't get updates and are using rs1 confirm whether their devices are on rs1_release_inmarket or rs1_release_inmarket_rim?
    like others after the au I stop receiving public updates, I'm on 14393.321, to get there I did the wdrt to 8.1 and all the steps (2 1/2 hours for finishing to install updates and apps!!!). How can I check the rs1_........? I'm not a insider, but anything that let me update the phone without doing all the wdrt steps again is welcome!
    01-09-2017 07:45 PM
  9. gabriel92's Avatar
    like others after the au I stop receiving public updates, I'm on 14393.321, to get there I did the wdrt to 8.1 and all the steps (2 1/2 hours for finishing to install updates and apps!!!). How can I check the rs1_........? I'm not a insider, but anything that let me update the phone without doing all the wdrt steps again is welcome!
    Insider app-> 3 dots -> about, to see it you do not need to be enrolled as insider.

    However, as you're on .321 I suppose you are on rs1_release_inmarket, one of my thoughts was that it could be due to branches as after quite long research on the registry itself and on microsoft website (OEM customizable registry keys) I did not find anything useful, so just did restore through wdrt process, as on phone when connected via usb internal memory showed most of the system files (mostly read-only, but some were writable), got some log files there as well (some with errors about updates, but not sure whether they are related to the app store or windows updates (seemed to be a mixture)).

    Also this time once 10586 build got installed I have tried to install DeviceForm provisioning package, maybe after update to 14393 device form will change, or maybe netflix will start to work lol, will post back in case anything of the above would work.
    01-09-2017 08:07 PM
  10. JMX777's Avatar
    Insider app-> 3 dots -> about, to see it you do not need to be enrolled as insider.

    However, as you're on .321 I suppose you are on rs1_release_inmarket, one of my thoughts was that it could be due to branches as after quite long research on the registry itself and on microsoft website (OEM customizable registry keys) I did not find anything useful, so just did restore through wdrt process, as on phone when connected via usb internal memory showed most of the system files (mostly read-only, but some were writable), got some log files there as well (some with errors about updates, but not sure whether they are related to the app store or windows updates (seemed to be a mixture)).

    Also this time once 10586 build got installed I have tried to install DeviceForm provisioning package, maybe after update to 14393 device form will change, or maybe netflix will start to work lol, will post back in case anything of the above would work.
    Lol Netflix...., I've using edge (on desktop render mode) for Netflix but the app used to be much faster, the windows central w10 app don't work too . Thx for the info! I'll wait for news!
    01-09-2017 08:36 PM
  11. gabriel92's Avatar
    in .576 still no netflix and device category shows up as computer. Trying to get .594 to see if the update problem is solved.
    01-09-2017 09:37 PM
  12. JMX777's Avatar
    Anyone try the .693?
    01-11-2017 08:57 PM
  13. gabriel92's Avatar
    Anyone try the .693?
    Yeah, its running pretty well, but had to repeat the WDRT process to get it (still no Netflix).
    01-13-2017 10:13 AM
  14. anthonyng's Avatar
    Man I just did 594 for my mom in law lol.... not sure I want to go through it again for 693.... pretty big version jump though so it's tempting!
    01-13-2017 12:12 PM
  15. gabriel92's Avatar
    Man I just did 594 for my mom in law lol.... not sure I want to go through it again for 693.... pretty big version jump though so it's tempting!
    Haven't got the .594, but it is way better than the .576!
    01-13-2017 07:26 PM
  16. anthonyng's Avatar
    Haven't got the .594, but it is way better than the .576!
    Though I worry that if wait too long the updates get turned off completely and can't get back to windows 10!
    01-14-2017 01:09 AM
  17. gabriel92's Avatar
    Though I worry that if wait too long the updates get turned off completely and can't get back to windows 10!
    I don't why that would happen anytime soon.
    01-14-2017 12:09 PM
  18. anthonyng's Avatar
    I don't why that would happen anytime soon.
    Well soon enough, creators update is coming and the release preview will switch over... then what?
    01-15-2017 11:27 PM
  19. gabriel92's Avatar
    Well soon enough, creators update is coming and the release preview will switch over... then what?
    There is no need to use insider in order to upgrade to w10m, .693 was released as cumulative update, the only thing needed to get w10m is to install upgrade advisor.
    anthonyng and Ankush V1 like this.
    01-16-2017 05:02 AM
  20. JMX777's Avatar
    Anyone tried .726???
    01-29-2017 02:07 PM
  21. Codster314's Avatar
    Creator's Update will come out in April. This will probably be our best chance at having our Update's Fixed.

    That said, if we can't jump from W8.1 > W10M > Creator Update directly... and we have to update to AU then CU... then most likely we'll never been able to update to Creator's Update anyway.

    It past releases we had to update to SP1, before we can update to SP2... so BLU may be stuck on the broken AU forever...
    01-30-2017 04:28 PM
  22. xpsknight's Avatar
    I am not holding my breath, if updates don't work in April, I'll just throw it in the garbage.
    Chandramouli13 likes this.
    02-04-2017 12:04 PM
  23. Guzzler3's Avatar
    I am not holding my breath, if updates don't work in April, I'll just throw it in the garbage.
    I got lucky, mine shat itself when trying to do a factory reset, and I couldn't even use WDRT. Fortunately I bought it from the MS store and I bought the extended warranty, so they replaced it with a Lumia 650.

    I will admit the Blu was a great WP8.1 device, but with W10M it was worthless. I didn't fully realize it till I had the 650 and I could experience W10M properly.
    Chandramouli13 likes this.
    02-04-2017 09:47 PM
  24. anthonyng's Avatar
    I will admit the Blu was a great WP8.1 device, but with W10M it was worthless. I didn't fully realize it till I had the 650 and I could experience W10M properly.
    luckily my mom in law needs are so basic she doesn't know it! She's just giddy that she even has a smart phone!
    02-20-2017 11:09 AM
  25. xpsknight's Avatar
    I got a response from BLU by email ... some hope?

    Hello,
    *
    Thank you for contacting BLU Products. We are happy to help you!
    *
    Please be advised that our Software Engineers are aware of this issue and are working with Microsoft on an update to resolve the problem.

    Should you have any additional questions please contact us at 1-877-602-8762 (Monday-Friday 9:30am-10:30pm EST).
    *
    Thank you for choosing BLU!
    *
    Best Regards,
    Into Blu
    BLU Products Social
    Facebook | www.facebook.com/Blu.Products
    Twitter | www.twitter.com/BLU_Products
    YouTube | www.youtube.com/ BLUProductsGlobal

    Instagram | @BLu_Products
    anthonyng and gabriel92 like this.
    02-22-2017 08:29 AM
93 1234

Similar Threads

  1. why my lumia 925 won't get update beyond 10586.494
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2016, 02:07 PM
  2. Battery Drain on Lumia 950 Post-Anniversary Update
    By ruchrana in forum Microsoft Lumia 950
    Replies: 5
    Last Post: 09-25-2016, 01:24 AM
  3. Vostro 3250 running Win 10 Build 1607 will no longer map network drive to QNAP
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-24-2016, 10:59 AM
  4. Cannot Hard Reset 650 -- Updated
    By gwinegarden in forum Windows 10 Mobile
    Replies: 1
    Last Post: 09-17-2016, 07:51 AM
  5. Lumia 950 stopped working all together after Windows 10 Update
    By karenclayton4076 in forum Microsoft Lumia 950
    Replies: 5
    Last Post: 09-17-2016, 06:20 AM
LINK TO POST COPIED TO CLIPBOARD