The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Digvijay Chauhan's Avatar
    Guys,

    I need your help and one of the reason is that Blu is not helping me. I can't even find service centres and that too in city like mumbai. Also, Blu is not responding to any of my emails.

    Anyway, my phone was working fine. I even upgraded it to Windows 10 with the help of some of the forums here, back in April.

    Few weeks ago, my phone started draining battery like crazy. It was unbelievable. It went from 100% to 30% within 3 hours. By that time it was already night and hence I kept it, thinking will look into it the next day. However, the next morning it the battery was dead, of course, it was draining like crazy.

    Since that day, I haven't been able to revive the phone. It's not charging, can't reset, can't even use WDRT to revive. Just don't know what's wrong.

    WDRT does show the phone connected for few seconds or may be minutes but it's not enough to start the process plus it asks for minimum 25% battery, which it is not charging. I have to keep it connected.

    So, any thoughts or is it gone forever? I wish it's not as Blu is not helping, it's in warranty.

    Thanks in advance
    10-26-2016 09:28 AM
  2. gabriel92's Avatar
    Try to do battery reset as described in another thread (I've seen that you have already done, but do it once more) and plug it into charger (not the usb port on your computer) for 30mins+ it should power up. If battery draining is still there repeat battery reset process.

    If above doesn't help:

    Did the phone get wet? If yes, then probably it is dead.

    Last resort option (CAUTION! if you're not familiar with the electronics give it someone who is), the dirty method, you need to dismantle the phone, unsolder the battery wires(recommended, as charging the battery directly can damage the phone circuitry), find an old phone charger (rated 5V and around 500mA), cut the wire, identify positive lead and ground, and connect it to the battery positive lead and ground (if not marked on the battery - you might need a multimeter to determine it, however if the battery is really flat it won't help) and finally charge it for 30-60seconds, solder the wires back and phone should power on.

    P.S. I am not responsible for any damage the dirty method might cause.
    10-26-2016 07:23 PM
  3. Guzzler3's Avatar
    Have you checked the USB port for "pocket lint"? Just the other day I too was having issues with my phone charging, and not being recognized by my computer. I tried a bunch of things, but then decided to take a closer look at the USB port with a magnifying glass. There was a bunch of lint stuck in the port. I took a wooden toothpick and started picking out the lint. After, everything started to work.
    10-27-2016 08:41 AM
  4. Digvijay Chauhan's Avatar
    Try to do battery reset as described in another thread (I've seen that you have already done, but do it once more) and plug it into charger (not the usb port on your computer) for 30mins+ it should power up. If battery draining is still there repeat battery reset process.

    If above doesn't help:

    Did the phone get wet? If yes, then probably it is dead.

    Last resort option (CAUTION! if you're not familiar with the electronics give it someone who is), the dirty method, you need to dismantle the phone, unsolder the battery wires(recommended, as charging the battery directly can damage the phone circuitry), find an old phone charger (rated 5V and around 500mA), cut the wire, identify positive lead and ground, and connect it to the battery positive lead and ground (if not marked on the battery - you might need a multimeter to determine it, however if the battery is really flat it won't help) and finally charge it for 30-60seconds, solder the wires back and phone should power on.

    P.S. I am not responsible for any damage the dirty method might cause.
    Thanks for your reply and apologies for delay, it is a festival season here in India

    I did what you suggested and still no result. I tell you what happens. The moment I plug in the charger, the red light comes on, the indicator light which tell you if the charging is on, also green means it's fully charged.

    However, after about 2 min, the light starts to blink. Blink and then straight and then blink again. This goes on for few min and then nothing. The light just goes off. Thats it.

    I had the phone plugged in for about 45 min but nothing. Tried battery reset, power on button pressing etc. My computer doesn't even recognize the device connection.

    Dirty trick not yet tried. The Blu team has not yet responded to my email yet. So that sucks.

    And my phone never got wet, it's in pretty good shape.

    Any thoughts ?
    11-01-2016 09:17 AM
  5. Digvijay Chauhan's Avatar
    Have you checked the USB port for "pocket lint"? Just the other day I too was having issues with my phone charging, and not being recognized by my computer. I tried a bunch of things, but then decided to take a closer look at the USB port with a magnifying glass. There was a bunch of lint stuck in the port. I took a wooden toothpick and started picking out the lint. After, everything started to work.
    Thanks a lot, I did check and everything is fine there. Let me know if you have more thoughts on this
    11-01-2016 09:18 AM
  6. Gadgetrendz's Avatar
    Hi all! I also bricked my friend's BLU WIN HD LTE[/B]. I tried to recover it using wdrt. At that time, i could not determine witch variant it was because i had no access to the menu. Software was messed up when he tried to factory reset. No label under the battery and system could not detect it either. I had to use emergency download mode
    recovery went on well, with "successful" at the end. Now phone is dead & no sign of life at all. Heeeeeeelp!!!
    Last edited by Gadgetrendz; 11-25-2016 at 04:48 PM.
    11-21-2016 03:28 AM
  7. Gadgetrendz's Avatar
    Alright WC,can I get some help on this forum?
    11-25-2016 04:51 PM

Similar Threads

  1. Trying to update to 14951 and get error 0x800703f1
    By mikewarner in forum Ask a Question
    Replies: 2
    Last Post: 10-27-2016, 07:27 AM
  2. Microsoft Windows 10 Event Live Blog and Discussion
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 3
    Last Post: 10-26-2016, 10:59 AM
  3. See Amazon UK's exclusive Call of Duty: Infinite Warfare and Watch Dogs 2 pre-orders
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-26-2016, 09:00 AM
  4. UNABLE TO SEE PICTURES and ABSENCE OF NETWORK FOR ONE THE SIM CARD in LUMIA 535
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-26-2016, 02:29 AM
  5. Microsoft tech is the best and the worst!
    By HeyCori in forum Microsoft News & Rumors
    Replies: 0
    Last Post: 10-25-2016, 09:23 PM
LINK TO POST COPIED TO CLIPBOARD