The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
04-28-2018 10:46 AM
31 12
tools
  1. Tom Hanson's Avatar
    Does anyone perhaps have the original Registry Settings for the keys below for the X150Q?

    Here are the ones I modified
    [HKEY_LOCAL_MACHINE\SYSTEM\Platform\DeviceTargetingInfo]
    "PhoneManufacturer"="MicrosoftMDG"
    "PhoneManufacturerModelName"="RM-1154_15855"
    "PhoneMobileOperatorName"="000-RU"
    "PhoneModelName"="Lumia 650 Dual SIM"
    "PhoneHardwareVariant"="RM-1154"
    Last edited by Tom Hanson; 03-10-2018 at 05:15 PM.
    03-10-2018 04:54 PM
  2. kovalDN's Avatar
    BLU WIN HD LTE 000-88 based devices (X150Q)
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\Platform\DeviceTargetingInfo]
    "PhoneManufacturerDisplayName"="BLU"
    "PhoneManufacturer"="BLU"
    "PhoneManufacturerModelName"="WIN HD LTE"
    "PhoneMobileOperatorName"="000-88"
    "PhoneModelName"="WIN HD LTE"
    "PhoneHardwareVariant"="QL850"
    BLU WIN HD LTE 000-33 based devices (X150E)
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\Platform\DeviceTargetingInfo]
    "PhoneManufacturerDisplayName"="BLU"
    "PhoneManufacturer"="BLU"
    "PhoneManufacturerModelName"="WIN HD LTE"
    "PhoneMobileOperatorName"="000-33"
    "PhoneModelName"="WIN HD LTE"
    "PhoneHardwareVariant"="QL850"
    03-11-2018 12:50 AM
  3. Tom Hanson's Avatar
    Thanks a ton kovalDN..
    I have one other question for you if you don't mind. I followed this great artical to upgrade a X150Q to 10.0.15254.248. It worked great.. Thanks for the info on all of this..

    After the upgrade the phone works great except Cellular data is not working. I made sure it was enabled. Worked before the upgrade and works in other phones if I swap sim cards. Any idea on this?

    I am going to reset the phone and test at each stage otherwise.

    Thanks in advance.
    03-11-2018 09:44 PM
  4. Adwait Gharat's Avatar
    @kovalDN

    Sorry to ask so many questions.... I just want be clear on the process

    So I MUST to reset back to wp8.1 first? Right now rhe phone is on 14393 or something.

    Installing the cab mean just open the link the your text file on the phone and run the cab file individually somehow?

    Then I just goto phone update and update the phone?

    Has anyone tried patching the .cab files directly over a build higher than 10.0.10586.xxx (such as 14393.xxx) after a hard reset using iutool? Does it still work and you get to 15063.xxx?
    or is this method to manually update via OTC specifically for 10586.xxx build only?
    04-06-2018 05:02 AM
  5. anthonyng's Avatar
    @Adwait Gharat I've yet to have time to try it on my mom in law phone, but I also won't try another method either!
    Adwait Gharat likes this.
    04-07-2018 01:14 AM
  6. unichips's Avatar
    I reverted back to 8.1 using WDRT, and then using iutool.exe to install the CABs listed at the top of this page to get to the RTM release of Windows 10 Mobile. After that, I tried a few different "next steps" and ended up with very different results:

    1) I allowed normal OTA updates to run, and after two successive OTA updates, I eventually gained access to the 2018-04 AU build (14393.2189).

    2) I reset back to 8.1 again, and followed the same initial steps, but instead of allowing OTA updates to run, I kept WiFi disabled, and instead I tried to follow the instructions linked here (https://forums.windowscentral.com/wi...xxx-build.html) to directly upgrade to the first release of CU (15063.251) using a newer version of iutool.exe. It failed.

    3) I repeated the reset steps again to get back to Windows 10 Mobile RTM; then, I used the newer version of iutool.exe to upgrade to the final directly downloadable version of 14393 listed in that thread, as an intermediate step to upgrading further to 15063.251. This time, I was able to get to 15063. When I then tried to do an OTA check for updates, it detected the fact that the 2018-04 update was available, but the download quickly failed. I repeated this multiple times over a couple of days, but the failure was consistent.

    I've gone back to the results from attempt (1), because it leaves my phone with the most recent set of security patches. However, I'd really like to know if there's anything I should do differently to successfully get myself on to the 15063.x builds. Any advice?
    04-28-2018 10:46 AM
31 12

Similar Threads

  1. Android or iPhone for Windows user?
    By nikon133 in forum The "Off Topic" Lounge
    Replies: 19
    Last Post: 02-06-2018, 04:25 AM
  2. Will the Surface Pro 4 work with the Microsoft Windows Mobile Display Dock?
    By Darthbobcat in forum Microsoft Surface Pro 4
    Replies: 1
    Last Post: 12-30-2017, 12:40 PM
  3. Are windows phone going to be dead soon?
    By Mehtab Khan2 in forum Ask a Question
    Replies: 12
    Last Post: 12-30-2017, 12:26 PM
  4. How could i win a contest in windows central?
    By Mehtab Khan2 in forum Ask Dan!
    Replies: 1
    Last Post: 12-28-2017, 09:09 PM
  5. Surprise! Leading media center solution Kodi has arrived on Xbox One
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-28-2017, 06:50 PM
LINK TO POST COPIED TO CLIPBOARD