1. Joe_Public's Avatar
    I'm having issues and getting no data connection on my Blu WIN Jr. I already tried both SIM slots to no avail, anyone else having this issue? I'm On AT&T
    edit:
    I have zero service, no calls or texts.
    10-20-2014 05:01 PM
  2. hcrick's Avatar
    Is it recognizing the ATT sim? What do the icons show?
    10-20-2014 05:05 PM
  3. will9's Avatar
    The cut corner, of the sim, should be facing the battery. Don.t ask me how I know.
    10-20-2014 05:35 PM
  4. Joe_Public's Avatar
    I get zero service, the SIMs don't even read, and Im sure Im loading it properly. will9, is it loaded the opposite way the phone tells you to load it?
    10-21-2014 03:28 PM
  5. bt66's Avatar
    My friend got one this afternoon. We had the same issue. But, after changing a couple of SIMS we gave up. Exchanged the phone for a new one. The new one recognized the SIM right away. Were able to make & receive calls. Did not test the data side yet.
    10-24-2014 01:15 AM

Similar Threads

  1. Replies: 4
    Last Post: 02-24-2015, 09:18 PM
  2. Anyone on Bell Canada with ATIV S Firmware 2424.14.9.3?
    By mapman_yyc in forum Samsung ATIV S
    Replies: 7
    Last Post: 10-30-2014, 03:26 PM
  3. Will Expandable Storage on 830 help Battery Life?
    By At the beach in forum Nokia Lumia 830
    Replies: 9
    Last Post: 10-27-2014, 10:58 AM
  4. Epocrates NOT actually working on windows app?
    By TheBog in forum Windows Phone 8.1
    Replies: 3
    Last Post: 10-21-2014, 07:47 AM
  5. Poll: Vote for the best podcast app on Windows Phone!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-20-2014, 04:00 PM
LINK TO POST COPIED TO CLIPBOARD