1. wards242's Avatar
    I have a dual sim BLU JR LTE mobile bought from Amazon UK at a very good price and it works here in France very well with a French and UK sim card.
    Windows Device Recovery Tool 3.4.34 is showing firmware version 15023 whilst my phone is 15009.
    Try as I might, I can get the phone to flash mode connected to the PC, but WDRT fails at that point.
    Has anybody managed to get this working on this phone and done an update?

    Thanks.
    05-07-2016 10:00 AM
  2. suppax's Avatar
    I've the exact same problem, some error relative to region/language

    ps. I've sent a mail to BLU describing the problem, let's see if they answer.
    Last edited by suppax; 05-08-2016 at 02:43 AM.
    05-07-2016 05:14 PM
  3. boxofbadgers's Avatar
    Same problem here, it looks to me like WDRT is just not downloading the image file. It skips that part and straight to the battery check. Anybody know the URL to directly download the image file?
    05-08-2016 10:37 AM
  4. suppax's Avatar
    in WDRT if u go in Settings >> troubleshooting >> Export it will make u a zip containing latests logs
    05-08-2016 12:21 PM
  5. wards242's Avatar
    Thanks for the replies.
    I have the BLU JR LTE 130e stuck with spinning gears and a sad smiley after attempting a hard reset using the buttons.
    Can get into flash mode but as above problems.
    Will try the log file.
    05-09-2016 09:44 AM
  6. boxofbadgers's Avatar
    Ive asked about this in the windows community pages (http://answers.microsoft.com/en-us/m...4-2306d595f1d2) and emailed blu - not had a response yet - will keep you updated if i do...
    05-09-2016 10:56 AM
  7. Ranit Sobti's Avatar
    I had similar issue. Solution to the same, as I have managed to progress is that instead of selecting x130e select x130q in WDRT. I was able to identify this upon reading about latest firmware merge for BLU Win HD of the E and Q models. Also read about 15023 being latest version for both Q & E win JR. Connect your phone as directed in WDRT and select x130q. I have done that and the phone is working absolutely fine. I was also able to upgrade to Win 10 using "Insider Fast Update". After getting OS version 10586 on first update to Win 10, I changed my preference in insider App to "Production". This helps you to get stable updates, rather than getting all the updates which may contain bugs.
    suppax, haree and matte.lova like this.
    05-10-2016 03:54 AM
  8. wards242's Avatar
    Thank you all for your assistance.
    Even though I thought my 130e BLU JR LTE was bricked I followed the above instructions and after getting the phone into flash mode
    installed 130q. Restored my last backup from Microsoft and purrrfect!
    As I am in France I use a French Sim card in slot 1 and a UK sim card in slot 2.
    I have spent the morning testing the phone including GPS and Camera and all is good.
    I use a non- standard ring tone which I had to re install but otherwise fine.
    As Ranit stated above I also think build 15023 works on the two version of this phone.
    Thanks again for your help.

    Rob
    05-10-2016 04:52 AM
  9. boxofbadgers's Avatar
    After doing this does your phone identify itself as a x130q or x130e?
    05-10-2016 10:47 AM
  10. wards242's Avatar
    Neither,
    just Firmware revision number:00130.03720.20001.15023
    I have now been updated Automatically to Windows 10
    Version 1511
    OS build: 10.0 10586.107

    so far so good!
    05-10-2016 02:12 PM
  11. boxofbadgers's Avatar
    Sounds good - did you get update to windows 10 via insider or just from the standard update?
    05-11-2016 01:03 AM
  12. wards242's Avatar
    Standard update.
    I read somewhere else on this forum that this had started happening which started this saga!
    As at this morning all is still good.The only thing I have not tried yet is the FM radio.
    05-12-2016 12:08 AM
  13. boxofbadgers's Avatar
    Fantastic news Wards - and that you for following up - I will take your advice, thank you
    05-12-2016 01:13 AM
  14. haree's Avatar
    Fantastic news Wards - and that you for following up - I will take your advice, thank you
    Hi
    I got the win 10 update all is well but it's insider update I can see the same in the recent update available but every thing is fine for me phone is fully working
    05-12-2016 06:08 AM
  15. suppax's Avatar
    Flashed to wrdt 15023 version, but i'm not getting the win10 update from normal update
    05-13-2016 02:19 AM
  16. haree's Avatar
    I had similar issue. Solution to the same, as I have managed to progress is that instead of selecting x130e select x130q in WDRT. I was able to identify this upon reading about latest firmware merge for BLU Win HD of the E and Q models. Also read about 15023 being latest version for both Q & E win JR. Connect your phone as directed in WDRT and select x130q. I have done that and the phone is working absolutely fine. I was also able to upgrade to Win 10 using "Insider Fast Update". After getting OS version 10586 on first update to Win 10, I changed my preference in insider App to "Production". This helps you to get stable updates, rather than getting all the updates which may contain bugs.
    hi
    thanks what u said is right while selecting q it started to download the sw some thing went wrong on the last OTA the phone touch was giving a problem hope this will solve it and revive my phone thanks for ur kind info i need to wait and see
    05-13-2016 02:54 AM
  17. haree's Avatar
    hi
    on doing the above looks like it got flashed in Chinese cant understand how do i get english pls help

    NOTE : got the language changed its on the 1st screen got it changed to English now my phone is fine and good no more playing around ill just stay with win8
    Last edited by haree; 05-13-2016 at 05:54 AM. Reason: correction
    05-13-2016 05:18 AM
  18. daigor87br's Avatar
    Good morning all, I cant connect even when I select both models, my cellphone does not recognize on the wdrt, and it goes to manual selection with I already try both models E and Q and does not change anything. Any Ideas? Drivers missing? Etc?
    07-04-2016 08:06 AM

Similar Threads

  1. Replies: 2
    Last Post: 02-26-2018, 08:31 AM
  2. How long it takes to check for update...?
    By Vivio vrvly in forum Windows 10
    Replies: 5
    Last Post: 05-08-2016, 03:02 PM
  3. Replies: 3
    Last Post: 05-08-2016, 12:42 AM
  4. How to set up two-step verification on your Outlook and Microsoft Accounts
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-07-2016, 09:42 AM
  5. Issue with controlling Netfix on Xbox via the remote on Xbox app
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-07-2016, 06:44 AM
LINK TO POST COPIED TO CLIPBOARD