1. Lloydbm4's Avatar
    Just curious if anyone else has had this issue?

    I unlocked both phones without issue. Ported the numbers no problem. Set up both phones correctly downloading Access Point and using a UK Sim to ensure I could tether and send MMS without issue. Both phones do this no problems. Everythings works on both phones. Only thing is, I should be getting at a minimum HSPA+ where I am (since the LTE bands for T-Mo aren't on these phones), but all I can get is Edge? Slow as snot! And once I pop the T-Mo Sim into my Moto X or Nexus 5, I immediately see 4G.

    Any ideas?
    06-22-2014 03:08 AM
  2. Laura Knotek's Avatar
    Just curious if anyone else has had this issue?

    I unlocked both phones without issue. Ported the numbers no problem. Set up both phones correctly downloading Access Point and using a UK Sim to ensure I could tether and send MMS without issue. Both phones do this no problems. Everythings works on both phones. Only thing is, I should be getting at a minimum HSPA+ where I am (since the LTE bands for T-Mo aren't on these phones), but all I can get is Edge? Slow as snot! And once I pop the T-Mo Sim into my Moto X or Nexus 5, I immediately see 4G.

    Any ideas?
    You'll need to wait until your area is refarmed to use T-Mobile LTE. Until that happens, EDGE is the best you'll get with unlocked AT&T devices.
    06-22-2014 03:14 AM
  3. len0808's Avatar
    Don't know about 1020, but the att 1520 have lte bands 4 and 17, so you should be getting lte. Att locked aws bands, so you will not get hspa+. Double check your apn settings and also make sure you have correct sim card from tmobile.
    06-22-2014 04:01 AM
  4. Jam8240's Avatar
    I did the same thing with a 1520. The best you can get is h+, but if T-Mobile has not reframed the 3g bands in your area, you will be stuck on edge, even if there is 3g service for native T-Mobile phones.
    Laura Knotek likes this.
    06-22-2014 04:13 AM
  5. len0808's Avatar
    I have an unlocked att 1520 on tmobile and I get lte on tmobile. There are also many members on this forum with unlocked att 1520 getting tmobile lte service.
    kennsg likes this.
    06-22-2014 06:26 AM
  6. metalchick719's Avatar
    I assume your area hasn't been refarmed yet. I have an unlocked AT&T HTC One that gets good LTE speeds on T-Mobile. You shouldn't have to wait TOO long to see 4G and LTE, though, as T-Mobile is in the process of converting all of its 2G to LTE.
    06-22-2014 02:51 PM
  7. RumoredNow's Avatar
    It is radios vs towers.

    T-Mo uses the 1700 MHz band in the US. Traditionally that has been where they park their 3G/H+ traffic.

    Which phones of yours have 1700 on the correct radio for 3G/H+?
    Lumia 1050 - RM940 (ATT variant) does not... Falls back to EDGE on 1900.
    Lumia 1020 - RM877 (ATT variant) does not... Falls back to EDGE on 1900.
    Moto X - not sure which variant you have... If you see 4G that is how T-Mo displays H+ and LTE will show LTE... I think you must have a T-Mo Moto X???

    T-Mo is currently shifting their 3G/H+ to 1900 MHz and using the 1700 band for LTE

    What happens with your phones when your area is refarmed?
    Lumia 1050 gets H+ and LTE. Falls back to EDGE in un-refarmed areas.
    Lumia 1020 gets H+ and LTE. Falls back to EDGE in un-refarmed areas.
    ​Moto X goes up to LTE and keeps H+ ???

    Nexus 5 - has the right stuff radio wise for any North American carrier. EDGE/3G/H+/LTE no worries no matter where or who. Limited only by the speed your carrier offers where you are standing at the moment.
    WP8fan likes this.
    07-01-2014 01:02 PM

Similar Threads

  1. Screen going black while on calls
    By offbeatbop in forum Nokia Lumia Icon
    Replies: 10
    Last Post: 06-27-2014, 03:53 PM
  2. what if i have two phones with same microsoft account
    By srikanth reddy4 in forum Ask a Question
    Replies: 11
    Last Post: 06-22-2014, 04:14 PM
  3. how to make hotspot on lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 06-22-2014, 04:37 AM
  4. Question about Nokia Lumia black?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 06-22-2014, 02:53 AM
  5. Problems with Microsoft and Nokia apps on new phone
    By thistlillo in forum Ask a Question
    Replies: 1
    Last Post: 06-22-2014, 02:47 AM
LINK TO POST COPIED TO CLIPBOARD