1. Allen Rhodes's Avatar
    I have not tried to purchase an app to my phone bill after my 8.1 update. I get a message saying "cant complete purchase" and a further message regarding no connection to cellular. Ive tried via cell and wifi on both, no go. Called AT&T and they said app purchasing to bill is activated. Any ideas? One phone is on Dev and the other is the standard release. Both are up to date respectively.
    09-21-2014 03:15 PM
  2. Allen Rhodes's Avatar
    Really.... Nothing?
    09-22-2014 11:32 PM
  3. Laura Knotek's Avatar
    I've had that happen a couple times over the past several years. Whenever it's happened, I've just done a soft reset or waited a couple days. I just bought an app (Tweetium subscription in app purchase) using AT&T billing yesterday, and it worked fine.
    Guytronic likes this.
    09-22-2014 11:37 PM
  4. MDMcAtee's Avatar
    I have not tried to purchase an app to my phone bill after my 8.1 update. I get a message saying "cant complete purchase" and a further message regarding no connection to cellular. Ive tried via cell and wifi on both, no go. Called AT&T and they said app purchasing to bill is activated. Any ideas? One phone is on Dev and the other is the standard release. Both are up to date respectively.
    Call Att back and have them check again.

    They have to look at your account further than just 1place. Give them the date of the update and have them look further at the date you've given.

    There is a place where they put a lock on the account if there has been a returned app for a credit from the store that doesn't show up in the normal place they are checking and has to be removed manually by them. Sometimes it gets added even when there has been no credit issued or if there has been a higher than normal return for credits issued.

    It seems their system does this for some reason and is supposed to be taken off when requested but isn't doing it all the time automatically.

    It took me 4 months to finally get it resolved by a USA customer service tech which I specifically asked to speak to. You have to specify that you want to speak to a USA tech when speaking to a overseas tech.

    Hard or soft resets don't work for this issue, nor does deleting the account through Microsoft.

    I had the same issue with my 1520 and switched to a Android m8 and it still persisted on it and finally got to the bottom of it.

    Mine worked fine on my 1520 with the dp up until I asked for a credit 1time.I purchased about 10apps by this way.
    Last edited by MDMcAtee; 09-27-2014 at 05:44 PM.
    Laura Knotek and gahbmwm5 like this.
    09-27-2014 05:33 PM
  5. misterff1's Avatar
    In my experience it won't work when you don't have the official OEM version installed, so the DP phone will not work for that reason. As for the other one...no idea
    09-27-2014 05:36 PM
  6. gahbmwm5's Avatar
    http://answers.microsoft.com/en-us/w...2-7bb1407ad263

    Man, I have tried it all....please see above posted thread...
    Even when flashing via NSRT to:
    OS: 8.10.12393.890-->AT&T OS
    Firmware: 3051.5009.1425.2001-->AT&T 8.1 Cyan
    See attached pic....!
    If you find out any more info, please post here...Thanks!
    09-27-2014 06:05 PM
  7. gahbmwm5's Avatar
    MDMcAfee, this is excellent advice...as this all started to happen after I requested a refund/credit on my account on Sept. 2nd.. Will AT&T right now and report back.. .!
    09-27-2014 06:11 PM
  8. gahbmwm5's Avatar
    Apologies for the 'triple posting' but I'm currently on my Lumia 920 and the WPCentral mobile site is still a challenge with IE11 mobile...
    Just got off the phone with AT&T Tech Level LL support and although she checked in 3 different places on my account...still no success.
    However with the info that I gave her from MDMacAfee---->she certainly understood the troubling issue better.
    A case has been setup up--->sent to the next level and I now have confidence that it will succeed..
    It is a fault/bug....in the AT&T system..somehow still blocking my account (after the automated refund) that I performed via MyAT&TApp on Sept. 2nd ..J will be contacted by this Wed., and will report back...lol
    Quite frustrating to say the least bit I'm sure glad that I found this thread and MDMacAfee advice..doing this through WPCentral app (paid)
    I too have had only 1 .99cent app refund...as Tech Support (even made mention of..)...and also 15-20 apps $$purchased..
    09-27-2014 08:37 PM
  9. Maaz Mansori's Avatar
    In my experience it won't work when you don't have the official OEM version installed, so the DP phone will not work for that reason. As for the other one...no idea
    I have tried on 2 different phones on DP and I'm able to buy apps on my AT&T account just fine.
    09-27-2014 08:56 PM
  10. gahbmwm5's Avatar
    Excellent...thanks for confirming Maaz! As I too had no issues with the first 2 DP installs and AT&T purchases. This all started @Sept. 2nd with the automated refund procedure.. Very frustrating but now I have hope and confidence that my account will be 'back-to-normal' soon...lol
    09-28-2014 08:20 AM
  11. Ed Boland's Avatar
    I've found that it differs from one app to another. In other words, some paid apps I can purchase using carrier billing, others I cannot. I always assumed it was the app developers that have it set up that way. Do they (the devs) have a way to choose which payment methods are accepted for their apps?
    09-28-2014 08:51 AM
  12. gahbmwm5's Avatar
    TT--->John -Product Manager and after reviewing my account it looks like a 30-day refund wait was put on account for the Sept.2nd--->MusicID refund--->This would cause the error message pop-up as I have only had 1 refund.
    He will CB Thurs 10/2 or Fri 10/3…
    If I still get the error, then he will totally re-due my account from start…
    Totally satisified...there will be a rectified solution to this frustrating issue!
    He totally familiar with the pop-up error, and yes they have the ability to put a 'blocker' somewhere in the account....where ATT C.S. and even Tech Support l & ll levels could not view...Since I have had only 1 refund with 8+yrs with them....this was not the case...
    Interesting enough there are @20 Product Managers, who handle elevated cases from both C.S., and Tech Levels l & ll...he doesn't get many calls....as he made mention he had been logged on for 4 hrs and I was his 'first call/case....nice position to have...lol
    Will post up again when successful! lol...
    Last edited by gahbmwm5; 09-29-2014 at 03:30 PM. Reason: added text
    Laura Knotek likes this.
    09-29-2014 03:27 PM
  13. gahbmwm5's Avatar
    A&T Product Manager called me back, he totally re-did my account from scratch...absolutely no blockers anywhere now. He asked if my Windows Live account had the proper billing address for my AT&T account...? Because when you hard reset the device, the Microsoft account will 'pull-all-info' from your mobile account billing setup....
    And when I went to Microsoft account--->customer billing it had an incorrect address...changed it and viola....now able to purchase apps through the Windows Phone store via my AT&T account..finally!
    Strange though this old address had worked fine before.
    Bottom-line....success...lol
    10-04-2014 06:18 PM

Similar Threads

  1. Internet Sharing on ATT WP8.1
    By DiGzNY in forum Nokia Lumia 920
    Replies: 2
    Last Post: 09-22-2014, 05:52 PM
  2. Anyone else decided not to upgrade to 8.1?
    By Bodeanicus in forum Windows Phone 8.1
    Replies: 6
    Last Post: 09-21-2014, 09:21 PM
  3. How can I know the speed of an SD card before buying it?
    By FAHMI BASSEM in forum Ask a Question
    Replies: 5
    Last Post: 09-21-2014, 03:00 PM
  4. Replies: 0
    Last Post: 09-21-2014, 02:55 PM
  5. Windows Phone Wallet could get a big boost with former Amazon Payments leader
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-21-2014, 02:30 PM
LINK TO POST COPIED TO CLIPBOARD