1. ctown25's Avatar
    Hello. I recently bought an unlocked AT&T Nokia Lumia 1520 from eBay with no problems. I work for, and have service with Wal-Mart Family Mobile (powered by T-Mobile) for the cheaper plans. Ever since Wal-Mart upgraded from 3G Only to 4G LTE, I haven't noticed any difference in speeds. I made a few calls to customer support and they ensure me my account is 4G LTE active. One rep told me that 4G and LTE is the same, but I disagree. I experimented with a T-Mobile sim card from my sister and confirmed an LTE indicator after a reboot and that lets me know it's not the phone. I bought an AT&T GoPhone (the 635 actually) and unlocked it using the unlock request method. I know it supports LTE and with that phone I also get only 4G with the WFM sim card. I've seen people who buy the WFM-branded or rather T-Mobile Nokia Lumia 635 get an LTE indicator with no problem and I'm completely lost as to what might be causing me to get only 4G speeds. Anyone with similar experiences or suggestions?
    03-07-2015 02:03 AM
  2. RumoredNow's Avatar
    I've moved this thread to the general Carrier Discussion area as it really is not an AT&T issue.

    Have you asked for a new SIM? Or a reprovision?

    The SIM may not have the authorization on it for LTE since it sounds like you got it under the H+ limit days. I doubt the SIM is too old for LTE (that style SIM should be long out of circulation), but you never know. I good service tech there - not a customer service type - should be able to tell by SIM card #. A tech could also put you in for a reprovision. That is a do-over for the provisioning or carrier side authorizations for what services and levels of service your account is allowed.

    Give 'em a call back and get a ticket opened to have a conversation with a real tech.
    Laura Knotek likes this.
    03-07-2015 09:30 AM
  3. davenc's Avatar
    Since both phones are from at&t they may not support the lte frequencies that tmobile uses in your area.
    03-07-2015 01:35 PM
  4. ctown25's Avatar
    After getting off the phone with a rep, I now realize my 1520 doesn't have the bands compatible with T-Mobile LTE. I believe the 635 has nearly all the frequencies for AT&T and T-Mobile. Disappointing but I didn't do my research. I guess 4G is good enough since I'm around Wi-Fi most of the time anyway.
    03-09-2015 12:41 PM
  5. RumoredNow's Avatar
    After getting off the phone with a rep, I now realize my 1520 doesn't have the bands compatible with T-Mobile LTE. I believe the 635 has nearly all the frequencies for AT&T and T-Mobile. Disappointing but I didn't do my research. I guess 4G is good enough since I'm around Wi-Fi most of the time anyway.
    AT&T 1520 uses LTE Bands 2, 4, 17 (among others)

    T-Mo towers uses LTE Bands 2, 4, 12 (all inclusive listing)

    Band 17 is a subset of Band 12 and fits right inside of it. Band 12 is 700MHz blocks A, B, C and Band 17 is 700MHz blocks B,C. So Band 17 radio works on Band 12 towers. Your AT&T 1520 IS LTE compatible with T-Mo towers and many use it that way. Your 635 is also LTE compatible.

    Someone is selling you a load of goods because they can't trace the issue.

    Did you ask for new SIMS or a reprovision on each number?

    Did you get a technician and not just a customer service rep?
    03-09-2015 05:34 PM

Similar Threads

  1. SO...the M8 WP is FREE on VZW!
    By thecaringkind in forum HTC One (M8) for Windows
    Replies: 6
    Last Post: 05-18-2015, 10:43 PM
  2. Wanna jump back to WP. Should I go with 830 or 930?
    By OndrejBakan in forum Nokia Lumia 930
    Replies: 51
    Last Post: 03-16-2015, 08:10 AM
  3. Store app not available (extra +info) problem
    By mertucar in forum Windows Phone 8.1
    Replies: 3
    Last Post: 03-10-2015, 07:12 AM
  4. HELP me understand why this doesnt work?
    By fletch33 in forum Samsung ATIV SE
    Replies: 2
    Last Post: 03-06-2015, 11:18 PM
  5. Reply button doesn't work.
    By Soon Choi in forum Microsoft Band & Band 2
    Replies: 0
    Last Post: 03-06-2015, 10:28 PM
LINK TO POST COPIED TO CLIPBOARD