1. Farnic's Avatar
    All of a sudden every time I try to text one specific contact I get a text from ATT saying something like "enter valid 10 digit number" and the only way texts will go through I if I delete the thread and start a new one, but as soon as I get a reply text from the contact I can't send until I delete the thread again. Anyone know what to do?
    04-15-2015 06:38 AM
  2. Flytetymex's Avatar
    That started happening to me this morning too.
    04-15-2015 08:41 AM
  3. Flytetymex's Avatar
    I deleted my girlfriends contact and I can text her but when she texts back, a completely different number comes back (that doesn't fit the 10 digit format). Are you on At&t? I am. Not sure what's going on. So for now, you can delete that contact and text the number if you really have to and when a reply comes in, reply to that initial text that you sent (if that makes sense). I was about to hard reset but it seems like maybe that won't solve it. I didn't do anything different last night
    04-15-2015 08:44 AM
  4. fpetro22's Avatar
    Yep that just happened to me this morning
    04-15-2015 08:53 AM
  5. Farnic's Avatar
    It seems that I can't reply to ANY thread that had an incoming text since this started. My only option is to delete and start a new thread every time I want to text. Something is up for sure.
    04-15-2015 09:01 AM
  6. dr_myles's Avatar
    Has anyone figured this out yet or got through to ATT? i called customer service but it says they are under heavy load right now. Other people must be having the same issue.
    04-15-2015 09:38 AM
  7. Flytetymex's Avatar
    According to the following link, AT&T is aware of the issue. So much for that. I just hard reset my phone and the Wifi here at work is molasses. Sigh. How frustrating. Still have the issue though

    https://forums.att.com/t5/Apple/Erro...t/td-p/4214086
    04-15-2015 10:02 AM
  8. sd2015's Avatar
    I'm having the same error message, but mine is to two people, not just one. Will this be fixed soon? I have tried deleting and readding the number to the phone, as well as I deleted everything I could see from and to that number. Still not working. I'm not sure if they're even receiving my texts. VERY FRUSTRATED!! :(
    04-15-2015 10:22 AM
  9. Flytetymex's Avatar
    On my end it seems to be working fine. At least for now. Try it.
    04-15-2015 10:31 AM
  10. ygtgngr's Avatar
    It happened to me too. Now it's fixed I guess...
    04-15-2015 10:37 AM
  11. Jeffrey Biondo's Avatar
    I'm having the same problem on my windows phone 8.1 , I can call the person but I can't text him is there a fix to this?
    06-16-2016 10:35 PM
  12. RumoredNow's Avatar
    I'm having the same problem on my windows phone 8.1 , I can call the person but I can't text him is there a fix to this?
    Welcome to the forum, Jeffrey.

    However, you are bumping a thread that is over a year old and shows it was a carrier side glitch that got resolved. Unlikely that the solution then is the same as now.

    You did say WP 8.1 do thanks for that. Can we get some more details?

    What phone? It is on ATT? Do you have cellular data (internet)? Dual SIM by any chance?

    Have you inspected the APN settings to make sure they haven't changed?
    Use this site to find your country and carrier then use the values they provide: World Wide Mobile Phone Settings Or check the help pages at your Carrier's website.

    WP 8.1: Settings > cellular + SIM > SIM settings > toggle "Manual Internet APN" to ON > tap "edit MMS APN" then input the values into the fields and selecting "save"


    Have you tried powering off > remove SIM and clean > reseat SIM and reboot?

    Have you contacted the carrier?
    06-17-2016 12:12 PM

Similar Threads

  1. Replies: 2
    Last Post: 07-27-2015, 07:35 PM
  2. Why my phone gives error connecting to Microsoft?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 04-25-2015, 08:54 AM
  3. Replies: 7
    Last Post: 04-16-2015, 12:45 PM
  4. Why are my Text Message coming from the wrong contact?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 04-14-2015, 03:03 PM
  5. Replies: 2
    Last Post: 04-14-2015, 07:28 AM
LINK TO POST COPIED TO CLIPBOARD