10-05-2013 12:06 PM
32 12
tools
  1. cae758's Avatar
    The cyan is back in stock on AT&T again still for $150 if anyone is interested. I purchased mine earlier today immediately after seeing it , so as not to miss out on the deal.
    05-14-2013 08:24 PM
  2. justop26's Avatar
    I got the black one on Friday, thinking that it would be a limited-time thing. Thank you for the heads up!
    05-14-2013 10:06 PM
  3. gtbuzz's Avatar
    Has anyone that ordered a Cyan actually gotten theres? I placed the order minutes after the story went live on WPCentral, and still no shipping. I've been told multiple times now that there is insufficient stock to fulfill my order and I'll get an email when it ships. Despite that, they still seem to be taking orders.

    I swear, AT&T is one of the most frustrating companies out there. Past 3 orders with them, Cyan L900, Yellow L920 and now this, have had the exact same thing happen. They take my order, but suddenly I get this low stock excuse despite the fact that they're still willing to take orders on the website. Eventually I end up getting it in a week or two, but it's very frustrating that they take this approach towards inventory management / customer service. Oh yeah, and in the past I didn't actually receive the shipment notification until after I got my item. Great job....
    05-15-2013 11:15 AM
  4. MikadoWu's Avatar
    I ordered 2 units by 7am the day the price changed. I then purchased a 3rd unit 5 days later after I received the first 2. The 3rd nit came in 3 days later. All of them are Cyan.
    05-25-2013 11:17 AM
  5. Res215dg's Avatar
    Just picked one up from At&T's site- Anxious to try this out on my new Lumia 920 :)
    07-01-2013 01:26 AM
  6. Norbert Sabic's Avatar
    Hi, I have a JBL PowerUp charging speaker for half a year now, and I was wondering if anybody ever used the micro-USB connector on it. Was there any software update?
    09-23-2013 09:48 AM
  7. Bora777's Avatar
    I was wondering if any other PowerUp owners have issues with the capacitive controls on the speaker. Mine inevitably stop working after a certain amount of time (maybe a couple of hours or so of playback) and the only way to restore them is by shutting off power to the speakers and back on again.
    10-05-2013 12:06 PM
32 12
LINK TO POST COPIED TO CLIPBOARD