1. Sosinondodrore's Avatar
    When the light fades up and down when notifying me that the battery is low, the light blinks when faded down like shown in the video linked below. When testing the fading via Device Hub, it doesn't blink the first times, but after it has faded maybe 3-4 times it starts blinking again when faded down.

    Is this a defect or is it supposed to blink? Have anyone else experienced this with their DT-903?

    Video:
    03-02-2015 03:46 PM
  2. Likwidz's Avatar
    You using a 930 with it? I can't get mine to work with my 930. I've gotten a 830 and 1520 to pair with it no problems, but can't get the damn 930 to work with it.
    03-02-2015 04:14 PM
  3. Sosinondodrore's Avatar
    Works perfectly with my 930. Tried to pair it with NFC?
    03-02-2015 06:14 PM
  4. Likwidz's Avatar
    Yeah, the NFC tag sees it then it after a few seconds I get a Bluetooth connection error.
    03-02-2015 06:32 PM
  5. Sosinondodrore's Avatar
    Strange, but could you reply to my original post? Do you experience this with your DT-903?
    03-02-2015 07:12 PM
  6. Sosinondodrore's Avatar
    Btw, have you tried a hard reset (factory reset) of the phone? Or a soft reset (volume+power for 10sec)?
    03-02-2015 07:14 PM
  7. Likwidz's Avatar
    Are you referring to the quick pulses of light before the long flashes? Off the top of my head I don't remember it doing that, I'll have to check it when I go into work.
    03-02-2015 07:31 PM
  8. zkyevolved's Avatar
    I had it with the 930 fine, couldn't get my 1520 to pair. I pressed and held the button on the bottom until it did something and then I repressed the NFC part of my phone to the base and it connected that time. Hope this helps!
    Likwidz likes this.
    03-06-2015 07:33 AM
  9. Likwidz's Avatar
    I had it with the 930 fine, couldn't get my 1520 to pair. I pressed and held the button on the bottom until it did something and then I repressed the NFC part of my phone to the base and it connected that time. Hope this helps!
    Hey thanks bro...that fixed my issue. I completely forgot there was that multi-function button at the bottom.
    03-06-2015 09:27 PM
  10. zkyevolved's Avatar
    Hey thanks bro...that fixed my issue. I completely forgot there was that multi-function button at the bottom.

    My pleasure. It seems you have to reset the 903 every time you want to pair it to a new device.
    03-07-2015 01:30 AM

Similar Threads

  1. When will I get the update Windows 8.1 update 1?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-30-2018, 12:02 PM
  2. Why does my volume decrease to zero when I insert my headphones?
    By Windows Central Question in forum Ask a Question
    Replies: 6
    Last Post: 07-21-2016, 03:08 AM
  3. Contacts disappear when edited?
    By PepperdotNet in forum Windows Phone 8.1
    Replies: 1
    Last Post: 03-12-2015, 10:52 AM
  4. Replies: 3
    Last Post: 03-02-2015, 06:07 PM
  5. T-Mobile shows its version of the Lumia 640 in new video
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-02-2015, 12:30 PM
LINK TO POST COPIED TO CLIPBOARD