1. DotNetRob's Avatar
    My band isn't recognized by my pc or surface anymore. When I plug it into the usb port, it charges but the Microsoft band software doesn't detect the device connected. Tried with two different charge/sync cables with no luck. Cleaned the metal connectors on the band but still no luck.

    Updated the software to 1.1.1106.2 but still no luck.
    11-08-2014 10:56 PM
  2. Karpito's Avatar
    Hi,
    I'm experiencing the exact same problem now. Were you able to find a solution?
    11-17-2014 11:03 AM
  3. DotNetRob's Avatar
    Hi,
    I'm experiencing the exact same problem now. Were you able to find a solution?
    No Unfortunately it comes and goes, after I posted this on 11/8 I took my band to the Microsoft Store, which said they would replace it when more came in.

    ​On 11/10 it suddenly started working again, would sync via the cable on both my pc and surface. But it stopped working again yesterday 11/16, have restarted the band, my pc and the surface but it doesn't change he outcome. The band charges but the pc/tablet doesn't detect anything is plugged in, so no sync occurs. Has to be something band related since it occurs both my both and tablet and with two different cables.
    11-17-2014 11:09 AM
  4. DroidUser42's Avatar
    Another thread suggests that USB3 ports can be flaky. I know I've had problems at work with some USB3 ports for other devices. They work fine, then one day it won't see it. I have to move the device to another port.
    11-17-2014 12:35 PM
  5. Karpito's Avatar
    I tried all 5 usb ports in my pc. None of them will let it sync...
    11-17-2014 01:41 PM
  6. DotNetRob's Avatar
    Just to Update my Thread, Microsoft store held a replacement for me in the latest batch. Took my band in to exchange it and they couldn't get a pc in the store to recognize the device either, it would charge but the pc wouldn't detect the device. Even tried restarting the band with no luck. So they exchanged my band. My new Band synced with both my pc and surface with no problem, on the first try...
    11-21-2014 02:27 PM
  7. hysonmb's Avatar
    I'm having this exact same issue. Might as well give the store a call later :(.
    At least it still functions properly so there's no rush to replace it yet.
    11-26-2014 02:59 AM

Similar Threads

  1. My wife's band died today.
    By ytrewq in forum Connected Living
    Replies: 16
    Last Post: 05-21-2015, 12:27 PM
  2. Where can I buy a Microsoft Band in Washington, D.C.?
    By tanayprasad in forum Ask a Question
    Replies: 6
    Last Post: 03-13-2015, 10:29 PM
  3. Will Cortana's speech work in the US with the UK speech setting?
    By Windows Central Question in forum Ask a Question
    Replies: 8
    Last Post: 01-06-2015, 02:18 PM
  4. Issue with weather tile
    By drobin59 in forum Connected Living
    Replies: 3
    Last Post: 11-13-2014, 02:35 PM
  5. Any news on Cyan/8.1 update for Metro pcs 521?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-09-2014, 08:21 AM
LINK TO POST COPIED TO CLIPBOARD