1. Brett Sanderson1's Avatar
    Anyone have their WiFi working in this build? I got my wifi working in the previous windows 10 builds but cant seem to get it to work with this one.
    04-30-2015 07:13 PM
  2. nansama's Avatar
    Hi Go to dell site and download and install network drivers for dell venue 8 pro.

    My DV8P with build 10074 is working fine with WIFI.

    3G... not yet.
    05-04-2015 05:55 AM
  3. bigeduck's Avatar
    Yeah, I had to uninstall and reinstall the driver from Dell.
    Also of note, if you're going to run Windows 10 Beta, .... get the OTG cable and a usb hub.... you're more than likely going to be reinstalling windows at some point when the startup bricks.
    waazzupppp likes this.
    05-04-2015 08:28 AM
  4. waazzupppp's Avatar
    I already needed the OTG cable for hooking a keyboard to it when it failed to bring up the touch screen keyboard at unlock... A bit of an issue there if you ask me. I did finally pull the plug and do a full clean install of 10074 and so far - it's been flawless. So far...
    05-13-2015 04:53 PM
  5. jdballard's Avatar
    I did finally pull the plug and do a full clean install of 10074 and so far - it's been flawless. So far...
    Is 10074 still running flawlessly? Considering it...
    05-28-2015 12:39 PM
  6. Brett Sanderson's Avatar
    Is 10074 still running flawlessly? Considering it...
    My wife screwed mine up by logging into a guest account. Can't get the keyboard to pop up / get into my other account. Too lazy to unpack my USB stuff so I'm going to wait a couple builds before i install again. It keeps uninstalling my BETA drivers on my desktop which is quite annoying because they are needed for GTA 5.
    06-01-2015 07:26 PM
  7. jdballard's Avatar
    I went ahead an upgraded (not a clean install) from Windows 8 to 10. I didn't need a keyboard or mouse - the existing drivers seem to work just fine while upgrading. It's running well but I wouldn't say it's amazing. It's about where I'd expect it to be at this point in the cycle. Here are the issues I've seen:


    • Battery life is OK when running but when it goes to standby, the battery is dead hours later. For example, this morning when I left for work the battery was about 80%. Came home? Dead. I tried the setting to not have wifi on when in standby, but it doesn't make a difference. I need to poke around the settings to see if I can find something else to try.
    • "Project Spartan"/Edge works fairly well. It tends to freeze from time to time when pressing and holding links to "open in new tab". It does seem to render pages pretty quickly, though.
    • When opening a link in Edge from Tweetium or NextGen Reader into a split screen, there's an awful flicker. Pressing and holding on the opening app helps, but not always. Assuming that this is not a Tweetium or Nextgen Reader issue.
    • Occasionally the start screen restarts. Reminds me of when explorer.exe on the desktop restarts.
    • You can't use a PIN to log on. I've set it to not require a password since mine is so long. Seen other reports of this, some with fixes, some without. I guess it's a known issue.
    • I've had a few issues resizing and moving tiles. One time, I had a tile get "stuck" and it bled through every app. Had to restart to clear it.


    Despite the above, it's actually pretty good. I haven't really tried the Music Preview app. Haven't tried it in non-tablet mode, much, either. I will say that after having read lots of complaints (in the comments on a story on thurrott.com) about the taskbar always being visible in tablet mode, I thought I'd hate it but I actually really like it. It's not distracting or bothersome at all and is actually useful. That's one reason I don't get worked up over changes in new versions until I try things because sometimes the idea sounds bad but the reality is better.

    If you're willing to put up with a few annoyances, I'd say go for it. Keep in mind that my usage of it is fairly limited. I mostly use it to read Facebook, Nextgen Reader for my RSS feeds, Tweetium for twitter, some browsing and short emails, so YMMV.
    Jazmac likes this.
    06-02-2015 12:45 AM
  8. r0ninX's Avatar
    Bit the bullet last night and installed Windows 10 TP on my Venue 8 Pro. Took way longer than it should have due to my own stupidity but after figuring out what I was doing wrong got it working. I have build 10130 and had downloaded all the Dell drivers onto my SD card prior. I did a fresh install and it worked flawlessly. I didn't need to install any of the drivers during the initial install ( I have had to install wifi drivers today after it shut down and my bluetooth doesn't work correctly yet....working on it) but overall I LOVE this OS. Cortana is awesome, Spartan (Edge) is a solid browser. Pretty much this may be my favorite version of Windows so far.....and it's free. Win-Windows.
    06-23-2015 08:52 PM

Similar Threads

  1. build 10074 install on hp stream 8 success!
    By brad4560 in forum HP Stream 8
    Replies: 1
    Last Post: 05-23-2015, 11:09 AM
  2. delayed updated info on runkeeper
    By 11B1P in forum Microsoft Band & Band 2
    Replies: 1
    Last Post: 05-01-2015, 04:35 AM
  3. Replies: 2
    Last Post: 04-30-2015, 07:49 PM
  4. ,Is the Nokia Lumia 1520 compatible with the Windows 10 OS?
    By WPCentral Question in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 04-30-2015, 07:48 PM
  5. Follow the NFL Draft on the Xbox One app starting tonight
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-30-2015, 06:11 PM
LINK TO POST COPIED TO CLIPBOARD