1. simzzdev's Avatar
    So I know this is one of the most common issues with the Dell Venue 8 Pro, but my device stopped charging and since the battery's dead, I have no idea how to get it to turn on. This is the second time it's happened to me. After reading 50+ forum threads about this issue that offered no real solution, naturally I decided to create my own. I've tried all the obvious stuff (trying multiple chargers, including the OEM charger, all with high enough amperage, pushing various button combinations and giving it time).

    It's a common issue for this tablet's charging port to actually break, so that's what usually is the culprit here. Unfortunately that means nothing to me because I've had this tablet just 3 months past the end of my warranty and no, Dell, I will not pay $269.99 for you to service it out-of-warranty. Because their design of the tablet placed in it a micro USB-A type connector (square) rather than the type-B (trapezoid, like a phone charger) connector it's common for people to plug it in backwards and break it in the process. [the Dell OEM cable is type-B, so it fits, but could go in backwards] Well my tablet had this issue happen just 3 weeks ago and I believed that that was what had happened, so I opted to go with the non-guaranteed eBay repair for $30, because why not?

    What that service did was replace the "bad charging port" with their own new one ( a type-B connector), which would hopefully enable my tablet to charge again, and also prevent me from ever making a dumb mistake like plugging in the cord backwards again. Well when I got it back, it did not charge still, but at least the battery had been charged for me. I was able to turn it on and update my BIOS (another common solution from other peoples' threads, which of course I could only do while I had charge in my battery) and just like that it charged again!

    A week or so later the same thing happens again. Only this time I am 100% sure I did not stick the charger in backwards, seeing as how that'd be impossible with the right shape of charging port in place at this point. So since I'm pretty sure I didn't break the charging port physically, does anyone have a clue what I could try to do to this brick of a tablet to get it to turn on or charge again?

    Sorry for the overly long message, but I was trying to be detailed. I've emailed the eBay seller to see if they had a magically process to get it to charge. I've tried everything else I've read online but it just doesn't recognize that it's being plugged in.

    Any response would be appreciated.

    Thanks,
    Johnny



    UPDATE:

    Well I guess I fixed it. I'll leave this up in case it's of any help to anyone else, I've heard about plenty of DV8P issues so maybe someone else had this happen to them. Anyways, the issue ended up just being my battery. Buying a new one and swapping it out fixed the issue.
    Last edited by simzzdev; 07-07-2015 at 02:24 AM.
    WINO0314 likes this.
    06-28-2015 09:14 PM

Similar Threads

  1. Why is my Cellular data not active anymore after update?
    By john Hmar mawi in forum Windows 10 Mobile Insider Preview
    Replies: 7
    Last Post: 06-29-2015, 05:52 AM
  2. Why aren't I getting SMS messages?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-28-2015, 06:51 PM
  3. Replies: 1
    Last Post: 06-28-2015, 06:29 PM
  4. [L730] Voice mail not showing up?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-28-2015, 05:40 PM
  5. Replies: 0
    Last Post: 06-28-2015, 02:23 PM
LINK TO POST COPIED TO CLIPBOARD