The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Aware's Avatar
    So my RedFly arrived today. Yippee.

    First impressions - very nice - like the texture - almost feels like rubber.
    Keyboard really is small isn't it? But not so small as my BlackJack :-)
    Whole unit seems awfully big for the size of the screen.
    Seems heavier than I would like.

    BlueTooth pairing works well. There's something tingly about leaving my phone over there <pointling pointlessly because you can't see the phone from where you are sitting ...> and interacting with it. Even more tingly is inserting a USB memory stick into the RedFly, then browsing to it in file explorer, soI can launch a pdf or PowerPoint file. Hyperlinks out to the web work fro PowerPoint too - although be sure to link to a mobile friendly page :-)

    I installed RDP cab files to restore the remote desktop feature removed by Microsoft. Works fine. Don't like that it limits me to 640x480. Don't like that it limits me to 8-bit colour (though that's sensible since I'm only getting EDGE connection where I'm testing). Wouldn't want to use this for anything other than an extreme emergency. Still want to see if I can find a way to force LogMeIn to work. No joy so far.

    **Now the bad** - USB pairing is not working. Well it is - but only for 1 to 15 seconds at a time. It seems to be in a constant connect/disconnect loop. I managed, with a lot of patience, to set up BlueTooth pairing, so I can at least use the RedFly but I'm expecting to see faster response if I can ever get USB to work ... plus I know I'll want to be able to charge up my phone on-the-go. I put an email in to tech support to see if they have a fix, but I have a suspicion this one is going back ...
    10-28-2008 01:51 PM
  2. JohnH59's Avatar
    My BT actually pairs faster than my USB and it stays paired.
    10-28-2008 02:02 PM
  3. cglaguna#WP's Avatar
    did u try resetting the phone?
    10-28-2008 02:11 PM
  4. Aware's Avatar
    did u try resetting the phone?

    Yes. Several times.
    Also tried turning RedFly on/off.
    Tried turning both on/off together.
    Tried restarting phone connected and disconnected from RedFly.
    Tried RedFly connected to mains and not.

    Tried a lot of other things. It took a couple o fhours or so to get to the point where I could Bluetoth pair. Don't think I could list all I tried (various phone settings, removing installed software etc.). Let's just say I tried stuff :-)

    But if you have a suggestion that you think might not have occured to me, I'll happily try it.
    10-28-2008 02:30 PM
  5. Ebag333's Avatar
    Hard reset.


    (Come on! All the cool kids are doing it! :D )
    10-28-2008 03:54 PM
  6. Aware's Avatar
    Well - unless you mean did I reflash my phone, I did every kind of reset I know about ;-)
    10-28-2008 04:30 PM
  7. hitch's Avatar
    I'm not sure if the BJ has the same connection options as my Tilt. I need to make sure that the check is in the box for "enable advanced network functionally" under usb connections for the Redfly to work using usb. I usually have it turned off so I can use wm5torage, if it is on, the program will not work. I'm with the others, bt works great, just no charging.
    10-28-2008 05:51 PM
  8. ckj's Avatar
    Aware, 3 things...

    1) In general, remote access clients don't work well (or at all) with or without the REDFLY when using a non-touchscreen phone like the Blackjack. I'll go see if I can test some remote access apps on a BJII (I don't have access to a I right now) and post back here. Remote access apps work very well on a touchscreen WM phone however.

    2) I'm not sure what RDP client you are using, but go to this link and you'll find an RDP client .cab that works very well. Each time after you launch the app (before you click "connect") go into the options and make sure that you ...

    Set the colors to "High Color (16bit)"
    Check the "Full screen" box
    Check the "Fit remote desktop to screen" box

    If you do this, you'll automatically get your remote desktop full screen (even no WM title bars) and it will run at 800x480. This client has a bug, where it will remember your username etc. settings, but it will forget to run at full screen often and as I said above, you have to go into the "options" each time before connecting. Overall, it's a great experience once its working.

    3) Which model of BlackJack are you using and on which carrier? I'll check into the USB problem for you.
    10-28-2008 06:23 PM
  9. Aware's Avatar
    Aware, 3 things...
    2) I'm not sure what RDP client you are using, but ...

    3) Which model of BlackJack are you using and on which carrier? I'll check into the USB problem for you.
    Thanks!

    I am using the client you suggested. Silly dumba$$ me didn't spot the Options ... I'll test that right now.

    BlackJack II, WM 6.1, ATT.
    10-28-2008 08:36 PM
  10. Aware's Avatar
    cool. I just linked up to my phone and retried remote desktop. Seems to work perfectly using your suggested settings. So good, Im posting this via RedFly, using Rdp to connect to my Vista laptop. OK the laptops only 15 feet away. The phone is 20 feet away Lol.
    Seems I have some encoding issues following character should be a dash, but comes out as half .
    10-28-2008 08:51 PM
  11. ckj's Avatar
    Aware, you may want to contact our support line about the USB connection problem. I’ve only spent maybe 6 hours total with the BlackJackII on 6.1 over the last few weeks, but I’ve connected/disconnect it at least 50 times with a USB cable and haven’t had any problems, it connects perfectly every time.
    By the way, I spent an hour or so last night testing RDP and Citrix on an AT&T BlackJackII with WM6.1 and was able to get it to work as you did. However, it wasn’t the best experience. RDP and Citrix run great on touchscreen phones, but not well (or at all) on non-touchscreen phones.

    I couldn’t get the Citrix ICA client to install at all on the BlackJackII.

    The BlackJackII with WM6.1 does seem to work on RDP as Aware discovered, but I had some problems.

    There are two .cabs floating around out there, an old but very stable “finster” version located here, and a new 6.1 version located here.

    The 6.1 version functions very well on the BlackJackII with one BIG exception. The client won’t accept mouse movements or clicks from the REDFLY or an external mouse connected to REDFLY (as you’d expect with a non-touchscreen phone in general since they don’t handle mouse input well). So you have to switch the REDFLY over to the 5-way nav mode (click here for explanation) and use the nav buttons to nudge the host Windows desktop’s cursor ever so slowly almost in a pixel-by-pixel fashion. It takes 5 to 10 seconds just to move the mouse from one side of the desktop to the other and absolutely destroys any productivity.

    The “finster” version of RDP installs and actually lets you use the REDFLY touchpad as a real mouse to control your host Windows desktop’s cursor. The one big problem I had with this .cab is that before you connect, if you try to set up the options, about 9 out of 10 times, I couldn’t get back to the main connection window to actually connect. I’m guessing that’s because the “options” tab is expecting an “ok” command and there’s no “OK” on the BlackJackII.

    Anyway, bottom line for anyone out there, you may be able to get RDP to work on a BlackJack, but you’re better off using a touchscreen phone if you really need to connect often to get work done.

    Aware, did you have any more luck than I did getting your BJII to connect in full screen and 16-bit color without having to change the “options” all the time?
    10-29-2008 05:13 PM
  12. Aware's Avatar
    Colin,

    I've already been chatting with Support over the USB connect issue. We've tried different drivers with no effect. If it may help, I've been deaing with Troy Beagly. [update. We gave up. I'm returning the device this morning for an exchange unit.]

    I had the same issue you did with connecting after setting options. I found that pressing Enter key solves it. I think (maybe) I had to change focus to the tab (screen/audio? tabs) then press enter. This works reliably. Frankly I'm shocked at how well remote desktop works over an EDGE connection.

    The single biggest issue I had was while typing - any non-numeric or alpha keypresses showed up as something unexpected, a dash was the half symbol (1/2) an apostrophe was some Greek symbol etc. I can live with that if I really have to - I know how to get Character Map up - in fact it's pinned to my start bar.

    Oh speaking of which, my start bar is too tall to fit into RedFly's 480 tall pixel screen. Any remote access option that enables an oversized screen that I can scroll around would be nice. If I can scroll around a 1024x768 or larger creen, I can live with a perfomance loss so I can use my development tools in an emergency (Flex, Flash, PhotoShop etc. etc.).
    Last edited by Aware; 10-31-2008 at 06:24 AM.
    10-29-2008 07:22 PM
  13. Aware's Avatar
    Just to close out the USB connect issue I had -

    I got a replacement RedFly this morning. Connected 1st time. No connect/disconnect loop. Seems to be working just fine, so I guess the original one had some sort of fault.

    Happy now :-)
    11-05-2008 11:06 AM
LINK TO POST COPIED TO CLIPBOARD