The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. CleveS's Avatar
    I've seen this mentioned, but I thought I'd start a new thread. I have a Sprint Touch Pro (CDMA) & was pretty happy with the new beta drivers, until I couldn't make a phone call! The phone dials & connects, but there's no audio! I can hear the carrier hiss, but that's it. I can't hear anybody & nobody can hear me. That's bad enough, but a soft reset doesn't fix it. I have been able to get it working by removing the battery for a minute, maybe powering off would have done it too.

    I don't use the phone much for voice so I have not been able to determine if there's any kind of pattern. I will say this, it never happened before I installed the RedFly drivers, & it hasn't happened since I did a hard reset & didn't reinstall the new drivers.

    When I first installed the new beta drivers everything worked great. Then I started getting ARM11 errors & I think that's when I started having the phone problem. I did a hard reset & installed a few basic programs. I don't use TouchFlo & I quit using SPB Mobile Shell. I still had ARM11 errors and the phone problem.

    Anybody else have this problem? Any ideas how to fix it? As it stands now I'm waiting for the next driver update for my Touch Pro. I sure hope they work, otherwise goodby RedFly.
    03-08-2009 07:26 PM
  2. ckj's Avatar
    cleves,
    You don't have enough posts yet for me to contact you via the forum so for now, call the main support line at 1-888-4REDFLY and ask to have your issue escalated up the support chain to a top-tier support guy named Troy.

    And/or when you have 5 posts on the forum, send me your contact info and I'll have someone contact you.
    03-10-2009 12:37 PM
  3. markda2000's Avatar
    I have had a similar problem when I used the latest beta 11 feb 09 with my second phone the htc kaiser, The phone no longer gets voice signal and cannot receive or send sms, bizarly data still works although only 2g.

    A hard reset has not fixed this.
    03-10-2009 05:12 PM
  4. ckj's Avatar
    Thanks for the feedback markda2000, I've only tried 93 on a few Tilts, but our testing team has a few unlocked TyTN II units and they are testing build 93 now. Please send me your contact info and I'll have someone reach out to you. Or you can call the 1-888-4REDFLY support number and ask to be bumped up to Troy as well. Make sure to tell him a) the exact phone model and carrier, and b) if you are using a cooked ROM or an officially released ROM.
    03-10-2009 06:05 PM
  5. CleveS's Avatar
    Colin, thanks for the attention. I have a full day tomorrow, I'll give Troy a call Thursday.
    03-10-2009 06:06 PM
  6. dsteinschneider#AC's Avatar
    I ran into this on my unlocked VZW Touch Pro running Scott Crosler's SSK ROM. It installed and worked great for a couple of days. Then (after installing a bunch of other software) I started getting the arm errors and the issue with the phone volume. All I did to fix it was uninstall Redfly beta 93, soft reset and reinstall the same beta. Been running for days since with zero problems.

    One of the software progs I installed was the latest update to SPB Mobile Shell. I don't run Touch Flo at all - Just Mobile Shell.
    Last edited by dsteinschneider; 03-16-2009 at 09:19 PM. Reason: Forgot to mention software I'm running
    03-16-2009 09:17 PM
  7. CleveS's Avatar
    I just installed the latest beta drivers, 147. So far it's been good.
    03-19-2009 07:48 PM
  8. leatherlips's Avatar
    I'm also having the phone issue. This started happening after a couple of days of it working with the last beta, and today's production release. (verizon touch pro, I don't use touchflo either).

    Here's some things I noticed:
    Attachment 18320
    This pic is of the strange icon that appears when attached to the redfly.

    Attachment 18321
    You can see here that the connection for phone is down. BUT data is good.

    Attachment 18322
    This one is just a screen that appears when I plug the redfly to the touch pro. I can't remember if this screen was coming on when things were working properly.

    Have any of you other folks found the solution?

    I will try what dsteinschneider did (remove, then reinstall drivers for redfly).
    04-01-2009 07:32 PM
  9. CleveS's Avatar
    Leatherlips,

    I've noticed that icon sometimes, but it always went away, so I never thought anything of it. I've not never lost the phone connection, just couldn't hear anything. BTW, that seems to be fixed now. The last picture is normal. That's a feature added by HTC which allows you to connect to the storage card as if it was a flash drive.
    04-01-2009 09:19 PM
  10. anon159272's Avatar
    I mentioned that no service icon in a post maybe 1-2 weeks ago on a stock Sprint Touch Pro. Disappointed it wasn't fixed in the production release.

    Edit: I just installed 163, was connected for a few minutes, and I just started seeing the no service icon.

    Edit 2: I can confirm that this actually breaks the functionality of the phone. The phone dialer will not come up, the home screen says "no service" (after I disconnect the Redfly) and I cannot dial a phone number from the dial history. After a soft reset, I get:
    ARM11 FATAL ERROR
    oncrpcxdr_std.c line 542
    Capture dumps?

    Then

    ARM11 FATAL ERROR
    oncrpc_xprtrtr.c line 674
    Capture dumps?

    Sprint Touch Pro. I have .Net CF 3.5 installed, because I require it for a couple of apps...maybe that's the source of the problem.

    Gosh I wish this worked.
    Last edited by haus; 04-02-2009 at 11:59 PM.
    04-02-2009 11:10 PM
  11. leatherlips's Avatar
    I contacted redFly support. They got back with me immediately. Here's their reply:
    Thank you for your email and support for the REDFLY Mobile Companion. We greatly appreciate your business!
    I believe I know what the problem is. Currently the SPB Mobile Shell is not supported. We have found application errors, Resolution issues, Performance issues, and lockups when using this application series.
    My suggestion is to uninstall the SPB applications and retry the phone and making a phone call. This should correct the problem. If is does not correct the problem, please let me know and I will try again.


    I removed the Mobile shell and still had the issue (occurred after about 5 min. of playing with the apps on the phone). I had installed another 3rd party app called AEButton Plus.
    I removed this one, and tried again. This time I did not get the failure for 30 or so min. I tried a couple of more times for short periods, and still cannot get it to fail. I will continue to work with the Redfly and see if I get any further failures. So far so good!
    04-03-2009 08:14 AM
  12. anon159272's Avatar
    Thanks - you're right, AE Button plus removal seems to fix the phone issue. What a strange 3rd party software interaction! Great catch, leatherlips.
    04-04-2009 12:15 PM
  13. leatherlips's Avatar
    Good deal Haus. I haven't had another occurance since the AEbutton removal either so I'm thinking I'm good to go. I may try to re-install the Spb Mobile Shell again to see if it works out with Redfly. I'll just install one app at a time and test from now on so I don't end up stumped again.
    04-04-2009 02:33 PM
  14. jwebb56's Avatar
    I have AE Button Plus installed on my EPIX and do not have any compatibility issues with Redfly drivers. Strange how things can be so phone specific.
    04-04-2009 03:30 PM
  15. bliipfert's Avatar
    I have had the phone issue running a cleanly installed sprint touch diamond with no third party apps. I can dial but lose all sound. I also have had an issue with an apparent corruption of the dialer.
    04-16-2009 07:36 PM
LINK TO POST COPIED TO CLIPBOARD