1. phildro's Avatar
    I've been reluctant to post my latest findings here, since I can't *exactly* associate this problem to the driver...but...

    I get a lot of stack traces when my TP starts up, and the bluetooth stack gets corrupted pretty easily. Often times, my bt can't connect to my car or my Jawbone headset until I reboot the phone.

    I also no longer have a BT icon on the screen. I have to go into the networking application to turn BT on and off now. I have been reluctant to wipe the device clean and try a fresh install because the resync process is so painful, but I may have to do it soon.

    Has anyone else noticed irregularities around BT and voice?

    The final comment is the connectivity issues. I would say that I get a connection that works 50% of the time when its wired, and 30% of the time when its BT. A phone reboot usually fixes the problem, but its really lowered my adoption of the unit.

    I wish I could think of the Redfly as an appliance that ALWAYS WORKS, but at this point, it is a science project that is very unreliable.

    Please give us a reliable driver for the next round.
    03-31-2009 09:13 AM
  2. cplush#WP's Avatar
    are you on a vzw touch pro? im looking to get one..but not if its incompatible with the 'fly...
    03-31-2009 09:20 AM
  3. phildro's Avatar
    i have a Sprint TP. I don't want to dissuade you from a purchase. I think the driver behavior varies for each device, but they are (hopefully) going to release a production quality driver in the near future.

    i just want it to happen sooner or later so I can use the combo consistently.

    i use the Fly to take notes in meetings while I'm presenting from my lapto, so its not an option to ask a roomful of prospects to wait while I reboot!
    Last edited by phildro; 03-31-2009 at 02:34 PM.
    03-31-2009 01:06 PM
  4. cplush#WP's Avatar
    yeah no joke. thats one way to bomb a sales pitch LOL
    03-31-2009 02:01 PM
  5. mknollman's Avatar
    I too have had issues recently with my TP and the last 2 drivers - 93 & 147. I agree that this needs works, but remember Celio calls our driver beta for a reason - it is not ready for prime time yet. I am still able to be functional, but have no BT connectibility at all.
    03-31-2009 05:22 PM
  6. laurieny's Avatar
    Phildro and mknollman,

    We just posted a released version for the Touch Pro phones tonight - build 163. We will continue to work with HTC on improving the TouchFLO interaction, but we think this build is quite stable now. And, we are not seeing any Bluetooth connection issues - but for that matter we saw very few connectivity issues with build 147. If you are still having BT problems it is much more likely that there is a hardware problem (ignoring that you may have some custom ROM that is misbehaving) with either the Bluetooth radio on your phone or the one on the REDFLY. If you can pair your phone to another Bluetooth device a few times without issue, then I am willing to see about exchanging your REDFLYs to see if that is your problem - though that would be rare and kind of a strange coincidence. Please send me email and we can discuss this further.

    Thanks,
    Laurie

    Director of Engineering
    Celio Corp | REDFLY
    03-31-2009 11:15 PM
  7. phildro's Avatar
    Wow- I can't believe we have a production driver! I just installed it, and did some non-scientific testing...basically I would connect/disconnect wired and those connections seemed very stable. I then connected/disconnected bluetooth and those connections seemed *pretty* stable.

    A couple of times, I got the bluetooth error, but the good news is that I was able to connect a few seconds later without rebooting the phone. I also have not seen any stack traces yet, but those only become obvious over a longer period of time.

    I'll have a chance to test the voice bluetooth stack a little later today when I'm in the car. So far, this is looking very good.

    Thanks Laurie and team!
    04-01-2009 08:05 AM
  8. phildro's Avatar
    After some more testing, I had to disable and re-enable Bluetooth to connect to the Microsoft Sync system in my car. After doing that, hands free voice worked fine.

    Now that I'm home again, the BT had some problems connecting to the phone. I tried several times, and was left with the message "The phone was busy and could not connect. Wait a few seconds and try again."

    Now I tried to connect a third time, and I have a white mouse pointer on the redfly but no picture. I'm sure everything will return to normal when I reboot. I also noticed that the TouchFLO was enabled but not visible after disconnects. So I manually had to go into the Today settings and disable/reenable TouchFlo to get it working again.

    Now I tried connecting with the cable and I also get the pointer on the screen but no picture. I can press hotkeys on the Fly and see the screen change on the phone.

    I'll try a clean install when i get a chance and see whether the behavior changes at all.

    It would be helpful if anyone with a Sprint Touch pro could corroborate any of this behavior.
    04-01-2009 04:00 PM
  9. CleveS's Avatar
    Phildro,

    I have a Sprint Touch Pro & I agree there's some funny stuff going on with the Bluetooth icon. Once I was connected via BT and noticed there was no icon when I disconnected, but Bluetooth was on in Comm Manager. Another time I ended the BT session by turning off BT from within REDFLY. When I looked at my phone the icon was still there, but it was off in Comm Manager. this is with the latest, non-beta, drivers. I never noticed this before, but I had sort given up on Bluetooth. Other than that it seems to be working much better, so far.

    I don't use TouchFLO, so I can't help you there.
    04-01-2009 07:44 PM
  10. phildro's Avatar
    So I took the plunge and wiped all the data from my phone and started over with a fresh install of the new GA driver. I can report that the bluetooth icon has returned, along with the thumbable status screen to get into the various networking settings, answer email or text and so forth. This has been gone from my phone for so long that I had forgotten it ever existed.

    So, the connection seems even more stable now and I bet that all of the beta upgrades over the last couple of months must have corrupted something in the stack along the way.

    Now that we're on a GA-level driver, I would suggest to anyone that they start fresh and clean to avoid any frustrating problems. I'll work with the 'Fly for a few days and then post my findings.
    04-01-2009 09:19 PM
LINK TO POST COPIED TO CLIPBOARD