The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Velvis's Avatar
    I really like the rhodium enhancements some of the custom roms have but all the ones I have tried wont allow me to setup the redfly with bluetooth. (It always says bluetooth must be on to authorize device, regardless of bluetooth being on.)

    Is there a rhodium based rom that will work with the redfly via bluetooth? or is there another way around this?

    Thanks!

    ( I understand it isnt "officially" supported so I am not complaining...)
    04-08-2009 10:39 AM
  2. itsy's Avatar
    Having the same problem here, have not been able to find a work around yet
    04-08-2009 02:19 PM
  3. JM99's Avatar
    I use natf lite rom w/xboxmod's manila. Xboxmod w/Da_G's clean 5.08 works too. The Da_G w/Xboxmod will run TF3D on the redfly too(sometimes).
    04-08-2009 04:15 PM
  4. Velvis's Avatar
    Those are GSM roms correct? Are there CDMA equivelents?
    04-08-2009 09:28 PM
  5. mknollman's Avatar
    I am not sure if there are working 21000+ roms out there for the RF's BT - but this is the reason I just went back to tristy build 20764 - like a rock. I have all functionality back including BT. I literally flashed 6 times on different romsand tried the RF's BT connection and got the error, I am convince for now it is a no go. Update if you find one as that TP2 interface is very nice.
    04-08-2009 11:37 PM
  6. itsy's Avatar
    After some registry hacking I was able to move over the bluetooth authorization information from a backup made on a stock rom to my cooked rom. Unfortunately the redfly still would not connect. After comparing reg entries between the two, have not yet found an entry that the redfly app is checking to see if this is enabled (may not even be checking the registry but something else entirely)

    Also interesting to note, when trying to connect with the terminal I see a popup flash under the "connecting" screen with a pin number leading me to believe that the usb cable is not the only way to authorize the device and that conventional bluetooth pairing may work as well....

    If *someone* *cough* would toss us a bone and let us know what redfly app is checking to see if bluetooth is on, I'm sure the community will be able to figure this one out :)
    04-09-2009 05:00 AM
  7. jakubd's Avatar
    I would like just to reconfirm this issue: TPro with qsqa ROM, build 21018.1.6.0 - I was sure pure HR would solve the problem, but it seems to be more general issue.
    04-09-2009 09:27 AM
  8. mknollman's Avatar
    I think this issue will remain until the TP2 is released and has its own beta driver. Then Celio will have a real rom to work with and a real reason to support it.
    04-09-2009 09:45 AM
  9. laurieny's Avatar
    I do hesitate to respond to this thread at all, given that this is about custom ROMs which I know you all know we do not support and I don't want to seem to be encouraging at all.

    However, I will say that there is nothing as simple as a registry key that you could look for or add to indicate that Bluetooth is enabled on the phone to get past the issue you are having. In our Windows Mobile Bluetooth code, we programmatically query, looking for the driver BTD0: It is then opened and a DeviceIoControl is sent to the driver to retrieve the local address, which we then use to know that Bluetooth is enabled on that phone. If the driver can not be opened, or if the DeviceIoControl fails, it will return a code that tells the control panel that Bluetooth is not enabled. I don't suspect that understanding this will provide a solution for you, but that is how it is done.

    Thanks,
    Laurie

    Director of Engineering
    Celio Corp | REDFLY
    04-10-2009 12:28 PM
  10. benjaminries's Avatar
    Thanks very much Laurie for that information. I think we can all respect Celio's support policy, but providing extra information like this is extremely helpful to power-users and can only increase goodwill. It may also lead to information that helps your developers.

    (I am a law student and the recent owner of a slightly-used C8. My iPAQ 910c was slow with the stock ROM and so I learned how to cook a custom ROM for it - the first one ever made for that device, actually. So it is a priority for me to make the ROM fully compatible with the Redfly.)

    After searching a bit about this, it seems that certain driver calls may behave differently under .NET CF 3.5 compared to 2.0. Thus my current theory is that the Redfly Bluetooth functionality is incompatible with .NET CF 3.5.

    The theory makes a lot of sense based on user experience. All official manufacturer WM6.1 (and previous) ROMs come with .NET CF 2.0. However, *most* cooked ROMs are cooked with .NET CF 3.5 instead, because it is thought to improve application speed. However, a few ROM chefs out there just keep the original .NETCF from whatever stock ROM they have ported.

    I'm travelling right now so I won't be able to test and confirm the theory until later this month. However, there may be a way for users with .NETCF3.5 cooked ROMs to install .NETCF2.0 from cab and get the Bluetooth feature working.

    Of course, I expect this will be resolved anyway when Celio releases drivers that are WM6.5 compatible - as I understand that even "official" stock WM6.5 ROMs will come with .NET CF 3.5

    EDIT: bad news, it looks like you can only install *newer* .NET CF versions ontop of others. I now predict that only ROMs with .NETCF2.0 (or earlier) cooked into them will work with Redfly over Bluetooth. Easy enough for we ROM cooks to fix for ourselves; good luck getting other chefs who don't own Redfly to release editions with the older .NET CF :(
    Last edited by benjaminries; 05-01-2009 at 05:50 PM.
    05-01-2009 05:21 PM
LINK TO POST COPIED TO CLIPBOARD