The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. TheJackah's Avatar
    I've noticed that each tab in Microsoft Edge uses between 13% and 20% of the CPU.
    My CPU is: AMD Athlon X4 760K Quad Core.

    Does anyone know a fix for this? I've also been reporting it through the Feedback options available.
    Last edited by TheJackah; 08-06-2015 at 02:47 PM. Reason: Missed number
    08-06-2015 02:40 PM
  2. idokamaroq's Avatar
    Get a better processor? Intel perhaps? Haha, jk.
    What sites specifically?
    08-06-2015 02:44 PM
  3. TheJackah's Avatar
    Get a better processor? Intel perhaps? Haha, jk.
    What sites specifically?
    Mostly it is on Windows Central - I don't know what it is about this site, but something is making it very heavy in comparison to other sites. It is so unresponsive. I would follow the trick in the other thread to fix that, but I don't want workarounds, I want actual fixes, otherwise it's just papering over the cracks, which, from experience, can end you up worse off in the long run.
    08-06-2015 02:47 PM
  4. idokamaroq's Avatar
    Well, ya, this site is horrible and really needs to be just redesigned from scratch. It seems like it could cause even the Tianhe2 to grind to a halt trying to render it. Lol
    20% does seem like a lot, though. I'll dig around on my machine when I get home and see if I can find anything
    08-06-2015 07:28 PM
  5. idokamaroq's Avatar
    I only hit like 1.5% rendering windowscentral.com, and then it quickly drops down to 0.2-0.6% on my i7. Does it sit at 20% for you, or does it die off after the site is done rendering? And are you sure you're looking at the CPU usage specifically for Edge and not the overall CPU usage for the whole system? Because running Edge and nothing else, my overall usage sits right around 20%. That's not because of Edge, just because of the OS and all its background processes.
    08-07-2015 01:20 AM
  6. adesonic's Avatar
    Windows Central racks up to 40% CPU on my pc, other sites only get to 5%
    08-07-2015 02:47 AM
  7. Cryio's Avatar
    Edge is very CPU intensive on my end too. Both on my laptop, i3 Ivy Bridge and on my PC, FX 6300 @4.5 GHz.
    08-07-2015 03:13 AM
  8. Cryio's Avatar
    It's like the browser isn't using GPU acceleration at all.
    08-07-2015 03:15 AM
  9. Vikas_Kr's Avatar
    I didn't noticed such thing on my Core2 Dua PC.

    Sent from my GT-S5312 using Tapatalk
    08-09-2015 09:49 PM

Similar Threads

  1. When will the Windows 10 update for the Lumia 1320 be released?
    By Sourav Agrawal in forum Windows 10 Mobile Insider Preview
    Replies: 4
    Last Post: 08-06-2015, 03:19 PM
  2. Closed
    By ads13 in forum Ask a Question
    Replies: 0
    Last Post: 08-06-2015, 02:26 PM
  3. Updated to Win 10, and now the keybord doesn't work...
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-06-2015, 02:13 PM
  4. Fourth column of tiles?
    By TLRtheory in forum Windows 10
    Replies: 0
    Last Post: 08-06-2015, 02:05 PM
  5. Microsoft releases preview of tools to convert iOS apps to Windows 10 as open source
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-06-2015, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD