The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
11-09-2015 03:26 AM
27 12
tools
  1. Varun Mishra's Avatar
    Can I change the default search engine to Google in microsoft edge browser for Windows 10 Mobile? I could do it in the PC by going to google.com and choosing advanced options in settings. Unable to find something similar in mobile.
    10-21-2015 04:34 AM
  2. Pete's Avatar
    This is a potential upcoming feature.

    Please read - Windows 10 Mobile may allow users to change the default search engine for Edge browser | Windows Central
    ven07 likes this.
    10-21-2015 04:39 AM
  3. Ma Rio's Avatar
    With the latest build, you can. It's the same way as on desktop.
    DCProjMgr likes this.
    10-21-2015 09:21 AM
  4. Pete's Avatar
    With the latest build, you can. It's the same way as on desktop.
    The option is there, but it doesn't work yet.
    ven07 likes this.
    10-21-2015 09:53 AM
  5. Ma Rio's Avatar
    The option is there, but it doesn't work yet.
    It does work. I changed it on my phone, and it works for me. If you only type in the search field and press enter, the search will trigger, however if you press some of the suggestions above, it will go to Bing.
    10-22-2015 09:09 AM
  6. Tafsern's Avatar
    It does work indeed.

    Step by step:

    1. Search for Google (ONLY Google) in the address field and press enter. Bing will show you the results.
    2. Press google.com in the results and make sure it loads.
    3. Go to settings - advanced and edit the adress field search
    4. Press google.com and set it as standard.

    There you have it, now you can Google from the address bar. It doesn't work if you press the suggestions, only when you press enter for whatever you search for in the address field.
    Last edited by Tafsern; 10-22-2015 at 09:59 AM.
    zwuncki likes this.
    10-22-2015 09:40 AM
  7. Pete's Avatar
    Fair enough. Last thing I read on Windows Central was that the option is there, but doesn't do anything. And for me, Bing is the only available choice to pick from. But then again, I'm in the UK, which is barely a country at all in Microsoft terms...
    ven07 likes this.
    10-22-2015 09:59 AM
  8. Tafsern's Avatar
    Fair enough. Last thing I read on Windows Central was that the option is there, but doesn't do anything. And for me, Bing is the only available choice to pick from. But then again, I'm in the UK, which is barely a country at all in Microsoft terms...
    Did you try the step by step thing I wrote?

    I live in Norway and Bing isn't really good here either. It looks good though :P

    It's nice to see that it's possible!
    10-22-2015 10:19 AM
  9. Pete's Avatar
    Ok, now I see. When I go to Google.com, I get redirected to Google.co.uk, which isn't a valid search engine according to Windows Mobile. But if I try Yahoo.com instead, it works as you describe.
    10-22-2015 10:26 AM
  10. Tafsern's Avatar
    Ok, now I see. When I go to Google.com, I get redirected to Google.co.uk, which isn't a valid search engine according to Windows Mobile. But if I try Yahoo.com instead, it works as you describe.
    Weird, it works with google.no. Should work with co.uk too. Try step two again and choose another google.com result. Should work even if it redirects you to co.uk :)
    10-22-2015 11:26 AM
  11. sulistyarso's Avatar
    wp_ss_20151023_0003.png
    on my edge google.com redirect to google.co.id. but when i check to setting->advance->change search engine, i see google there and i try to make it as default. it works. :)
    10-22-2015 01:41 PM
  12. Tafsern's Avatar
    Tip: If it doesn't work with mobile view enabled, try with desktop view :)
    10-22-2015 03:22 PM
  13. Ma Rio's Avatar
    If it doesn't recognise .co.uk you can also click the link that says 'use google.com instead'. That should forse .com, and that should get recognised.
    Also, google.rs (Serbia) works for me, so IDK why it won't work for you.
    10-22-2015 06:20 PM
  14. ROBBIE HALL's Avatar
    Tried it. No luck. Open Edge, go to google.com (or .co.id or .com/ncr) wait for it to load....open settings in edge, go to advanced settings....no option....what am I doing wrong?
    10-22-2015 06:50 PM
  15. anon(3463402)'s Avatar
    It works with google.ba (Bosnia).

    Switching to Desktop mode may help if search engine is not recognized in Mobile view.
    10-22-2015 10:54 PM
  16. sulistyarso's Avatar
    Maybe try open google using https://
    10-22-2015 11:17 PM
  17. Tafsern's Avatar
    Tried it. No luck. Open Edge, go to google.com (or .co.id or .com/ncr) wait for it to load....open settings in edge, go to advanced settings....no option....what am I doing wrong?
    The thing that worked for me (and that I explained in the step by step thing) was to search for Google first in the adress field. Only Google! Then you will see the Bing results, and then press one of the Google.com results you get and it will open. Now try to go to advanced settings and change it :)

    If that doesn't work in mobile mode, switch it to desktop mode and do the whole thing again!
    10-23-2015 02:05 AM
  18. Pete's Avatar
    Yes, the desktop method works to get the default set to Google and I now see "Google" as my default search.

    But when I type a search term into the address bar and tap on one of the search suggestions, it actually performs a Bing desktop search instead of Google.

    Very odd.
    10-23-2015 02:15 AM
  19. Rasetech's Avatar
    The letter happens because the system already did a search on bing to even show you the search suggestions. So it seems that the defined search engine does not work for the auto suggest feature right now.
    10-23-2015 02:36 AM
  20. sulistyarso's Avatar
    Turn off suggest from edge setting,
    10-23-2015 02:44 AM
  21. Tafsern's Avatar
    Yes, the desktop method works to get the default set to Google and I now see "Google" as my default search.

    But when I type a search term into the address bar and tap on one of the search suggestions, it actually performs a Bing desktop search instead of Google.

    Very odd.
    That's what I wrote in my first post :)
    Pete likes this.
    10-23-2015 03:04 AM
  22. Pete's Avatar
    So you did.
    Tafsern likes this.
    10-23-2015 03:57 AM
  23. creanyo's Avatar
    I got the same problem (just got identified Bing and Wikipedia :/ ) but as @Tafsern said, works after you change from mobile view to desktop view...thanks dude! :)
    Tafsern likes this.
    10-23-2015 04:55 PM
  24. MonsterVlad's Avatar
    Tip: If it doesn't work with mobile view enabled, try with desktop view :)
    Thank you so much, this is what helped me!
    Tafsern likes this.
    10-23-2015 05:35 PM
  25. varunx's Avatar
    great, thanks for the tips. So I will wait for the next build 10575 where I don't have to flash back to 8.1
    ven07 likes this.
    10-23-2015 08:09 PM
27 12

Similar Threads

  1. How to go up a folder in OneDrive app?
    By crise in forum OneDrive
    Replies: 4
    Last Post: 11-02-2015, 07:54 AM
  2. How can I get Cortana and search working?
    By Windows Central Question in forum Cortana
    Replies: 1
    Last Post: 10-25-2015, 12:05 AM
  3. Log in on Windows 10 failing, how can I get in?
    By Windows Central Question in forum Windows 10
    Replies: 1
    Last Post: 10-21-2015, 03:19 PM
  4. Replies: 1
    Last Post: 10-21-2015, 08:37 AM
  5. timetreeapp equivalent app in windows phone store.
    By Nazir Taib in forum Ask a Question
    Replies: 0
    Last Post: 10-21-2015, 07:41 AM
LINK TO POST COPIED TO CLIPBOARD