1. Rajesh Ramtere's Avatar
    My application which is in Startup folder is not started after restarting the computer. I find some solutions on internet like
    1. Hkey_Local_Machine\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ System\ Set EnableLUA to 0 (See at right side - By Default it is set to 1)
    2. Set User Access Control settings to lowest level

    When i do this settings, my application which is in start up folder, application runs when machine restarts every time.. But this setting inhibit the operation of some MS programs like MS-Edge, Photo-Viewer, Skype Video etc. Resetting to default "1" and restart PC would resolved it. We need to look for better solution to this "security measure" by later Windows version.. Please guide me with better solution
    08-09-2016 12:46 AM
  2. TechFreak1's Avatar
    Okay first and foremost is the application you are having an issue with is - Edge or a different one entirely?

    If the latter, what is the application called?

    Also have you tried uninstalling via control panel and reinstalling it again?
    RumoredNow likes this.
    08-09-2016 05:44 AM
  3. Rajesh Ramtere's Avatar
    Let me put up my problem in a different way:

    1. My team has developed a windows (C# WPF) application. This application requires elevated privileges to execute. (right click on app --> "Run as administrator" even for an administrator user). This application need to run at startup occasionally (depending on user preferences).

    2. When user selects to run the application on windows startup, the application creates its shortcut in the "startup folder" of the windows.

    3. As this application needs administrative privileges to start running, we have made the setting as shown in the attachment image.

    Problem : With this UAC settings my application startup automatically whenever configured to start, at boot on windows 7. For windows 10 (I upgraded my PC from windows 7 to windows 10 Pro recently) these settings do not help. When I right click "Run as administrator" on my application from the shortcut in the startup folder, my application works fine.

    I made the registry settings as discussed earlier, It helps start the application on boot. However, some MS tools give an message saying : eg "MS Edge can't be opened using the built-in Administrator account. Sign in with a different account and try again.".



    I feel, somehow the UAC prompt, which generally occurs on running this application cannot allow same application in startup mode. How can I tell windows to run the application in administrator mode ? (windows does not by default run an app in administrator mode even when logged-in user is an administrator of that PC).

    uac.png
    08-10-2016 01:51 AM
  4. TechFreak1's Avatar
    Let me put up my problem in a different way:

    1. My team has developed a windows (C# WPF) application. This application requires elevated privileges to execute. (right click on app --> "Run as administrator" even for an administrator user). This application need to run at startup occasionally (depending on user preferences).

    2. When user selects to run the application on windows startup, the application creates its shortcut in the "startup folder" of the windows.

    3. As this application needs administrative privileges to start running, we have made the setting as shown in the attachment image.

    Problem : With this UAC settings my application startup automatically whenever configured to start, at boot on windows 7. For windows 10 (I upgraded my PC from windows 7 to windows 10 Pro recently) these settings do not help. When I right click "Run as administrator" on my application from the shortcut in the startup folder, my application works fine.

    I made the registry settings as discussed earlier, It helps start the application on boot. However, some MS tools give an message saying : eg "MS Edge can't be opened using the built-in Administrator account. Sign in with a different account and try again.".



    I feel, somehow the UAC prompt, which generally occurs on running this application cannot allow same application in startup mode. How can I tell windows to run the application in administrator mode ? (windows does not by default run an app in administrator mode even when logged-in user is an administrator of that PC).

    Click image for larger version. 

Name:	UAC.PNG 
Views:	1 
Size:	17.7 KB 
ID:	129283
    What about group policy settings?

    Have you tried creating a global script in conjunction with a background service? (Set to automatic - delay)

    The easiest route I see is to create a background service as forcing the application to run with the built-in administrator account is a no go as that could potentially could open up exploit holes.
    Last edited by TechFreak1; 08-12-2016 at 04:34 AM.
    08-12-2016 04:17 AM

Similar Threads

  1. My Windows 10 does not boot after downgrade from anniversary upgrade
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 08-10-2016, 08:27 AM
  2. Sudden surge in Outlook Junk Mail
    By albertico in forum Microsoft Office
    Replies: 1
    Last Post: 08-09-2016, 10:00 PM
  3. why is lumia950 lagging , when charge drops below35%??
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-09-2016, 12:18 AM
  4. 'digital signature are not verified '
    By DEvilsHell in forum Windows 10
    Replies: 2
    Last Post: 08-09-2016, 12:10 AM
  5. What data is lost when you download and install icloud?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-09-2016, 12:06 AM
LINK TO POST COPIED TO CLIPBOARD