1. Nadeem Zulfiqar's Avatar
    I really wanna use Microsoft edge, but it always shows a blank page for a long time before opening website, while chrome opens fast if I do side by side comparison on this same pc. I read that by enabling TCP Fast open I pages will load fast but I can't see any option of Networking or TCP Fast Open in about:flags, my windows is up to date. what should I do?
    06-26-2018 08:09 PM
  2. TechFreak1's Avatar
    You're going to have to wait for a KB update to fix this issue or try clearing the cache/history though I'm not sure how much the latter will help.
    06-27-2018 05:33 AM
  3. Timbre70's Avatar
    Think it's a characteristic of Internet explorer and Edge.

    Same experience here.

    Surprisingly, the edge on android is pretty fast, as good as chrome. 👍
    06-27-2018 07:11 AM
  4. tgp's Avatar
    Surprisingly, the edge on android is pretty fast, as good as chrome.
    Edge on Android uses the same browser engine as Chrome. Its basically Chrome in an Edge wrapper. That is why it is as fast as Chrome, because its the same thing.
    TechFreak1 likes this.
    06-27-2018 07:47 AM

Similar Threads

  1. why my speaker not working when I am on call?
    By andresontom in forum Ask a Question
    Replies: 2
    Last Post: 06-27-2018, 05:39 AM
  2. Microsoft To-Do is getting a dark mode on Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-26-2018, 02:30 PM
  3. How to fix Windows Mixed Reality headset that won't wake up
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-26-2018, 02:10 PM
  4. Huawei's AMD Ryzen-powered MateBook D now available in the U.S. for $629
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-26-2018, 02:00 PM
LINK TO POST COPIED TO CLIPBOARD