1. Cruzer1's Avatar
    Hey all, thought I'd create this thread to see how many people here are experiencing the same crashing problem with Ice Age Village. Ever since hitting level 20, the game won't open for me, the 1.1 update didn't fix the issue. I've tried contacting Gameloft through their website and their facebook with no reply regarding an update to this this issue. Hopefully if we get enough numbers here WPCentral might ask Gameloft if there's an update to fix this issue? Just now looking at marketplace reviews, looks like there are a fair amount of people experiencing this also.
    05-08-2013 06:53 AM
  2. ImAdrian23's Avatar
    I had some troubles with the app since the new update, but once I restarted my phone it worked like a charm. Give it a try!
    05-08-2013 08:53 AM
  3. Cruzer1's Avatar
    Restarted it heaps of times, no success :(
    05-08-2013 04:09 PM
  4. kingkoopa09's Avatar
    Yea mine now locks up whenever downloading especially when goin to visit so I can't beat my mission
    05-15-2013 10:37 AM

Similar Threads

  1. Anything similar to Age of Empires?
    By johnmcd348 in forum Games
    Replies: 28
    Last Post: 04-10-2014, 04:07 PM
  2. Ice Age Village where is it?!
    By ImAdrian23 in forum Games
    Replies: 1
    Last Post: 07-03-2013, 11:26 AM
  3. Ice Age Village pulled out from...
    By ImAdrian23 in forum Games
    Replies: 6
    Last Post: 05-02-2013, 01:03 PM
  4. Age Calculator
    By ur2sweet in forum App Spotlight
    Replies: 0
    Last Post: 06-27-2011, 10:02 AM
LINK TO POST COPIED TO CLIPBOARD