1. Wevenhuis's Avatar
    Hi,
    About a month or two now, I have been having an issue where websites are acting funny on the latest version of internet explorer for windows 8.1 on my first generation surface pro. The issue issue with websites like pocketnow.com and wmpoweruser.com where pictures and disqus comment fields will turn up as white spaces. This is both for the modern UI and desktop versions of internet explorer.
    I contacted microsoft on this issue. The problem probably lies apparently with the videodriver and at least one other person had this issue, although not apparently with a surface pro. The solution according to microsoft is to uninstall and install the video driver.

    I got instructions but I am a bit hesitant to execute this solution. I am afraid it will affect the whole OS and make my surface pro in a significant way. The surface pro is currently my daily driver. I cannot afford a solution that might affect the whole system.

    I was wondering if there are other surface owners out there that have tried this with a significant driver for their surface devices and what the experiences are with major issues. The biggest fear I have is that when I uninstall the driver that I cannot play any media anymore, or worse lose control of any functionality of input with keyboard or touch controls, rendering my surface useless.

    I am curious to hear your stories/advice on this issue. I might help me take the (bold) step to fix an annoying issue. Thanks in advance.
    01-11-2015 04:55 AM
  2. Marquis de Faux's Avatar
    First, try this in Internet Explorer and see if it fixes the problem:
    Tools -> Internet Options -> Advanced -> Reset

    If that does not fix it, you should follow the Microsoft solution. Without the video drivers, you will not be able to play some video, but the touch will work and otherwise it will be fine. When you reinstall, everything should work again.
    01-11-2015 10:56 AM
  3. Wevenhuis's Avatar
    Thanks! The first option worked to a large degree. I still having issue loading disqus on the website like pocketnow.com. Not sure if this is a videodriver issue, or if there is another fix. Have you got any ideas? (any ideas better than the video driver uninstall-install).
    01-12-2015 06:19 AM
  4. Marquis de Faux's Avatar
    I've been having problems with Disqus too, it might be a problem with them and not your device.
    Do you only have problems in IE or does it work in other browsers?
    01-12-2015 06:26 PM
  5. Wevenhuis's Avatar
    The issue seems to only be internet explorer. I tried it on chrome, but it works there. It''s frustrating, because I have to use two browsers now, just to use disqus.
    01-13-2015 07:23 AM
  6. Marquis de Faux's Avatar
    Try this:
    Tools -> Internet Options -> Delete Browsing History and delete the Temporary internet files and Cookies.
    Also go to Windows Update and install any updates that may be available.
    Make sure no Compatibility Mode or anything is turned on.
    01-13-2015 03:19 PM
  7. Wevenhuis's Avatar
    Well, I saw I got a ciritical update from microsoft today dd/ 15/1/2015. After insallment and auto restart I checked internet explorer. Yep internet exlplorer is working properly again. After the IE reset I still had an issue with a blank screen and disqus comment fields on some websites. Without following any further advice and checking after the windows update every thing is normal. I do not know if there is a causal relationship with the update, but the correlation is striking. I guess there was a fix for IE somewhere in this update.

    Thanks. Issue solved.
    Marquis de Faux likes this.
    01-16-2015 01:00 PM
  8. Wevenhuis's Avatar
    I'm back. Issue does not seem resolved 100%. Theres seems to be an issue that commenting on the website forum mywindows.nl is very slow to respond in both internet explorer in winodws8.1. I Can start a thread or reply to a thread. But once selecting the textbox and typing, the text appears deadslow. I can only type a word once every 20-30 seconds. I' ve tried it in Chrome but it seems better there. The only bug in chrome with my surface pro is that the virtual keyboard pops up every single time I start typing in any text or search field when using the typecover.
    Has anyone else experienced this?
    02-19-2015 02:03 PM

Similar Threads

  1. Why can't I open downloaded attachments in Windows 8.1?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-11-2015, 08:39 AM
  2. Replies: 2
    Last Post: 01-11-2015, 05:55 AM
  3. Windows phone calender
    By aaron j in forum Ask a Question
    Replies: 1
    Last Post: 01-11-2015, 05:28 AM
  4. Will the Lumia 720 get the new update ( windows 10)?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-11-2015, 03:03 AM
  5. Can't Connect to Internet
    By Akhil Prajapati in forum Nokia Lumia 1320
    Replies: 1
    Last Post: 01-11-2015, 02:33 AM
LINK TO POST COPIED TO CLIPBOARD