1. gearhead05's Avatar
    Around 7 or so last night I started having issues with the marketplace. I was playing Puzzle Quest 2 and my game froze up, then my phone just restarted on it's own. After it booted back up, I tried downloading an app from the marketplace before it gave me the "install" button it kept asking me to sign into my windows live ID. I would click sign in and then I kept getting the message about "Can't get info right now, try later." I just tried again this morning and the same thing happened.

    Is anyone else having problems?
    05-27-2011 09:24 AM
  2. jalb's Avatar
    It is working well from here, Samsung Focus, on AT&T.
    05-27-2011 09:28 AM
  3. gearhead05's Avatar
    So I figured out my issue. I checked my account settings and somehow I wasn't signed in and it was telling me my password was incorrect. It then said that I had to change my password. I did that and everything seems to be working fine. This was a very odd occurence...
    05-27-2011 09:41 AM