1. perpleSlerp's Avatar
    The age old problem of USB devices not showing in 'My Computer'..

    Windows XP S3 will not display new plug and play USB devices ( i.e. Lumia 640 and 640 XL, SanDisk thumb drive, portable hard drive, etc). Existing devices are still displayed and work fine (i.e. Memorox thumb drive, USB mic, USB audio gear, etc).

    When I plug new devices they are recognized and I usually get a window prompting me to install the drivers (even though some of most of these devices require none). Clicking next gets an error message.. always.. on every device... and the resulting message that the USN device did not install properly or may not work properly, etc.

    Devices may or may not show up in 'Device Manager', if they do they have a yellow question mark.

    Devices DO NOT show up in "Disk Management"

    I've tried everything it seems, including...

    Deleted and reinstalled all USB port drivers.

    Deleted the UpperFilters registry value and the LowerFilters registry value under registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}

    As described here: https://support.microsoft.com/en-us/...ark-letmefixit

    Any ideas?
    08-12-2015 07:56 PM
  2. realwarder's Avatar
    If it prompts for drivers, pointing at the correct driver should install it... if it doesn't and a reboot doesn't fix it... try unplugging everything else?

    Check the Event Log for errors to search for.

    You could also use system restore to return to a time when it was working.

    Note: XP is majorly unsupported... time to upgrade to a secure OS?
    08-12-2015 08:05 PM
  3. perpleSlerp's Avatar
    Thanks, tried all of those. Event log just gives driver fail errors. I don't have any restore points going back to the last time it worked.. I'm not even sure how long ago that is as I haven't had a need for a new USB device in some time until recently. XP has been good to me, my lap top does everything I need it to do, no need or want to spend money on in upgrade I don't need. I haven't had any anti-virus on any of my machines in over 10 years and only had one virus about two-three years ago after my sister got done using it while dog sitting for me! I don't open mail, files, programs or download anything unless I'm 110% sure what it is. That and the built in website warnings in Google and Firefox have gotten me by. Every few months I'll run a free virus and or malware etc scan just for SnG's.. they never find anything but for a few adware bugs, if that. Just have to figure out what's going on with the USB device issue...and get'r back in shape,.. she has a lot left in the tank.
    08-12-2015 08:57 PM

Similar Threads

  1. New Windows TP 10 on Lumia 1020!!
    By Mike Newport in forum Windows 10 Mobile Insider Preview
    Replies: 6
    Last Post: 08-17-2015, 12:36 PM
  2. Why is there a lot of unnecessary files in Groove Music?
    By Ali Akbar 7 in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 08-15-2015, 04:49 AM
  3. My Lumia 640 indicates that the update 10512 is available to download but nothing is happening?
    By luvurmuther earth in forum Windows 10 Mobile Insider Preview
    Replies: 2
    Last Post: 08-12-2015, 08:40 PM
  4. Why won't my email accounts sync in Windows 10?
    By Patty Rash in forum Windows 10
    Replies: 0
    Last Post: 08-12-2015, 07:50 PM
  5. Why is my Windows 10 download taking so long?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 08-12-2015, 07:22 PM
LINK TO POST COPIED TO CLIPBOARD