1. Rooks308's Avatar
    Hey folks,

    I'm currently on a 30 day mission to try using a Windows phone as my only phone to see if I would be happy with switching over from an iPhone. I'm due for an upgrade from my 5S and i'm sure a new model will come out in Sept/Oct so now is the time I need to decide if I will make the switch.

    I picked up a T-Mobile Lumia 640 and so far I really like it. I understand it isn't a flagship phone so I'm not comparing benchmarks or anything like that.

    What is frustrating me to no end however is that I cannot seem to get a decent wifi speed/connection unless I do 2 things.

    1. Disable bluetooth. I just ran a test and if I have bluetooth on I get 1.8 or so Mbps down, and about 5-6 up. If I turn it off I get 28 or so down and 8+ up.
    2. Disable wifi calling, same reasons as above.

    It seems crazy to me that I would get such a dramatic drop in speed just by having bluetooth on. I've never experienced this with any of the other phones i've owned (iOS or Android). Is this just my specific device? or is anyone else having this problem? Was there a known bad batch or something? I'd LOVE to move this to my 5Ghz network but Microsoft didn't include that option on this phone.
    08-16-2015 06:38 PM

Similar Threads

  1. Lumia 435 vs 635
    By stefanosGR in forum Nokia Lumia 635
    Replies: 13
    Last Post: 09-07-2015, 06:22 AM
  2. How do I log in as Administrator on a Lumia 640 LTE?
    By KB720 in forum Windows Phone 8.1
    Replies: 4
    Last Post: 08-23-2015, 10:11 AM
  3. Why can't I share images or videos to Facebook or messenger vis button?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 08-16-2015, 04:15 PM
LINK TO POST COPIED TO CLIPBOARD