1. libra89's Avatar
    I'm considering buying an unlocked Lumia that has LTE that works in America, but wasn't made for the American market originally. GroupMe is an important app for communication, for me. I can't seem to find any threads on this, but I would love if someone can tell me if GroupMe works well (or at least as it should) on phones not made for the American market.

    Does anyone know? This thread doesn't only apply to GroupMe, but it also applies to other apps that might be more so US only or US specific. Even if you don't use GroupMe, there might be a regional/country app that you use. Please share your experiences w/ unlocked Windows phones and how it can affect your regional apps.

    (That is the only thing that is holding me back from taking a chance on it.)
    12-03-2015 07:42 PM
  2. xandros9's Avatar
    Um, the original phone's region shouldn't make a huge difference at all. In any measure.

    Well, maybe you'll have a different set of preloaded apps, or a different language selected in the first-use language picker.

    but actually, it'll be fine, don't worry about a thing.

    All you have to worry about is the cellular bands and stuff.
    libra89 and RumoredNow like this.
    12-03-2015 08:45 PM
  3. libra89's Avatar
    Um, the original phone's region shouldn't make a huge difference at all. In any measure.

    Well, maybe you'll have a different set of preloaded apps, or a different language selected in the first-use language picker.

    but actually, it'll be fine, don't worry about a thing.

    All you have to worry about is the cellular bands and stuff.
    Thank you, I hope it works out for me.
    I made this thread because it worked as it normally should on my t-mo 640, and also on the branded 435 when I had it.

    However I tried out an Americas variant of the 532, and it refused to load my groups. I tried uninstalling it and then reinstalling it. Made no difference though. :/

    When I went back to the 435, everything worked as it should.
    12-03-2015 09:22 PM
  4. xandros9's Avatar
    Thank you, I hope it works out for me.
    I made this thread because it worked as it normally should on my t-mo 640, and also on the branded 435 when I had it.

    However I tried out an Americas variant of the 532, and it refused to load my groups. I tried uninstalling it and then reinstalling it. Made no difference though. :/

    When I went back to the 435, everything worked as it should.
    It's weird, but I don't know what to say about that. It should work regardless.

    I threw a French ROM on my 920 a couple years ago and it didn't change anything other than selecting French first, so I had to scroll to US English.
    libra89 likes this.
    12-03-2015 11:26 PM

Similar Threads

  1. Pictures on SD Card has limited functions?
    By Windows Central Question in forum Microsoft Lumia 950
    Replies: 9
    Last Post: 12-05-2015, 05:27 PM
  2. Cortana Live Tile not working
    By MS_DOS_3 in forum Microsoft Lumia 950
    Replies: 2
    Last Post: 12-03-2015, 11:13 PM
  3. So No way to run Android apps on W10 Mobile right now?
    By bo_woods in forum General Phone Discussion
    Replies: 1
    Last Post: 12-03-2015, 07:00 PM
  4. Living Images on W10M?
    By MattyJ94 in forum Ask a Question
    Replies: 0
    Last Post: 12-03-2015, 06:15 PM
  5. Replies: 0
    Last Post: 12-03-2015, 05:51 PM
LINK TO POST COPIED TO CLIPBOARD