1. Windows Central Question's Avatar
    Its a very strange problem and I am not able to know what the root of the issue is. So i will list it down. I'm connecting my lumia with netgear wifi

    Problems are

    1) I'm not able to download or update any app over wifi. Cellular data works but not wifi. However I'm able to surf websites, whatsapp on my phone.

    2) Don't know if the problem is with the router but I connected my iphone to the router and was able to download apps through their app store. So whats wrong with my windows phone here...

    3) Also I connected my windows phone to another wifi hotspot and its working fine here and also was able to download apps from the windows store.

    Guys please help me here in resolving this issue.
    04-22-2016 08:47 AM
  2. Chintan Gohel's Avatar
    Its a very strange problem and I am not able to know what the root of the issue is. So i will list it down. I'm connecting my lumia with netgear wifi

    Problems are

    1) I'm not able to download or update any app over wifi. Cellular data works but not wifi. However I'm able to surf websites, whatsapp on my phone.

    2) Don't know if the problem is with the router but I connected my iphone to the router and was able to download apps through their app store. So whats wrong with my windows phone here...

    3) Also I connected my windows phone to another wifi hotspot and its working fine here and also was able to download apps from the windows store.

    Guys please help me here in resolving this issue.
    If I understand you correctly here, you were able to download and update apps over another wifi connection from the one you have.
    Can you delete the wifi from your phone and add it again?
    Secondly, switch off your router and then start it up again to see if your phone can update after that
    04-22-2016 12:16 PM
  3. Siddharth Mukherjee's Avatar
    Hi Chintan.....I have tried all the steps mentioned by you before. Still no help.

    Yes I was able to download apps over through a mobile hotspot of another smartphone.

    Another piece of info which might help, Im using an eternet internet connection with static IP and using a netgear router for wireless connectivity.
    Could this be a MAC issue?
    04-22-2016 09:17 PM
  4. Chintan Gohel's Avatar
    I'm not familiar with wifi routers so I can't help you there right now. The suggestion I can give that can help you temporarily is try to find a place with wifi other than your own and update/download apps there. I know it's a backward solution but it will help you get your work done for the moment
    04-23-2016 01:00 AM
  5. Vlatko Stojanovski's Avatar
    Another piece of info which might help, Im using an eternet internet connection with static IP and using a netgear router for wireless connectivity.
    Could this be a MAC issue?
    I don't see how it can be a MAC issue, but something you wrote made me wondering. The internet is a fixed IP, so I am guessing the Netgear is the one giving IP addresses to devices.

    The question is whether the fixed IP is on the same segment range as the one the router is giving away? Example: Internet IP: 77.26.152.3, IP addresses given to devices by router: 77.26.152.4,77.26.152.5 etc. Or is is it a different segment? Example: Internet IP 77.26.152.3, but devices get 192.168.0.1, 192.168.0.2, 192.168.0.103.

    It is possible that the setup you have is getting the Win Store downloads blocked, but not Apple Store, as they are both different path the information travels on the internet.

    I must however stress, that this is all based on speculation, as I have no idea of your real setup and connections ISP Device/Router/WiFi Setup
    04-23-2016 05:17 AM
  6. Siddharth Mukherjee's Avatar
    Yes you are right Vlatko. The IP address given to the devices are way different that the internet IP address is.....can you throw some light on this issue and point me towards a resolution in the right direction.
    04-23-2016 02:40 PM
  7. Vlatko Stojanovski's Avatar
    Yes you are right Vlatko. The IP address given to the devices are way different that the internet IP address is.....can you throw some light on this issue and point me towards a resolution in the right direction.
    Well it all depends how the the internet wire is connected to the router or to be more specific to what port of the router (one of the LAN ports or WAN/Internet) as well as what the network status window of the router says. Also its always advisable to update the firmware on the router if you haven't so far.
    04-24-2016 02:34 AM
  8. Siddharth Mukherjee's Avatar
    Its connected to the WAN port. I also notice that some websites don't open when Im connecting through my wifi router for eg windowsphone.com and even windowscentral.com on my smartphone. However when Im connecting the internet wire directly to my desktop without involving my router everything works fine and all sites open. I think I first need to understand whats causing the problem. Whether its my phone, my ISP or my router.
    04-24-2016 01:42 PM
  9. pankaj981's Avatar
    Connect to your WiFi router's administration menu and see if DHCP is enabled. Also try fiddling with the broadcast frequency (set it to 20MHz if possible for testing) and channels to see if it works?

    It definitely isn't your ISP, its your router.
    04-24-2016 04:03 PM
  10. Vlatko Stojanovski's Avatar
    Its connected to the WAN port. I also notice that some websites don't open when Im connecting through my wifi router for eg windowsphone.com and even windowscentral.com on my smartphone. However when Im connecting the internet wire directly to my desktop without involving my router everything works fine and all sites open. I think I first need to understand whats causing the problem. Whether its my phone, my ISP or my router.
    From your setup, I'd also go with pankaj981's suggestion and try different frequency and channels as might also be interference from the surrounding you might not be aware of.
    04-28-2016 07:35 AM

Similar Threads

  1. Effect of disabling background apps
    By LarsCor in forum Windows 10 Mobile
    Replies: 7
    Last Post: 04-26-2016, 07:54 AM
  2. Why is iTunes for Windows 10 so awful
    By donaldvc in forum Windows 10
    Replies: 3
    Last Post: 04-25-2016, 09:32 AM
  3. We just played Outlast 2 the sequel to one of the most terrifying games ever
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-24-2016, 03:30 PM
LINK TO POST COPIED TO CLIPBOARD