1. Eric J F's Avatar
    I had to reset my Alcatel Fierce XL W10 (15063.332) phone and after reinstalling the Kindle app couldn't get it to authorize. I tried numerous one-time passwords without success. Amazon chat told me the app is no longer supported on W10 mobile even though it still works on my other Alcatel phone (Idol 4S; 15063.332). I also noticed it's no longer advertised on the Kindle apps page.

    I hope I'm wrong, but if you like the Kindle app, don't uninstall it or reset the phone!
    05-28-2017 12:52 AM
  2. xandros9's Avatar
    I ran into this last week, there's no way I can log in with it on Windows Phone.

    (attempted password12345 and 12345password, password and then 12345, etc. With 12345 standing in for the OTP code.)
    05-28-2017 02:03 AM
  3. Kerry2112's Avatar
    I ran into this problem the last time I had to reset my 950XL DS a couple weeks back and I eventually did get it to authorize. But I can't for the life of me remember how I did it. Now that I've been victimized by the insider build fiasco yesterday and had to use WDRT, I'm stuck again with an unusable Kindle app.

    I have a weird recollection of using the code it emails you in the user name (email) field instead of the password field but I tried that last night and it didn't work. Will play with it more this weekend.
    xandros9 likes this.
    06-02-2017 01:45 PM
  4. Kerry2112's Avatar
    So, out of nowhere, the Kindle app let me authorize today. I tried to register the device, failed as usual, waited for the usual email with a numeric code to sign in with. But the email didn't show up. So, in frustration, I deleted the Kindle app.

    Then (of course) the email arrived. So I re-installed the app and again tried to log in using my email and the code emailed to me as the password. Lo and behold, it worked!

    So I can't honestly say I know why or how, but I'm back on Kindle on my 950XL DS.
    libra89 likes this.
    06-16-2017 10:41 AM
  5. camaroz1985's Avatar
    Well that is an odd change of events, but a good one at least.
    06-16-2017 10:45 AM
  6. Eric J F's Avatar
    Thanks for letting us know- it worked for me, too.
    06-17-2017 07:01 PM
  7. mileson73's Avatar
    didn't quite understand you. I have same problem. Amazon doesn't recognize my mail or password (I get that in the message when I try to register kindle app).
    Did you press FORGOT YOUR PASSWORD? and then you got a code in mail or something else?
    06-17-2017 07:45 PM
  8. Eric J F's Avatar
    When you try to register the Kindle app with your Amazon log in information, you get a message the info isn't recognized, and they're supposed to automatically text or email you a numeric one-time password. You then enter that in the password field.

    What was happening before was the one-time passwords never worked. Now they are. Try uninstalling the app, restart the phone, and reinstall the app. Also, check your Amazon account to make sure they have a number or email to contact you.
    06-18-2017 08:48 AM
  9. mileson73's Avatar
    hmm, I did as you said, but this is obvious Amazon problem. I get message to late, about 30 minutes later, and that code which I get after 30 min is not valid :)
    06-18-2017 03:02 PM
  10. Rising Mos's Avatar
    For those of you who want Kindle in the store, be sure to express your displeasure to Amazon Kindle support. The more people request it, the faster we will get it back.
    06-30-2017 04:48 AM
  11. SteveNoza's Avatar
    Had this problem with the Kindle app on my new x3, had Amazon support call me and they bypassed the 2 step authorization for me, installed just fine after that. Now in trauma after hearing Evernote is pulling support :(
    06-30-2017 10:15 PM
  12. kauaibuckeye's Avatar
    I finally got my Nokia 1520 WP8.1 Kindle app to register. I temporarily disabled 2-step authentication. I then entered my normal user name and password on the registration page. I kept checking my email inbox for an email with a 1-time security code from Amazon. I then entered my normal user name and the security code as a password. The Kindle registered successfully and the app is running again!
    Last edited by kauaibuckeye; 03-06-2019 at 03:57 PM.
    03-05-2019 11:22 PM

Similar Threads

  1. Why no phones for Verizon?
    By savagelizards in forum General Phone Discussion
    Replies: 28
    Last Post: 06-05-2017, 08:46 AM
  2. Is there a way to remove a contact section from the People app W10??
    By Panos Athanasiou in forum Ask a Question
    Replies: 2
    Last Post: 05-28-2017, 03:06 PM
  3. Replies: 4
    Last Post: 05-27-2017, 05:19 PM
  4. Replies: 0
    Last Post: 05-27-2017, 05:02 AM