1. BigwaveMx's Avatar
    Some weeks ago, I noticed that I can't explore, play and find music in the store when I'm connected over mobile data. When I'm connected trough Wi-Fi everything seems fine. After a long chat with windows phone support staff, he found that the problem seems to be related to the last OS update. The issue is fixed when you change the connection speed from 4G LTE to 3G.

    Does any other have this issue or this happens only to my L1020???

    Hope this helps to any other with the same issue.
    RTGent likes this.
    12-11-2014 01:01 PM
  2. RTGent's Avatar
    I'll have to experiment; thanks for the tip. I did note a delay yesterday in downloading a few songs I had Bing-found and gone to the Store for while sitting in a caf. It's always gone through pending and downloading within 10-20 seconds, even on mobile data; but yesterday I was waiting longer and didn't think of checking whether I was on LTE.
    12-12-2014 11:32 AM

Similar Threads

  1. Icon Camera 📷 Issues
    By aaronarnwine in forum Nokia Lumia Icon
    Replies: 4
    Last Post: 01-13-2015, 06:47 AM
  2. Replies: 5
    Last Post: 12-20-2014, 03:51 PM
  3. Anyone else having issues sending pictures vis SMS?
    By Blacklac in forum Windows Phone 8.1 Preview for Developers
    Replies: 3
    Last Post: 12-11-2014, 07:36 AM
  4. Why is my wifi connection so weak on my Lumia 625 Nokia?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-11-2014, 07:10 AM
  5. Sail through the air and join The Snowman on his way to the North Pole
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-11-2014, 03:50 AM
LINK TO POST COPIED TO CLIPBOARD