1. western_riders_dad's Avatar
    Hi, all.

    Just received my HP Elite X3 bundle, and the X3 Lap Dock. I've connected the X3 to the Lap Dock, and am attempting to update firmware for the Lap Dock, however, it is not displayed in the HP Device Hub. Any suggestions?

    I am running OS build 10.0.14393.693, and have tried connecting wired and wirelessly to the Lap Dock, with the Lap Dock connected to power as well. Continuum is running successfully, I just can't see the Lap Dock within HP Device Hub when connected.

    Thanks in advance!
    01-19-2017 07:31 PM
  2. azgoth444's Avatar
    Hi, all.

    Just received my HP Elite X3 bundle, and the X3 Lap Dock. I've connected the X3 to the Lap Dock, and am attempting to update firmware for the Lap Dock, however, it is not displayed in the HP Device Hub. Any suggestions?

    I am running OS build 10.0.14393.693, and have tried connecting wired and wirelessly to the Lap Dock, with the Lap Dock connected to power as well. Continuum is running successfully, I just can't see the Lap Dock within HP Device Hub when connected.

    Thanks in advance!
    That's weird. It should show itself in the device hub once you start it up. It does take awhile to refresh itself like a few seconds. Thats how it is on the deskdock. Maybe try a soft reset before connecting again and launching device hub perhaps.

    http://m.windowscentral.com/new-firm...-dock-touchpad

    Putting this link here just incase you missed anything.

    Sent from mTalk
    01-20-2017 01:25 AM
  3. western_riders_dad's Avatar
    Thank you for the reply.

    It appears I'm good to go now. Last night, I noticed a number of my apps had an update available, including HP Device Hub. So, after updating the app and connecting via USB to the Lap Dock it now shows in Device Hub and I was able to perform the fw upgrade.

    Thanks again! Looking forward to being back in Windows Mobile after enduring a couple years of Android being Android.
    01-20-2017 07:53 AM
  4. azgoth444's Avatar
    Thank you for the reply.

    It appears I'm good to go now. Last night, I noticed a number of my apps had an update available, including HP Device Hub. So, after updating the app and connecting via USB to the Lap Dock it now shows in Device Hub and I was able to perform the fw upgrade.

    Thanks again! Looking forward to being back in Windows Mobile after enduring a couple years of Android being Android.
    Thats great news. Welcome back and enjoy using your Elite x3

    Sent from mTalk
    Last edited by azgoth444; 01-20-2017 at 09:18 AM.
    01-20-2017 08:03 AM
  5. peter338393's Avatar
    By changing the OEM parameters of my Lumia 950, I managed to install HP Device Hub on my phone. Unfortunately, the app will not recognize Lapdock. Anyone managed to get this working?

    If not, there is some proud X3 owner living either in the Milan/Turin area or in Bonn, Darmstadt, or Berlin..? :-)
    02-03-2018 02:45 AM

Similar Threads

  1. Lumia 550, 950 and 950 XL now back in stock at the U.S. Microsoft Store
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 01-19-2017, 01:32 PM
  2. How to use Wallet app in India?
    By emamitabha in forum Ask a Question
    Replies: 0
    Last Post: 01-19-2017, 11:41 AM
  3. HoloLens is now shipping to developers in Japan
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-19-2017, 10:30 AM
  4. How to use your Surface Pro 3 docking station with a Surface Pro 4
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-19-2017, 10:11 AM
  5. ASUS' new ZenBook UX430 and UX530 pack discrete graphics in a thin body
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-19-2017, 10:11 AM
LINK TO POST COPIED TO CLIPBOARD