08-04-2017 12:54 PM
118 ... 345
tools
  1. azgoth444's Avatar
    Anybody else having issues with the latest software update? Came out about Thursday the 12th. I've noticed two significant issues:

    1. Fingerprint reader doesn't work at all. It doesn't even register that I'm trying to use it. This is a major loss with how much longer it now takes every time I want to turn on the device (iris scanner takes a lot longer).
    2. Battery life has dropped significantly, at least I think - there's the usual small sample size caveat. Normally I get home from work with 60%+ remaining, but yesterday I realized at lunch I was already down to 40%. Today has been similar.


    Update: as ridiculously simple as it sounds, another restart (not the automatic restart after installing the update) and at least the fingerprint reader is working again.
    Yes, having battery issues with significant drain. Will still last but with less percentage by the end of the day. Also camera crashes when going into photos after taking a shot. Blackout screen appears before booted to start screen. Maps not working properly when switching to aerial mode. Didnt have problems with the fingerprint or iris scanner.

    Update: Battery drain due to Zombie Anarchy game for me. Everything else seems fine. Did a soft reset and seems better now.
    Sent from mTalk
    Last edited by azgoth444; 01-19-2017 at 05:57 AM. Reason: found out why battery drained.
    01-15-2017 02:37 PM
  2. jes1888's Avatar
    Hello, I switched thru warranty my L950Xl for the elite x3 and so far I've been like 4 days with it. Problems that I've noticed so far are

    1. No audio on skype when connected to a Bluetooth headset, any, speaker (charge 3), Headset (Plantronics Voyager edge), just nothing I can hear but I can't talk, if I turn off the BT and speak thru the phone it works fine sometimes, other i'm heard with a robotic voice, static.

    2. Low framerate video on skype. When on a video call I saw the other party's screen to see the quality of my X3's front shooter and to my surprise just a piece of crap quality, framerates around 8-12 FPS, it's just unbearable.

    These 2 are not present on other video call apps. (I tried viper and WhatsApp and quality is better on those and audio works fine)


    3. After trying continuum thru my Microsoft display dock for a few minutes phone was pretty warm and when disconnected phone started to reboot itself like for 8 minutes. Automatically turned itself on and off, repeatedly.

    4.While I do notice that the battery lasts more than in the 950XL, in my opinion it's not that much either, a little over exaggerated. Same thing with performance, there's not that much of a difference for me, nor phone nor in continuum.

    5. The phone is sold as an AT&T certified phone according to MS page, I wanna know what on earth that means. Gets LTE like my L950XL, which never said to be a AT&T certified phone, not LTE enhanced support, average, almost poor speeds on LTE. (I get 20MB's down tops when other phones get 50MB's down, and around 2-4 MB's up while other devices get around 8-14 MB's for upload.

    6. No 60fps 1080P video recording? It's a joke right? What about the camera that says it's 16MP and the camera app says it shoots at 10MP? AND THOSE ANNOYING CAMERA SOUNDS that can't be turned off!!


    As sad as it is for me to say this, but I miss my L950's reliability a little bit. I've been with windows since WM days, and WP7 and every step of the sad way, but to be honest, I'm not satisfied with what I have, I have a $800 phone that doesn't performs like it costs and feels like a beta phone somehow. Hate that I can't turn off the camera shutter. Even though brightness is at minimum, it's still too much bright to use it comfortably on a movie theater for example. Proximity sensor does not works when a Bluetooth device is connected. And worst of all, this device is already obsolete, when they start pushing for x86 support on snapdragon 935 this will just cease to exist, a device that's been out barely for a year...
    01-23-2017 10:09 PM
  3. technogi's Avatar
    Any time I try and take a picture with HDR selected my camera crashes. WIth HDR not selected it works fine? Also it seems like no External Hard Drives work when plugged into the desk dock?
    02-26-2017 08:34 PM
  4. Mark Kaplan's Avatar
    Anyone else experiencing the SD card disconnecting randomly?
    03-03-2017 10:41 AM
  5. invisik's Avatar
    Yes, once a day to as little as once every couple of weeks.

    I also have the revised sim/sd card tray.... Makes no difference for me.

    -m
    03-03-2017 01:53 PM
  6. Netwolf-irc's Avatar
    As of March 3, 2017; VPN on HP Elite X3 is completely broken. Any firmware or OS updates have failed to fix this. So have reports to HP or Microsoft via feedback.

    Not Working:

    1. IPSec/PPTP with L2TP with PSK (or cert).

    - The VPN connects, but Edge fails to route the traffic properly through VPN. Changing location setting does not help. Checks are being made by visiting whatsmyip.org after connecting via VPN.

    2. Any Connect with Shared Cert/Password

    - The password is never accepted as valid.

    Other devices:

    In both instances, the same when repeated on an iPad, iPhone and Android tablet with the same information work out of the box. Also, works on Lumia 950 XL; making it a uniquely HP Elite x3 problem
    03-03-2017 08:18 PM
  7. Mark Kaplan's Avatar
    Follow up. I opened an HP Support ticket. They just called and said they were sending a replacement tray to fix a known issue.
    03-04-2017 02:13 PM
  8. stephanejap's Avatar
    Just got my replacement tray, put my sim and micro-sd in, turned on the phone, put in my pin, got to the start screen and... SD card DISMOUNTED!!!!!!
    03-09-2017 05:19 PM
  9. Mark Kaplan's Avatar
    Yep, replacement tray did not solve the issue for me either. Now support isnt responding.
    03-10-2017 06:58 AM
  10. smolsson's Avatar
    I did have the SIM issue a couple times a week or so ago, but not since (Hopefully not jinxing myself). However since the last week or so I have been getting multiple freezes a day to where I have to reset the phone. Not sure what's driving that since I have not made any changes over this time.
    Any ideas?
    03-21-2017 12:55 PM
  11. Durahl's Avatar
    Anyone else having issues with charging the phone using any other method than the Dock or the Qi?
    I for one can't charge it anymore using the Traveler Charger or via connecting it to a PC's USB Port.
    It also won't make a connection to any of my PC's via the USB Port - PC's won't make the connection sound.
    aximtreo likes this.
    06-30-2017 03:58 PM
  12. Nate W's Avatar
    5. The phone is sold as an AT&T certified phone according to MS page, I wanna know what on earth that means. Gets LTE like my L950XL, which never said to be a AT&T certified phone, not LTE enhanced support, average, almost poor speeds on LTE. (I get 20MB's down tops when other phones get 50MB's down, and around 2-4 MB's up while other devices get around 8-14 MB's for upload.
    You are right. I never noticed the AT&T Certified description. Why in the world does it not IMS register then? I am going to call AT&T about this and ask. Any luck on your end? I am going to ask AT&T what that means exactly.


    Also a new FW was pushed today. Maybe network tweaks are included?

    UPDATE found this out: so the Elite X3 is certified. But on the certified pages of IoT devices. So HD voice seems out of the question. Also VoLTE. However something else may be in the works....http://iotdevices.att.com/certified-devices.aspx
    Last edited by Nate W; 07-13-2017 at 09:03 PM.
    07-13-2017 05:15 PM
  13. jes1888's Avatar
    You are right. I never noticed the AT&T Certified description. Why in the world does it not IMS register then? I am going to call AT&T about this and ask. Any luck on your end? I am going to ask AT&T what that means exactly.


    Also a new FW was pushed today. Maybe network tweaks are included?

    UPDATE found this out: so the Elite X3 is certified. But on the certified pages of IoT devices. So HD voice seems out of the question. Also VoLTE. However something else may be in the works....http://iotdevices.att.com/certified-devices.aspx
    I don't know man, I stopped using it and got an s8+ . U don't ask I don't tell, mine was mixing signals from different carriers and affecting the real one. Bunch of interrupted calls and everything. In on the talk of getting a refund from hp, we'll see how it goes. I'll still be here, since I carry wp closely in the heart
    Nate W likes this.
    07-15-2017 12:47 AM
  14. kenuck13's Avatar
    two or three times a week i need to re-boot because the screen simply will not go to sleep. does anyone else have this issue?
    08-01-2017 01:04 PM
  15. ryanlrobinson's Avatar
    two or three times a week i need to re-boot because the screen simply will not go to sleep. does anyone else have this issue?
    Sometimes. Probably more like 1-2 times a month rather than 2-3 a week, but yes, I have experienced that.
    08-01-2017 02:25 PM
  16. nwuankwo's Avatar
    my camera flicker when i open it,especially for the first time. It happens after the latest firmware update. anyone having the same issue?
    Nate W likes this.
    08-02-2017 08:42 AM
  17. MsftMan's Avatar
    my camera flicker when i open it,especially for the first time. It happens after the latest firmware update. anyone having the same issue?
    Yes, this happens with the default camera app. The hesitation from first opening and seeing the viewer then a brief flicker and the viewer comes up again. Oddly enough, this behavior doesn't happen with ProShot.
    08-02-2017 11:01 AM
  18. Nate W's Avatar
    Yes, this happens with the default camera app. The hesitation from first opening and seeing the viewer then a brief flicker and the viewer comes up again. Oddly enough, this behavior doesn't happen with ProShot.
    Ironically the default camera app does not flicker on the 950 XL though.
    08-04-2017 12:54 PM
118 ... 345

Similar Threads

  1. Pictures + Videos Taken With My HP Elite X3
    By Indistinguishable in forum HP Elite x3
    Replies: 47
    Last Post: 10-13-2017, 04:03 PM
  2. [Showing Off] My HP Elite x3 Start + Lock Screen
    By Indistinguishable in forum HP Elite x3
    Replies: 15
    Last Post: 03-25-2017, 10:29 PM
  3. HP Elite X3 Unboxing - Not in English
    By cwinger in forum HP Elite x3
    Replies: 12
    Last Post: 08-19-2016, 08:10 AM
  4. Web developers can now use Twitter to report Microsoft Edge bugs
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-11-2016, 02:11 PM
LINK TO POST COPIED TO CLIPBOARD