07-13-2017 07:13 PM
26 12
tools
  1. gamo62's Avatar
    For those wondering if Visual Voicemail works on the Elite X3 with AT&T, it does. Just had to log in, and it showed up. I know the 950/950xl dual SIM did not work right out of the box. I am running the production ring AU.
    RumoredNow, kurtd and TechFreak1 like this.
    09-15-2016 11:25 AM
  2. kurtd's Avatar
    That's good to know. We have Lumia icons on verizon and since verizon hates us, they can't seem to support it. Have you checked to see if any Wi-Fi calling settings are on the phone?
    Alex Zapata likes this.
    09-15-2016 04:41 PM
  3. Zulfigar's Avatar
    For those wondering if Visual Voicemail works on the Elite X3 with AT&T, it does. Just had to log in, and it showed up. I know the 950/950xl dual SIM did not work right out of the box. I am running the production ring AU.
    Correct, the 950/950xl dual sims didn't work right out of the box because there was an OS update that enabled it, which the Elite X3 has.
    09-15-2016 05:59 PM
  4. Alex Zapata's Avatar
    Originally posted by kurtd
    That's good to know. We have Lumia icons on verizon and since verizon hates us, they can't seem to support it. Have you checked to see if any Wi-Fi calling settings are on the phone?
    Indeed, I'm curious to see if many of these features work on T-Mobile as well.
    09-15-2016 09:15 PM
  5. q21701's Avatar
    How did you set it up exactly? I just switched to att and got my elite yesterday.
    09-16-2016 05:15 AM
  6. Albatross2's Avatar
    How did you set it up exactly? I just switched to att and got my elite yesterday.
    On AT&T you need to call the voicemail number the first time, use the voicemail icon at the bottom of the call history screen to do this. Once you've made the initial call in and set up your voicemail with a pin the visual voicemail icon should apper at the top of the screen a few seconds after your initial call ends.
    09-16-2016 12:13 PM
  7. PerfectReign's Avatar
    That's what I did on my 950xl, which has both an AT&T as well as a T-Mobile SIM. VVM works on the device.

    I expect the Elite X3 will work same.


    Would LOVE VoLTE.
    09-16-2016 01:48 PM
  8. Kadafi24's Avatar
    Originally posted by Albatross2
    Originally Posted by q21701
    How did you set it up exactly? I just switched to att and got my elite yesterday.
    On AT&T you need to call the voicemail number the first time, use the voicemail icon at the bottom of the call history screen to do this. Once you've made the initial call in and set up your voicemail with a pin the visual voicemail icon should apper at the top of the screen a few seconds after your initial call ends.
    I did my initial voicemail set up after receiving my phone but now I'm trying to set up my visual voicemail but can't seem to find this option
    09-16-2016 09:57 PM
  9. josephan's Avatar
    If it doesn't set up the first time, try resetting your voicemail password on the ATT website. Wait a few minutes then call in into the voicemail through the phone app. It will have you set a new password, greeting, etc. When finished with your settings, hang up and a few minutes later the visual voicemail icon should show up on the top menu. I had to do this a couple of times to get it.
    TechFreak1 and RumoredNow like this.
    09-16-2016 11:21 PM
  10. DUITDale's Avatar
    that worked perfectly ...(with a prior AT&T phone and voicemail used) ...just dialed voicemail from Call History - beautiful!!!
    I don't know how long I'd have gone before I did that if you hadn't posted this. Thanks
    10-27-2016 08:49 PM
  11. chsoriano's Avatar
    Not sure if anyone knows, but I started using iSeeVM back when the 950XL just came out because it didn't have support. Since then, I haven't been able to get the built-in visual voicemail to work.

    Do I have to turn off iSeeVM by dialing the special code before the phone will recognize that I have AT&T visual voicemail when I call my AT&T voicemail? Right now after I call my AT&T voicemail, it doesn't ask me for my voicemail PIN like it is supposed to.
    10-29-2016 10:43 PM
  12. RumoredNow's Avatar
    Do I have to turn off iSeeVM by dialing the special code before the phone will recognize that I have AT&T visual voicemail when I call my AT&T voicemail?
    Yes.

    ISeeVM changes the forward to # when you don't answer to YouMail. Turning off ISeeVM will restore the default forward to # which goes to your carrier.
    10-30-2016 08:59 AM
  13. nate0's Avatar
    If on AT&T do you guys see advanced LTE services enabled/IMS registration also? Thanks.

    Sent from my phone
    10-31-2016 11:57 AM
  14. chsoriano's Avatar
    So I've actually been seeing the network indicator flash between LTE and LTE+ but it never consistently remains LTE+. So I don't think it's actually working.
    jtshorns likes this.
    10-31-2016 11:58 AM
  15. Daniel Rubino's Avatar
    So I've actually been seeing the network indicator flash between LTE and LTE+ but it never consistently remains LTE+. So I don't think it's actually working.
    I see that too
    jtshorns likes this.
    10-31-2016 03:29 PM
  16. nate0's Avatar
    Found out some interesting information. While speaking to AT&T about my Elite X3 tonight and making sure it was registered on their backend properly, they informed me that the Elite X3 is not on their list of HD Voice capable devices YET. Any news out there regarding this?

    They seemed confident in that they are just waiting on the news between AT&T/HP for it to be a sealed deal....Or do you think this was just blown smoke? I recall an article out there where the Microsoft 640s got the HD Voice updates pushed to them, so I am hopeful the X3 gets this soon.
    11-06-2016 10:48 PM
  17. Albatross2's Avatar
    The AT&T Branded Lumia 950 gets HD Voice on the At&T network but the Microsoft Branded version does not. It is identical hardware. The only difference is the provisioning on the back end. I will be stunned if the Elite X3 is treated any different than the MS Lumia 950.
    11-07-2016 08:58 AM
  18. chsoriano's Avatar
    Yeah... I'd love to see the X3 get full LTE-A wi-fi calling, HD voice, etc.... But don't hold your breath
    Alex Zapata likes this.
    11-07-2016 09:04 AM
  19. nate0's Avatar
    I wad pretty amazed to see my questions answered this way, they even put me on a priority mailing list to be notified. Could just be their standard operating procedure though.

    Sent from mTalk
    11-07-2016 09:07 AM
  20. Daniel Rubino's Avatar
    Found out some interesting information. While speaking to AT&T about my Elite X3 tonight and making sure it was registered on their backend properly, they informed me that the Elite X3 is not on their list of HD Voice capable devices YET. Any news out there regarding this?

    They seemed confident in that they are just waiting on the news between AT&T/HP for it to be a sealed deal....Or do you think this was just blown smoke? I recall an article out there where the Microsoft 640s got the HD Voice updates pushed to them, so I am hopeful the X3 gets this soon.
    HP was getting their phone certified for AT&T; not the same as selling it or branding. Means, however, that the phone should use most AT&T services out of the box.

    I suppose HP could do it in the firmware, but not 100% sure.
    nate0 likes this.
    11-07-2016 01:36 PM
  21. nate0's Avatar
    HP was getting their phone certified for AT&T; not the same as selling it or branding. Means, however, that the phone should use most AT&T services out of the box.

    I suppose HP could do it in the firmware, but not 100% sure.
    Is that certification still pending?

    Sent from mTalk
    11-07-2016 01:56 PM
  22. spyderzWPC's Avatar
    I see you guys say you see lte and lte+ for some reason I only see h and h+ have you had that issue? I am on At&t in the boston area.
    11-10-2016 11:16 AM
  23. nate0's Avatar
    I see you guys say you see lte and lte+ for some reason I only see h and h+ have you had that issue? I am on At&t in the boston area.
    I only see that (H H+) when placing or receiving phone calls. The LTE+ appears for me on occasion but for a mere second then goes away, as described here.

    Sent from mTalk
    11-10-2016 12:20 PM
  24. chsoriano's Avatar
    Yeah, in addition to occasionally while on calls, I also see it in various spots around Houston, TX. So may just depend on your area and what AT&T might be doing on the towers in your area.
    11-10-2016 12:26 PM
  25. PerfectReign's Avatar
    FWIW, I have an ATT SIM and get vvm




    Sent from mTalk
    libra89 likes this.
    11-10-2016 02:11 PM
26 12

Similar Threads

  1. Update Stalled at 45%
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2016, 02:18 PM
  2. weird yellow line and touch failure
    By abhishek singh21 in forum Microsoft Lumia 535
    Replies: 1
    Last Post: 09-17-2016, 07:41 AM
  3. Anyone got this working on AT&T with Windows 10
    By jacksonmf in forum Samsung ATIV SE
    Replies: 3
    Last Post: 09-16-2016, 07:00 AM
  4. Essential ReCore tips and tricks for beginners
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-15-2016, 11:11 AM
  5. PrioVR and what it means for Oculus Rift
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-15-2016, 10:42 AM
LINK TO POST COPIED TO CLIPBOARD