Black Friday is almost here!

Get the inside track on all the best deals.

03-07-2018 10:32 PM
168 1234 ...
tools
  1. Mark Kaplan's Avatar
    I'm also having this issue. It happens once or twice daily. Quite annoying actually.
    03-03-2017 05:21 PM
  2. JaimitoFrog's Avatar
    Originally posted by Darkie On
    I had the same problem SD card removed. got a 2nd X3, same problem. got 2 different sim tray, same problem.

    but since I've turned off my Bluetooth service, no longer have the problem. after 3 weeks of no Bluetooth, my x3 had not reported SD card removed error.
    I have just turned my Bluetooth back on. so far, error has not recurred.
    Getting this problem more frequently these days. I updated the fw and latest fast ring. But likely not related. But if a new sim tray doesn't help, maybe it is software. I might try ur BT off approach.
    03-05-2017 08:03 PM
  3. Clive Rennie's Avatar
    I recieved a new sim tray problem went away then came back a week after they sent me a new phone and yes the problem is still there i was told to keep both phone to compare for awhile and with the new sim tray in the first one the problem is on and off so i have been reporting back to them that i have the problem on both units one with the anniversary update and one with the new preview update. so we will see what they will do dont want to give up my X3 i love it but i might have to and stick with my L950xl.
    03-06-2017 06:22 PM
  4. Mark Kaplan's Avatar
    I had a call today from someone that seemed to know there is a known issue with the phone and how it deals with larger cards. I expect they will need to issue a firmware update to truly solve the problem.
    JaimitoFrog likes this.
    03-06-2017 07:21 PM
  5. fgol's Avatar
    I had the same problem SD card removed. got a 2nd X3, same problem. got 2 different sim tray, same problem.

    but since I've turned off my Bluetooth service, no longer have the problem. after 3 weeks of no Bluetooth, my x3 had not reported SD card removed error.
    I have just turned my Bluetooth back on. so far, error has not recurred.
    I suspect you're correct that BlueTooth is related. A few times I have gotten the SD Removal message immediately after my phone sent a notification to my Band.
    Last edited by fgol; 03-07-2017 at 02:24 PM. Reason: Adding quoted text, which I thought Reply to a post did automatically....
    03-07-2017 02:22 PM
  6. Mark Kaplan's Avatar
    I received the replacement tray and it had no effect. I did have the older tray but the new one did not resolve the disconnecting issue. I tried turning Bluetooth off completely but I still got the error. I believe this is going to need a firmware fix.
    03-07-2017 06:43 PM
  7. Narathan's Avatar
    Makes me wonder if this bug got introduced with the latest firmware since I've never had this problem before on this phone, including reboots out of nowhere. Phone works fine without card though. Going to try my older 32gb card to see what happens.
    03-08-2017 04:24 PM
  8. cnashx's Avatar
    I was told today that it could be the card causing this issue.
    They are supposed to be sending me a list of cards that work and ones that have issues.
    03-08-2017 04:30 PM
  9. Narathan's Avatar
    Well, phone just went into a reboot after trying to move some music to it. Guess I'll have to stick with my 950XL for now :(.
    03-08-2017 05:57 PM
  10. Mark Kaplan's Avatar
    I'm not seeing the reboots but the SD card disconnect is really annoying. Share the list of cards they claim will work when you get it.
    03-08-2017 07:33 PM
  11. JaimitoFrog's Avatar
    Maybe we can list the cards in issue here? I have a Sandisk 128GB.
    I wonder if reformatting it from scratch will help. Anyone tried that?
    03-08-2017 09:11 PM
  12. Mark Kaplan's Avatar
    Mine is a 200gb SanDisk.
    03-09-2017 12:26 AM
  13. emmeborn's Avatar
    03-09-2017 02:54 AM
  14. cnashx's Avatar
    I haven't gotten the email yet, but they told me that over 64GB Sandisks have problems for sure. (I have a 128GB Sandisk)
    03-09-2017 09:07 AM
  15. JaimitoFrog's Avatar
    I don't recall having this problem so often when on production build. I'm now on fast ring. What about the rest of you?
    03-09-2017 09:16 AM
  16. cnashx's Avatar
    I don't recall having this problem so often when on production build. I'm now on fast ring. What about the rest of you?
    I've kept my x3 on production build, unlike my 950xl as I didn't want issues with HP firmware.
    03-09-2017 10:07 AM
  17. PerfectReign's Avatar
    There's been a running discussion on the Elite X3 support forum at HP. I have the new tray, a 32gb sd card, and no issues.

    http://h30434.www3.hp.com/t5/Elite-x.../6020181#M1051

    Sent from mTalk
    03-09-2017 10:20 AM
  18. Mark Kaplan's Avatar
    That's too small a card for me. I currently use a 200gb card that is half full.
    03-09-2017 10:55 AM
  19. Narathan's Avatar
    I've tried the Sandisk 32GB and that rebooted my device, but I read that was a problem in the Fast Ring preview. I'll give it another try with the latest build.

    My other cards were Samsung Evo 64gb and 128gb cards.

    UPDATE: Left the phone idle for a few hours and it seems to run fine with the Sandisk 32GB card. I don't have the new tray, this phone is part of the first batch.

    Going to switch out the 128gb card again, see whats different. Will try a format. There's got to be an explanation.

    Second update: So far no unmounts, but I do get the message "scan your sd card for errors" every time I reboot the device. Seems fine... for now.
    Last edited by Narathan; 03-10-2017 at 05:19 AM.
    03-09-2017 01:43 PM
  20. Narathan's Avatar
    Alright. Still a disconnect. Going to stick to the Sandisk 32gb card for now since that one arena to work fine. This definitly is firmware related. The 128gb card always worked just fine before the last firmware update. Hope they bring out a fix soon!
    03-10-2017 06:31 AM
  21. Narathan's Avatar
    Nevermind. This one is ejecting as well. Giving up for now.
    03-10-2017 07:43 AM
  22. JaimitoFrog's Avatar
    Hope a new fw from hp coming soon.
    03-11-2017 11:09 AM
  23. MOBBAK's Avatar
    Hope a new fw from hp coming soon.
    I think we should see a new FW from HP when Redstone 2 has been released from Microsoft.
    03-12-2017 03:42 AM
  24. emmeborn's Avatar
    I have kept my X3 on Fast ring since the beginning, but I think the problems with my 64GB Sandisk card begun a couple of firmwares ago.
    Last edited by emmeborn; 03-13-2017 at 05:22 PM.
    03-13-2017 09:00 AM
  25. JaimitoFrog's Avatar
    Called hp support. They said they have a new sim tray. The older one says 1, 2 on it. Newer one says Top on it. I doubt this will work. Anyone got the newer one?
    03-13-2017 09:18 AM
168 1234 ...

Similar Threads

  1. Dual SIM CARD question
    By crg28 in forum Microsoft Lumia 950 XL
    Replies: 15
    Last Post: 03-08-2017, 07:52 PM
  2. How can we get a listing of all apps installed on the microSD card?
    By Doctor_Who in forum Microsoft Lumia 640
    Replies: 6
    Last Post: 12-17-2016, 01:21 PM
  3. This 64GB Transcend UDMA compact flash card is yours for 34
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-15-2016, 05:00 AM
  4. Ethernet cards don't work except from boot disk
    By rollob in forum Windows 10
    Replies: 8
    Last Post: 12-11-2016, 08:02 AM
  5. Why Can't I Move Groove Music Onto A SD Card?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-11-2016, 12:33 AM
LINK TO POST COPIED TO CLIPBOARD