1. thrash994's Avatar
    Finally we received 8.1.1 and I had hope for my phone but today it totally disappointed me.
    Today my 8S went unresponsive and froze 3 times in a row and probably will freeze few more times. Each time I had to wait more than 5 minutes to boot up. I'm done with this crap device.
    Going to buy L1320 this week.
    10-22-2014 10:57 AM
  2. BatteryLife's Avatar
    Try a hard reset and do not restore data maybe. There may not be a clean installation.
    10-22-2014 11:00 AM
  3. thrash994's Avatar
    I have never wanted to do hard reset because I'm too lazy to backup everything on it and then install everything once again. But thankfully it's fine now.
    10-22-2014 02:32 PM
  4. xandros9's Avatar
    Guess no 1320 eh?

    but yea, sometimes an update leaves junk around and stuff.
    10-23-2014 05:44 PM
  5. thrash994's Avatar
    Still no 1320, but in a few hours I'm going to buy it. Finally available in a store in other city near me for 270 euros which is 340 dollars (something like that).

    I have one question. Can I use the same account on L1320 that I'm using right now on 8S?
    10-24-2014 07:01 AM
  6. charlatan1978's Avatar
    Hi, you should be able to.
    I'm using the same account on my HTC 8S and Nokia Lumia 625.
    10-24-2014 07:13 AM
  7. thrash994's Avatar
    Finally, I bought L1320 :)
    xandros9 likes this.
    10-24-2014 02:45 PM
  8. thrash994's Avatar
    This phone is still proving me that it's not worth anything. Today I set up an account for my dad, he wanted this phone for him. So I signed up a new account for him. The phone was already reset so I've just logged in with the new account but suddenly from nowhere the default camera app stopped working. Whenever I tried to launch the camera it got me back to the Start. I did 4 hard resets so far and that didn't solved the problem. After the 3rd reset the backup didn't finished as it should so nothing was complete and I was not able to log into the account to sync the contacts. Right now I'm doing another hard reset just for the contacts and honestly I don't give a single f u c k about the camera. I'm going to leave the phone as it is. I have installed Camera360Pro Beta and it's working fine. I just want everything else to work as it is meant to. TO EVERYONE OUT THERE WHO ARE STILL BUYING THIS LITTLE PIECE OF S H I T, IT'S NOT WORTH GUYS. There are plenty other Lumias!

    P.S. I love my Lumia 1320!

    Update: Somehow I managed to get things back to normal after 5 hours of struggling. The support account on twitter was unable to help me so I found out by my own. I have no idea how it is possible but the phone language was causing the problem, so I set it back to English and it's working like a charm now.
    Last edited by thrash994; 11-16-2014 at 08:34 AM.
    11-15-2014 06:16 PM

Similar Threads

  1. Replies: 168
    Last Post: 11-04-2014, 12:05 PM
  2. Replies: 10
    Last Post: 10-22-2014, 06:14 PM
  3. Haunted Humpday Sale: This versatile HTC One M8 flip case is only $22.95 today!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-22-2014, 10:42 AM
  4. Clash Of Clans
    By Joewill Ryell Donny in forum Ask a Question
    Replies: 1
    Last Post: 10-22-2014, 05:03 AM
  5. Microsoft's rumored wearable device may have passed FCC approval
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-21-2014, 08:11 PM
LINK TO POST COPIED TO CLIPBOARD