1. zethymir's Avatar
    Well it look s like it.
    I just got it today, started charging it, set up an account, downloaded skydrive. Then i wanted to test the camera button, tried when i was in a browser, all that happened was that it flipped to the apps window then back again to the browser.
    I tried to use the camera button with the screen turned off, nothing.
    Tried to use it in the main window and again it flipped to the apps winow and back again. Went to the apps window and clicked the camera icon, and nothing happened.
    I unplugged it from the usb and it turned off. I can't seem to get it on again, if i hold he power button for a couple of seconds it vibrates, but that's about it. It had been charging for about 40 minutes. And it doesn't react in any way when i plug it back into the charger either.
    Anyone know anything about this? Suggestions?
    11-12-2012 04:10 AM
  2. hipporama's Avatar
    Probably a bad piece. Get it exchanged.
    11-12-2012 08:07 AM
  3. CaptDjob's Avatar
    Hard reset?
    11-12-2012 08:59 AM
  4. MojoHand69's Avatar
    Sounds like a bad unit. I would exchange.
    11-12-2012 10:36 AM
  5. zethymir's Avatar
    Tried hard reset, but no reaction at all.

    Yeah, i've already issued warranty on it. I remembered it was having other issues from when it started up, screen freezing as well.
    11-12-2012 10:10 PM