1. shinygerbil's Avatar
    Had a weird problem with my 8X today. Pulled it out to go on the internet, and saw it had no signal - but my page loaded. Was a little spotty, but I still had internet. (Definitely not WiFi.) I put it back in my pocket, assuming it just had a little bit of signal and would sort itself out. I received an email, pulled out the phone again to check it and noticed I still had no signal; decided to reboot. After the reboot, signal came back - along with text messages from my gf who'd been calling me for the last 15 minutes!

    That's not the first loss of signal I've had with the phone, although usually it comes back in a couple of minutes. Anyone else had anything similar?
    11-20-2012 12:15 PM
  2. iamtim's Avatar
    I had almost that exact thing on my 920; the only thing that cured it for me, however, was restarting the phone. My 8X hasn't seen that issue though.
    11-20-2012 12:17 PM
  3. David Horn's Avatar
    An easy way to restore the correct signal bar is to make a quick phone call - this seems to reset the display.
    11-21-2012 04:17 AM
  4. shinygerbil's Avatar
    Ah, I'll try that next time. I think we can agree that it shouldn't be happening in the first place though :p
    11-21-2012 06:28 AM

Similar Threads

  1. No Data Connection After Low Signal/No Signal
    By Fuzzy John in forum Windows Phone 7
    Replies: 1
    Last Post: 02-24-2012, 01:16 PM
  2. No Notification but then I plugged my phone
    By campbellc in forum Windows Phone 7
    Replies: 3
    Last Post: 09-27-2011, 04:32 PM
  3. No signal, means no data connection?
    By jeff4L in forum HTC HD 7 / 7s
    Replies: 6
    Last Post: 04-20-2011, 01:58 AM
LINK TO POST COPIED TO CLIPBOARD