09-14-2014 08:59 PM
165 ... 567
tools
  1. prettyconfusd's Avatar
    Hi Lucy, this thread has loads of people saying how to fix this!

    Either apply a few layers of tape to the back of the sim card and put it back in the phone or send it back to HTC.

    Most people here have used the tape option with no problems. Sending it back to HTC will result in your phone getting wiped.
    06-10-2013 07:47 AM
  2. gettysburg11s's Avatar
    Dude, thanks so much. I have a Lumia 900 as my backup phone, and I put a microsim adapter in it along with the nano sim from my iPhone 5, and I got nothing. As soon as I tried your idea, it worked perfectly.
    08-05-2013 06:25 PM
  3. Svetoslav Enkov's Avatar
    But I noticed that the two phones that were having the issue were both using a particular case that the other 3 were not. This particular case requires that you press a little harder on the power button to wake the phone up. The power button just happens to be on the same corner as the SIM tray. I wonder if the corner of the phone is put under too much pressure because of the case. Anyone else having this problem using a case requiring you press hard on that corner of the phone? Anyone without a case having this problem?
    I am aware of this so I have bought (waiting for a slow delivery from China) hard skin case to replace my lovely TPU Soft gel case. I have noticed that that the pressure is too much on the power button with this TPU cases. The Nillkin hard cases (I have same for my old ZTE Tania) have open areas for the buttons, this is not good for dust/spill protection, but lowers the pressure... Also I have preventive attached two layers of scotch on the bottom of the SIM card. My phone to date have only one restart when the phone was on table and I was in the bathroom and it have ringing and vibrating two minutes before I pickup - on pickup it restarted. The phone is a month age old, this restart happen on 3-rd day (and on fifth day I attached a scotch and no more problems).
    08-11-2013 05:15 AM
  4. HeavyHanded's Avatar
    This morning my phone worked. Then as I left the house, I got the dreaded "No Sim" on my phone tile. Rebooted many times. Tried the tape method until I could barely close the SIM Door. Nothing. Didn't recognize the SIM. Then I put the SIM, back into my iPhone 4 and that didn't recognize the SIM either. Somehow, the 8X destroyed my the SIM. Maybe there is a short somewhere? I'll try and get my SIM replaced tomorrow. If it works in my iPhone but not in my 8X i'll call in the global warranty service.
    10-08-2013 08:58 AM
  5. HeavyHanded's Avatar
    Well, good news. I got a new sim and everything is great, again. Hopefully I didn't damage my phone by shoving thick taped Sims into the tray.
    10-12-2013 10:35 AM
  6. John Ostrowski's Avatar
    I was having sim card errors and my 8x randomly shutting its self off so I thought of it as a computer and took off my case and now its fixed. Its over heating so if your phones are in cases try taking them off and see if it fixes for you.
    11-15-2013 05:27 PM
  7. mgilb4's Avatar
    Make your service provider give you a new phone.

    I have had my htc 8x for a year now. The first 6 months I had it, this only happened once every other month. Slowly it started to happen more often. Then, the phone started to randomly reboot itself. Even better, sometimes it would just turn itself off -- especially useful when your phone doubles as an alarm clock. Then, I intermittingly would not be able to send text messages. Finally, my phone started having sim card errors while I was on the phone. This causes the phone call to end suddenly with no warning.

    I went to verizon wireless to switch out my sim card. The result of this was that now every single text I send I has to be sent three times before it goes through.

    Verizon is sending me a new phone. Save yourself the hassle.
    12-12-2013 01:56 PM
  8. laurent laurent's Avatar
    I had the same issue on my Lumia 1020.

    I discovered that happend when the "tap+send" (NFC) is on.
    Maybe due to an interference the phone reboots with a "sim Error" message.

    I was able to replicate this problem by placing my phone on various electronic devices.

    I hope that the next firmware will fix this. In the meanwhile, I don't need (NFC)

    Cheers.
    12-27-2013 06:04 AM
  9. djstrife's Avatar
    so ridiculous...I had the phone about 10 months and it started doing the "invalid sim error" more often and shutting off by itself. I went to T-mobile and it was still under warranty. Got a replacement phone now for 2 months and now it's started doing the same thing again...at a loss of what to do!
    nohra likes this.
    02-19-2014 09:53 AM
  10. berty6294's Avatar
    so ridiculous...I had the phone about 10 months and it started doing the "invalid sim error" more often and shutting off by itself. I went to T-mobile and it was still under warranty. Got a replacement phone now for 2 months and now it's started doing the same thing again...at a loss of what to do!
    I've got a crazy idea that may or may not have been mentioned yet... try putting a piece of tape on the back of the sim card!
    02-19-2014 09:57 AM
  11. emiotto20's Avatar
    how do i stop it sayi ng sim error
    05-07-2014 06:34 AM
  12. prettyconfusd's Avatar
    how do i stop it sayi ng sim error
    Really?! There's an entire thread here with solutions and you still needed to ask?

    In fact the post directly above yours answers your question!

    Read the thread, there's only seven pages of it. Hardly 'War and Peace'... :)
    05-07-2014 01:18 PM
  13. Johntee540's Avatar
    I just read this entire thread - and just did the fix. I will let you know how it all goes. I have had both the message and the reboot problem now for several months. I have resisted replacing the phone as I have too much on it to go through the hassle of re-installing and moving everything. I have good hope that this will work. Be Good - JT
    05-15-2014 10:20 AM
  14. champion7891's Avatar
    Hey guys sorry for restarting this thread. I have recently faced this "no service" issue after I had the repeated reboot problem. Thats solved now but I have the sim issue.

    I have 2 sims, for carrier A and carrier B. Both work fine in my other HTC 8X.

    When insert sim 1 in the affected phone, in network options it does detect the sim (it tells me that the sim is of carrier A), but there is not network service. At first I though it was a sim issue or a seating issue so I applied the tape fix. Didnt work. SO i put in my other sim, of carrier B, Its detected as carrier B sim if I go to network options in settins, but i get zero bars and no service

    Any ideas
    09-08-2014 11:14 AM
  15. WickedCold's Avatar
    This is a known issue with the HTC 8x SIM card tray. Same thing happened to me with mine. (Constant Shut offs, SIM card errors etc)
    I had my SIM card replaced and this seemed to fix it for awhile. The error came back and I contacted HTC about it and they sent out a replacement SIM card tray. The error has for the most part disappeared.
    09-14-2014 08:59 PM
165 ... 567

Similar Threads

  1. Replies: 16
    Last Post: 08-19-2014, 12:09 AM
  2. Replies: 14
    Last Post: 02-21-2013, 12:45 PM
  3. Replies: 15
    Last Post: 02-04-2013, 06:46 AM
LINK TO POST COPIED TO CLIPBOARD