1. ZachieChan's Avatar
    Does anyone else have data connection issues? For example, it says I have 3g but in reality I have no data service? This goes on and off and the only solution to this is turning my phone off then on. This seems to happen when I lose my data, "regain" it according to the top left icon, then when I try to use the internet it doesnt work. Also when I have the fake 3g symbol, after I wait about an hour or so not using my phone I attempt to use the internet and it magically works? Very annoying and the worst pet peeve of this phone. I have put the SIM card in and out and doesnt seem to solve this. I did have SIM card issues where the SIM card error would show up, but with the latest firmware updates it is now fixed. Anyone else experience these connection issues? Also wi-fi works fine for me.

    05-06-2013 01:31 AM
  2. chomsky11's Avatar
    Sounds like you're simply in a bad coverage area. I have had my 8X for a month now and live in San Francisco, and have had no data issues. I'm on T-Mobile. I get 5 bars almost exclusively when I'm not on WiFi. If you have to turn the phone off and on though to get data you may have a bum handset and will need to swap it.
    05-06-2013 02:02 AM
  3. Dennis Kerney's Avatar
    Instead of resetting the phone to get your reception back, try toggling Airplane mode. I have the same issue, and I believe that it is caused by being out of reception frequently. If you are out of reception for more than a few minutes, it just stops searching for a signal for a while, I assume in order to save battery life. Sometimes it'll show that I have bars of 3g/4g, but it is just showing what I had before reception was lost. Toggling Airplane mode always fixes it.
    05-06-2013 09:26 AM
  4. rdifiori's Avatar
    Pull the sim card out and put a piece of scotch tape on the back of it. Trim the tape so it matches the shape of the card. Reinsert the card. This makes the card press harder against the contacts in the phone. This cured the problem for me. If the sim card is loose and loses connection, the internet connection drops and will not recover until the phone is restarted or until it is put in and out of airplane mode.
    05-06-2013 09:58 AM
  5. ZachieChan's Avatar
    Thanks for the replies! I do live in a small rural area in Northern California and the service is spotty, especially in buildings, and speeds aren't very fast. Also Dennis, I have in fact tried toggling it in and out of airplane mode, and this only works sometimes for some reason, not all the time for me. Even if I toggle airplane mode in a good service area, it still won't pick up a connection. And rdef, thanks for the input! I will try this to see if I see any changes! Thanks. Anyone else have these problems?
    05-06-2013 10:15 AM
  6. jhguth's Avatar
    You need to tape your sim card, that will fix it
    05-06-2013 12:56 PM
  7. scottcraft's Avatar
    I'm going to try the tape. My 8X loses cell signal and data at home. It will be nice if a piece of tape fixed it.
    05-06-2013 05:15 PM
  8. ZachieChan's Avatar
    Thanks for all your replies! I have finally tried the tape method by putting 2 pieces of tape on my SIM card. And so far it works! Before I couldn't open media content sometimes but now I can all the time. I have yet to go out to try my 3G service to see if it is consistent. Also I have yet to send media content to other people since before I couldn't send other people media content occasssionally and thus I would have to turn my phone on and off. I will report back when these situations arise to see if it truly works! Thank you.

    EDIT: Also scottcraft did the tape method work for you? Would like to know if this works for you since I have read it has worked for many people.
    05-06-2013 08:06 PM
  9. scottcraft's Avatar
    Thanks for all your replies! I have finally tried the tape method by putting 2 pieces of tape on my SIM card. And so far it works! Before I couldn't open media content sometimes but now I can all the time. I have yet to go out to try my 3G service to see if it is consistent. Also I have yet to send media content to other people since before I couldn't send other people media content occasssionally and thus I would have to turn my phone on and off. I will report back when these situations arise to see if it truly works! Thank you.

    EDIT: Also scottcraft did the tape method work for you? Would like to know if this works for you since I have read it has worked for many people.
    I haven't tried yet. I'll probably do it in the morning. The trick is going to be remembering how to get the double shot case off, I haven't had it off since I put it on.
    05-06-2013 10:33 PM
  10. scottcraft's Avatar
    I just taped mine. I'll let you know how it works.
    05-06-2013 11:45 PM
  11. scottcraft's Avatar
    Looks like it doesn't help mine, no signal right now.
    05-06-2013 11:47 PM
  12. ZachieChan's Avatar
    Looks like it doesn't help mine, no signal right now.
    I see thanks for the input! I don't know if it will help you, but I put two layers of tape on mine, just to take sure it would be enough filler in case one piece didn't work.
    05-07-2013 12:10 AM
  13. scottcraft's Avatar
    I see thanks for the input! I don't know if it will help you, but I put two layers of tape on mine, just to take sure it would be enough filler in case one piece didn't work.
    I'm going to leave it in there and see if it makes a difference at all. I don't know think it will hurt to leave it so I'll see how it does.
    ZachieChan likes this.
    05-07-2013 08:41 AM
  14. Sanjaybairwa's Avatar
    Pull the sim card out and put a piece of scotch tape on the back of it. Trim the tape so it matches the shape of the card. Reinsert the card. This makes the card press harder against the contacts in the phone. This cured the problem for me. If the sim card is loose and loses connection, the internet connection drops and will not recover until the phone is restarted or until it is put in and out of airplane mode.
    12-30-2016 04:14 PM

Similar Threads

  1. Unlocked 920 - Data Connection Issue
    By DFB in forum Nokia Lumia 920
    Replies: 3
    Last Post: 12-21-2012, 04:46 PM
  2. Do I have the dropping data connection issue?
    By choover in forum Nokia Lumia 900
    Replies: 2
    Last Post: 06-01-2012, 08:49 AM
  3. Data Connection Issue Wifi + LTE
    By badMojo69 in forum Nokia Lumia 900
    Replies: 8
    Last Post: 04-25-2012, 05:39 PM
  4. Replies: 13
    Last Post: 04-10-2012, 02:15 AM
  5. Data connection issues
    By kltye in forum HTC TITAN
    Replies: 14
    Last Post: 12-06-2011, 09:51 PM
LINK TO POST COPIED TO CLIPBOARD