1. my_wolfe's Avatar
    Hi all,

    I have an AT&T HTC 8X that I just started using on the Bell Canada network. The frequences seem to be the same and it should work on both networks. When I put my IMEI number into the phone checker on the bell website it says it is a compatible phone.

    Voice and text work fine, unfortunately data does not work. It says it is on the 4G network in the top left of the phone, but I'm unable to use any apps that require data. Not sure if anyone else has had this problem or might have any idea why this is? Tech support hasn't been very helpful. Hopefully its a setting or something on bells end, although maybe the phone isn't compatible, but that would seem odd as they use mostly the same frequencies.

    I'm also unable to text images and I don't think I can receive them either (although haven't confirmed that 100 percent) not sure if that's a related issue.

    Any advice any one has would be greatly appreciated.
    05-20-2013 01:04 PM
  2. my_wolfe's Avatar
    Figured it out, needed to enter the apn data for bell's network manually.
    05-20-2013 03:04 PM
  3. fgaudet's Avatar
    I'm just about to take my HTC 8x from Rogers to Bell - have an unlock code but haven't unlocked yet (need to get another SIM first). I want to get the $30 prepaid plan + 100Mb.

    Does DataSense work on your 8x on the Bell network? They advertise the feature, but can't tell me if it will work on an unlocked phone.

    My major gripe with Rogers is their "My Account" app doesn't work for prepaid plans and neither does their web portal as far as getting info about how data I have left - I'm hoping DataSense will work!
    05-28-2013 07:36 PM

Similar Threads

  1. Nokia Lumia 900 on Net10...data problems :(
    By Jordan Miera in forum Nokia Lumia 900
    Replies: 29
    Last Post: 03-14-2013, 08:46 AM
  2. Replies: 2
    Last Post: 12-10-2012, 11:08 AM
  3. Bell Canada launching the 8X on Nov. 15th!
    By 64GUNSHIP in forum HTC 8X
    Replies: 78
    Last Post: 12-01-2012, 10:15 PM
  4. ATT Lumia 920 on FIDO Canada..will LTE work?
    By xtrip in forum Nokia Lumia 920
    Replies: 2
    Last Post: 11-07-2012, 08:32 PM
  5. Data problems on my Titan today
    By Naturewriter in forum HTC TITAN
    Replies: 7
    Last Post: 12-24-2011, 08:35 AM
LINK TO POST COPIED TO CLIPBOARD