1. saylow510's Avatar
    I recently bought the htc 8x and went to a tmobile store for a microsim. When I put my new microsim in the phone, there is no signal at all. I tried restarting, reinserting the sim. Does any know how to fix this problem?
    07-15-2013 06:36 PM
  2. Laura Knotek's Avatar
    What carrier is the device branded to? Is it a T-Mobile device, or is it a device from another carrier? If it is from another carrier, is it unlocked?
    07-15-2013 06:41 PM
  3. saylow510's Avatar
    It's branded to T-Mobile and I'm currently using T-Mobile service
    07-15-2013 06:49 PM
  4. Laura Knotek's Avatar
    It's branded to T-Mobile and I'm currently using T-Mobile service
    Did you ask anyone at the T-Mobile store for help?
    07-15-2013 07:20 PM
  5. juanitoriv's Avatar
    Make sure the sim is activated. They may have forgot at the store. A quick call to customer service should fix that.

    Also, in settings, cellular, make sure automatic is the initial set up.
    Laura Knotek likes this.
    07-15-2013 07:22 PM

Similar Threads

  1. No T-Mobile logo?
    By lghtnj in forum Nokia Lumia 521
    Replies: 21
    Last Post: 08-16-2013, 09:35 AM
  2. Nokia 920 Straight Talk "no network found"
    By katastrofee in forum Nokia Lumia 920
    Replies: 5
    Last Post: 07-18-2013, 03:33 PM
  3. Upset with HERE MAPS! Still no traffic
    By snowwake8 in forum Applications
    Replies: 11
    Last Post: 07-15-2013, 12:36 PM
  4. Facebook integration no longer working
    By Fishtoast in forum Windows Phone 8
    Replies: 3
    Last Post: 07-15-2013, 02:45 AM
  5. No Xbox Music tab on my Music+Video app
    By john_777 in forum Windows Phone 8
    Replies: 1
    Last Post: 07-13-2013, 11:15 AM
LINK TO POST COPIED TO CLIPBOARD