1. Slowpokex's Avatar
    I literally JUST got the HTC Windows 8x yesterday.
    I told my friend to text me because I really like the messaging system on the Windows phone, but when I never got his text and I mentioned it to him on Skype, through my computer.
    He said he sent a text message to me but I never got it. So I just shrugged it off.

    However, just now I texted my friend and she replied but I didn't get it. I messaged her on Facebook and she said she replied to my text.
    So, I asked her what phone she had and she replied with "iPhone". My other friend also was using an iPhone when he texted me.

    I did NOT previously have an iPhone. However, I am using my same number that I had with Verizon and I switched to AT&T when I got this new phone.

    Any solutions? I haven't been finding any and this could become a real problem :I
    07-28-2013 03:21 AM
  2. WanderingTraveler's Avatar
    Okay, it may be a problem with the network.

    Try having any non-iPhone users text you and see what happens.
    07-28-2013 03:39 AM
  3. Slowpokex's Avatar
    I had a non-iPhone user text me around the same time that she said she texted me :c
    07-28-2013 03:49 AM
  4. WanderingTraveler's Avatar
    I had a non-iPhone user text me around the same time that she said she texted me :c
    Did you receive the text? If you did, I really don't know what to say.

    I could always say that iPhones hate having to see your 8X, but that wouldn't be logical. Contact AT&T if anything strange continues to happen.

    When worse comes to worst, you''ll have to switch phone numbers.
    07-28-2013 04:18 AM
  5. Slowpokex's Avatar
    I don't care about switching numbers :I
    I'll call them tomorrow. Hopefully they can fix it if not, everyone is just going to have to get used to me having a new number.

    and if that doesn't fix it...then I don't know what will.
    07-28-2013 04:21 AM
  6. Microsoftjunkie's Avatar
    I have an 8x, and use to have the very same problem. The problem was the iPhone user. Believe it was a problem with the network, but don't think its your phone. If you're receiving texts from non iPhone users, you're fine.
    WanderingTraveler likes this.
    07-28-2013 04:32 AM
  7. shane francis's Avatar
    theres another solution for this. its easy, just tell your friends to dump the iphone and buy a windows phone ;).
    07-28-2013 05:22 AM
  8. lnsertName's Avatar
    Did you have an iPhone prior? Chances are you iPhone friends are trying to message you via imessage still. They need to change it to text.

    *edit*

    Read whole post, sorry... That would be my suggestion...
    Sandi Moore likes this.
    07-28-2013 05:40 AM
  9. Sandi Moore's Avatar
    That worked!!! Changed from imessage to text! Thank you!
    09-26-2013 11:30 AM
  10. Tina McNerthney's Avatar
    Thank you. I was having the same problem texting myself from my work IPhone. I went into the Messaging settings on my IPhone and turned off IMessage and turned on MMS Messaging and was able to send text messages to my Nokia Lumia 521 phone.
    10-02-2013 03:25 PM
  11. AngrySprintUser's Avatar
    I'm having the same issue and just contacted apple regarding the issue. Here's what they told me.

    If you switch from an iphone, to a different phone without switching off imessaging first, iphone messages will still go to imessaging. The guy was like "yeah it's something you guys should've probably known", yeah thanks

    So now I have to go and reactivate the iphone. Turn off imessaging, then deactivate it and reactivate the WP8. FML
    10-03-2013 05:05 PM
  12. Laura Chytrowsky's Avatar
    I had the same problem with texts messaging from iphone users. I just got the nokia lumia and my boyfriend has a iphone. I try everything to have him receive text messages from me, but the only thing I can get to work was have him to change his settings of imessage to text.

    I know a lot of people that a iphone, do I have to ask every single one of them to do that?
    is there a way where I can have my phone work for them?

    I did have a iphone preciously before this one.
    01-02-2014 09:32 PM
  13. wpn00b's Avatar

    So now I have to go and reactivate the iphone. Turn off imessaging, then deactivate it and reactivate the WP8. FML
    I wish I could have saved you this trouble before. You don't have to reactivate the iPhone, just connect it to WiFi, then deactivate iMessage. Also check that any other iDevices aren't set to use iMessage with that same phone number.
    01-06-2014 08:58 AM
  14. etlahrs's Avatar
    I had the same problem with texts messaging from iphone users. I just got the nokia lumia and my boyfriend has a iphone. I try everything to have him receive text messages from me, but the only thing I can get to work was have him to change his settings of imessage to text.

    I know a lot of people that a iphone, do I have to ask every single one of them to do that?
    is there a way where I can have my phone work for them?

    I did have a iphone preciously before this one.
    I didn't have an iPhone previously, but constantly get "Can't Send" when trying to text iPhone users. Most of the time it is after I have been texting them, then it just stops. The only way I have found to fix this is to put the phone in airplane mode so all the connections are turned off. Then turn airplane mode off. I usually then delete the message thread and start a new one, then it sends. But this is such a pain. I don't understand why this only happens with iPhones.

    If someone has a better, more permanent solution, that would be awesome.
    01-09-2014 01:56 PM

Similar Threads

  1. Replies: 4
    Last Post: 08-05-2013, 12:32 AM
  2. Replies: 6
    Last Post: 07-28-2013, 01:22 PM
  3. Sharing video from viner
    By mikeeemm in forum Windows Phone 7
    Replies: 3
    Last Post: 07-28-2013, 02:14 AM
  4. Nokia Lumia 510 Not Getting All Emails
    By osamatanvir1 in forum Windows Phone 7
    Replies: 2
    Last Post: 07-27-2013, 06:33 PM
LINK TO POST COPIED TO CLIPBOARD