1. Adam Linka's Avatar
    Hello!

    I have a strange problem with my HTC 8X. I have this device for 3 months, everything was working perfect since last update. Pages in IE and everything that uses internet connection is just very slow, when i use wifi. BUT if i do speedtest, it says 21Mbps (exactly what i have on my PC wire connected to the same router). I tryed factory reset - didnt help, reseting router - didnt help, changing from WPA2 to WPA - didnt help. If i connect to mobile network, everything just works perfectly fine and i am pretty sure, that mobile network is slower than my home internet. Any ideas, guys? btw i have another problem with my FB chat in the intergrated messenger - everytime i set up online status, it says "connected (logged in)" but also says "Nobody is online", when i see many friends online on my PC. So if someone knows solution, please, let me know :) Thanks
    08-07-2013 01:15 PM
  2. Laura Knotek's Avatar
    It is possible that you are getting interference from other wireless devices or networks. Have you tried changing the channel on your router?
    08-07-2013 09:04 PM
  3. Adam Linka's Avatar
    I've just tried it, but without success. Also tried change from WPA to WEP - didnt help :( But this happens even if i change the router, so i think, theres something from with my phone.
    08-08-2013 03:29 AM
  4. BroMarduk's Avatar
    Adam,

    I'm having a similar issue with slow WiFi on my 928. One thing I did find that restores WiFi speed back is to turn the celluar radio off. For me, Cell On, WiFi On = Slow WiFi and Cell Off, WiFi On = Blazing Fast WiFi. Not proposing that as a solution, but curious if that helps you out as well. I noticed its not so much the speed, but the ping times that are really slow with both on. I also noticed that it is not that way with all access points, so it could possibly be the router. I'm using a Asus RT-N66U as my router and use WPA2.
    08-12-2013 12:58 AM
  5. Adam Linka's Avatar
    Thanks for help, but it isnt working for me :( It really pisses me off, cuz it happened from nothing, my connection via WiFi was great, but now from day to day its just fkn slow. Maybe its coused by GDR2 update, but im not sure.. Ill try my phone in another wifi to check if problem is in phone or in router.
    08-12-2013 06:11 AM
  6. garyrday's Avatar
    I have exactly the same problem on my HTC 8X. it was work great until GDR2. I've tried it with several different wifi hotspots and routers at different physical locations, no joy. There is definately a bug with wifi in GDR2. Just wish i could revert to GDR1 as having a working wifi is way more important to me than the very few enhancements in GDR2. Please Microsoft, reliability is more important than features!!!
    08-22-2013 02:22 AM
  7. JulianRaymondDC's Avatar
    I have two Lumia 920's in my house (read no GDR2), and I'm having the exact same problem. I event deleted the network and restarted everything in case it was a DNS problem. This is ******* me off!
    09-03-2013 07:50 AM
  8. absonj's Avatar
    I've got the G2 update, and ever since, my WiFi connectivity has been a bit slow. I have to wait a minute after waking phone up before I can connect to WiFi, and sometimes it just drops the connection to my router. Its a pain, but it beats the.constant reboots and random freezes / battery pulls back when I had android. Still love the phone and especially the OS! Seeing more and more of the 8X out there. And hearing nothing but good from the new users.
    Sent from my wicked sexy HTC 8X windows phone using Board Express
    09-03-2013 08:07 AM
  9. ebk14's Avatar
    I have a Verizon 8x and have been having the exact same problem ever since the GDR2 update. When im at home, or any other WiFi connection that normally has been very fast, hardly works at all anymore. If I switch the WiFi off and use the lte network, the problem goes away...really annoying that things can never be perfectly right with this phone.
    09-03-2013 09:50 AM
  10. iampwd's Avatar
    Same problem with Ativ S after gdr2 (manual update). Router Asus RT-N66U.
    09-03-2013 10:01 AM
  11. OsT Pathology's Avatar
    Same here after the gdr2 update :\
    09-04-2013 05:08 PM
  12. vinscg's Avatar
    Same here, my gf's 8x as slow wi-fi
    Only tested with my internet-sharing for now.... But it was slow! (gdr2)
    09-04-2013 05:54 PM
  13. FearL0rd's Avatar
    I'm having the same problem with my 8X and 920

    http://forums.windowscentral.com/win...eople-hub.html
    09-15-2013 08:21 PM
  14. ShocWave's Avatar
    I have a similar problem here on my Samsung Ativ S.
    I wouldn't say the connection is slow, but the speed drops to nothing for a short time every few minutes.

    If I were watching a YouTube video, it would give me an error message about the connection.
    If I were browsing webpages using IE, I would have to hit refresh several times for the page to display.
    If I were using apps, I would see the loading "..." fly across the screen until I back out.
    09-16-2013 12:33 AM
  15. ebk14's Avatar
    I just wanna bump this message up. Im curious why not all htc8x phones wouldn't be having this WiFi issue post gdr2? Its a huge problem, WiFi is basically completely unusable now...i have to either use data only or constantly switch my WiFi off then on to get it to work for a minute...
    09-20-2013 04:48 PM
  16. gohaaron's Avatar
    Same here with my ATIV S after updating to GDR2!! my case is even worse where my stream disconnects after 5-10 secs!! WiFi is connecting but after doing some tests i found that the connection keeps breaking/disconnecting. very frustrating indeed! tried everything but still nothing has changed!
    09-23-2013 05:22 PM
  17. iampwd's Avatar
    I changed beacon interval to 1000 from 100 on my router and I think that help. Also disabled 3g when on WiFi. Haven't tried long enough to be certain if this helps or not. Probably not...
    09-24-2013 03:13 AM
  18. Eberstein's Avatar
    HTC had an update on my 8x for WiFi, but I'm not sure what it did.
    09-28-2013 11:53 AM
  19. ebk14's Avatar
    HTC had an update on my 8x for WiFi, but I'm not sure what it did.
    did you automatically receive the update? What carrier do you have?
    09-28-2013 02:23 PM
  20. ShocWave's Avatar
    GDR3 fixed it for me!
    10-17-2013 07:51 PM
  21. ebk14's Avatar
    It didn't fix mine urghhhhh
    10-22-2013 10:01 AM
  22. Derick Ho's Avatar
    I have the same issue on my Lumia 920. But different is , when i connect to my office wifi, it seems like no problems.. but i cant know what is the different in my home wifi and my office wifi. both are 5mbps.
    11-27-2013 04:55 AM

Similar Threads

  1. Anyone else experiencing slow charging?
    By Meagey in forum Nokia Lumia 925
    Replies: 6
    Last Post: 03-26-2015, 04:30 PM
  2. Whatsapp Connectivity error
    By Razan Ahmed in forum Nokia Lumia 520
    Replies: 7
    Last Post: 03-26-2014, 11:35 PM
  3. Can't send/receive media texts via Verizon 928
    By xrs22 in forum Microsoft News & Rumors
    Replies: 13
    Last Post: 08-18-2013, 02:41 PM
  4. Connectivity issues...
    By AndyCalling in forum Windows Phone 8
    Replies: 3
    Last Post: 08-07-2013, 02:21 PM
  5. Replies: 9
    Last Post: 08-07-2013, 07:25 AM
LINK TO POST COPIED TO CLIPBOARD