1. benrk's Avatar
    Hi-
    I recently got an HTC 8X smartphone with Windows Phone 8. I cannot connect to my home Wi-Fi network unless there is no security. I can add MAC address filtering, but my parents don't want it because it is not secure enough. I have been using WPA2 TKIP and WPA2 AES, and none of them allow my phone to connect to the network. They all brought up an error message of: Connection Unsuccessful, ...there was no response from the network. I tried WEP but couldn't figure out what to do with it. Are the WEP keys the passwords or the passphrase the passcode?

    I also tried a reset of my router, hard reset of my phone, and changing the SSID, but none of that works. The only thing that worked was taking off all security and using MAC address filtering. I also have a WP7.8 Samsung Focus Flash that has always worked perfectly and connects easily without any configuration.

    This is really bothering me because I love the phone and want to use it.

    Does anybody know anything or can help me?
    Thank you very much!!

    -Ben
    Last edited by benrk; 08-10-2013 at 11:58 PM.
    08-10-2013 07:51 PM
  2. Laura Knotek's Avatar
    Have you tried the following?
    To connect to a hidden Wi-Fi network

    A Wi-Fi network might be hidden, which means the network name isn't broadcasted. A hidden network won't appear in the list of available networks on the Wi-Fi settings screen, and a notification won't appear when the network is in range. To connect to a hidden Wi-Fi network when it's in range, you'll need to enter the network name and password.

    1. In Settings > Wi-Fi, make sure that Wi-Fi networking is set to On , and then tap Advanced.
    2. Tap Add , type the network name in the Network name box, and then tap Add.
    3. On the Sign in screen, type the password in the Password box, and then tap Done.


    Note

    The network name and password are case-sensitive.

    Connect to a Wi-Fi network | Windows Phone How-to (United States)
    08-10-2013 09:35 PM
  3. benrk's Avatar
    I have tried that. It did not work. I think it has something to do with the security because I put it on No security and it did work. Thank you for your help though.
    08-10-2013 10:32 PM
  4. eric12341's Avatar
    Are other devices able to still connect to the network?
    08-10-2013 11:45 PM
  5. benrk's Avatar
    Yes. All other devices connect perfectly fine. Two Kindle Fires, my Nexus 4, Windows 8 computer, and even my Samsung Focus Flash.
    Thanks for your help!
    08-11-2013 11:08 AM
  6. benrk's Avatar
    Okay... I tried switching it to straight G (instead of b/g) and also changed the password. I got the WiFi to work on my 8x for about an hour and now it won't connect. The only way it worked was if I signed into the network on my phone when it was still loading the new router settings. Otherwise, it never works. Does this give you any clues?
    08-12-2013 06:45 PM
  7. Pu Corleone's Avatar
    i had the same problem like u. my phone is HTC 8s. and when i tried to do what Laura Knotek said, it worked. i think u should try again and make sure u type a CORRECT network name. good luck :)
    benrk likes this.
    10-24-2013 08:47 PM
  8. eruptflail's Avatar
    Make sure you turn off "validate security certificate"
    10-25-2013 11:57 PM
  9. benrk's Avatar
    Turned out all I needed was a router firmware update. If all the other methods fail, try checking to see if there is a firmware update available for your router.
    02-22-2014 04:05 PM
  10. eastendboy13's Avatar
    Hi Ben,
    Can you please give me some details on how to get the Routers firmware updated? Sorry if this sounds a little lame.........I have Cable internet from BrightHouse Networks.

    Thanks!
    03-03-2014 09:52 PM

Similar Threads

  1. External Storage (MicroSD) versus Windows Phone 8 OS
    By Mike Damone in forum Windows Phone 8
    Replies: 13
    Last Post: 01-07-2014, 06:52 AM
  2. [Alpha][BETA] Fuelly App - Windows Phone 8 Signup
    By jkidd01 in forum App Spotlight
    Replies: 31
    Last Post: 12-02-2013, 05:51 PM
  3. my new lumia 920 is heated in back
    By pinturicchio_10 in forum Nokia Lumia 920
    Replies: 8
    Last Post: 08-11-2013, 07:43 PM
  4. Safe to say, no Google apps, ever?
    By Boris Lozac in forum Windows Phone 8
    Replies: 3
    Last Post: 08-10-2013, 10:12 PM
LINK TO POST COPIED TO CLIPBOARD