10-11-2016 01:37 PM
74 123
tools
  1. etphoto's Avatar
    Tried the SIM tape thing - it fixed the no service issue but I still get the "Try Again" message, even after GDR3.
    Yeah, grd3 did not correct the issue, as I was hoping. Happened to me a lot last night. Read this thread this morning and got all excited after reading the suggestion to turn text backup to off. Went to that setting and I already had it turned off, so that isn't the issue. <sigh>

    I am not a developer, but isn't updates supposed to make things better? Just makes sense. I can't stand when your device is working fine, get an update, and problems start. Then, have to wait months for the problems to be fixed.
    12-06-2013 07:51 AM
  2. Pedpole's Avatar
    My wife's ohone has had this problem for months. We have been to the local Verizon store 5 times to complain and they have tried different things, but none have worked. The last time they put a new sim card in and it was ok for a few weeks, but now is back. They said maybe an update will be out to fix it. I have a Nokia 822 and haven't had an issue with it. The 8x is junk in my opinion and Verizon hasn't been much help.
    12-12-2013 01:06 PM
  3. xrs22's Avatar
    Mine was a network problem. I'm located in the mountains and the nearest cell tower is 12.5miles in the town east of me. My phone gets on LTE when I hit the 9 mile mark, I always check it, but my wife's and sons android phone can get multimedia messages where as I can't. And I now that the terrain messes with the reception. I usually have to use roam to download multimedia texts/pics. I've already talked to tech support about it and they said wait for the next update, this was back in mid June this year.
    12-12-2013 01:20 PM
  4. GreenScrew's Avatar
    I have been a regular sufferer of this issue but haven't seen it since the recent updates that went out to the developer/tester audience. <knocking on wood>
    12-15-2013 06:34 PM
  5. GreenScrew's Avatar
    4 days later my optimism is increasing that the two small updates that went out to the dev preview folks has finally resolved the can't send issue once and for all! I haven't had a single instance since. But still "knocking on wood" for the time being....
    12-19-2013 12:28 PM
  6. gregz83's Avatar
    I had an interesting conversation with a Level 2 tech at Verizon named Chris. While he could not fully explain the cause of the issue, it seems to have something to do with the SMS traffic and the "Switch" that the cell phone is connected to at the time. He "cleared the traffic" and reset some things with my account on the switch.

    I honestly have no idea what this all means but for now it seems to have resolved the issue. I can tell you that I will keep calling and bothering them if this fix is not permanent.

    He also recommended as I travel a lot, that I power cycle the device at each new location I go to. Hard resets the switch connection as apposed to my phone just jumping to a new switch that is available.
    12-19-2013 05:55 PM
  7. tampacoder's Avatar
    Whew! I thought I was the only one with this issue. Driving me nuts. I'm glad a fix is in the works
    12-19-2013 06:55 PM
  8. scotthenry76's Avatar
    I am having the same problem here. Usually about one per week. Powering down then back up and forwarding the message to the intended contact seems to temporarily fix the issue. Hopefully a fix will come soon.
    12-26-2013 01:18 AM
  9. Joseph Lewkovich's Avatar
    I'm having this problem as well. It started after I switch to TMobile, then back to Verizon because my HTC 8x wasn't working well on TMobile. When I rejoined Verizon, everything was back to normal except the Retry problem. Thing is, my texts always go through on the third retry, so it isn't too much of an issue, just a nuisance. I'll try some of the workarounds in this thread and report back if anything works.
    12-26-2013 02:08 PM
  10. Tara Kirkland's Avatar
    Have had the same problem for months, but none of the above mentioned solutions worked for me. Just found this article and the problem has been remedied: Can't Send Text Messages on Windows Phone 8 | Joel Verhagen
    12-27-2013 07:09 PM
  11. fx45guy's Avatar
    After I turned off international text checking, it got Worse! Takes 3 times to successfully send a text now instead of only having the issue once in a while.
    12-31-2013 02:51 PM
  12. jlzimmerman's Avatar
    It's interesting that this is only happening on the HTC 8X, or so it seems. I haven't heard this issue happening on the Lumia 928. My wife is ready to jump ship because of this so I'm in damage control and about to buy 928 off eBay : /
    01-03-2014 09:17 AM
  13. wpn00b's Avatar
    The issue is being investigated. I've brought it up to the software guys at work and they are looking into it. It isn't a Verizon issue only, also not HTC 8X only...but frustrating all the same. I believe it is in the OS. But again, it's reported and being worked out.
    01-05-2014 05:18 AM
  14. wpn00b's Avatar
    I had an interesting conversation with a Level 2 tech at Verizon named Chris. While he could not fully explain the cause of the issue, it seems to have something to do with the SMS traffic and the "Switch" that the cell phone is connected to at the time. He "cleared the traffic" and reset some things with my account on the switch..
    "That is not the sole reason. It isn't always a network issue. I'm glad it seems to be working for you though.

    I can tell you that I will keep calling and bothering them if this fix is not permanent.
    Don't do this. It won't help. Just make sure that you have reported the issue in a way that it gets to someone that can do something about it. Chris is a great guy, I'm sure, but he doesn't write the software for the OS.

    If you do call back, call once and ask the technician to look up the issue in the internal device forums for the HTC 8X...it's in there. Not everyone has access to it. Whoever you get, let them know that a prior tech created a post detailing this issue and you'd like to add to it. If they have access they will gather your device info such as software version and such, and the problem description. That's it. If enough people report it in this way, the guys that report the widespread issues to the manufacturer, will notice and escalate it to Microsoft and HTC (or whoever depending on your device and OS) as an issue that needs fixing in an OS update.

    He also recommended...that I power cycle the device...
    This is always a good idea every once in awhile, regardless if you travel a lot or not. Computers like being reset every now and then. Keeps things fresh and clean. We all benefit from a quick nap, right?

    As for my two cents, I find that copying the failed message, then deleting it, then pasting it back into the same thread and sending makes it go through. Try that next time this happens.

    Good luck.
    01-05-2014 05:42 AM
  15. leland_jr's Avatar
    I have this now every single time I try to send a text. I'm about to take up TMobile on their offer if they'll buy the 8x. Would rather not, but this is insanely irritating.
    01-19-2014 03:59 PM
  16. Batkanman's Avatar
    Think I found solution - it's very easy and worked very well for me.
    So...Go to: Phone, then tap on three little dots in the right bottom corner,
    then tap "settings", scroll a little bit down, and *TURN OFF INTERNATIONAL ASSIST* .
    That's all! Enjoy!
    01-29-2014 11:58 AM
  17. etlahrs's Avatar
    Think I found solution - it's very easy and worked very well for me.
    So...Go to: Phone, then tap on three little dots in the right bottom corner,
    then tap "settings", scroll a little bit down, and *TURN OFF INTERNATIONAL ASSIST* .
    That's all! Enjoy!
    I have tried this previously and it still happens on a daily basis, usually multiple times a day.
    01-29-2014 04:31 PM
  18. Batkanman's Avatar
    This helped 8x owners who are outside of the US, just as I am.
    My friend also fixed the problem by turning off "international assist".
    01-29-2014 10:18 PM
  19. pedrag's Avatar
    i'm on my second HTC 8x and still have the same issue (try again). i tried the *TURN OFF INTERNATIONAL ASSIST* and still receive the same error message. in my case, message is successfully sent always on the 3rd re-try, so it works but annoying.
    02-22-2014 10:34 AM
  20. etlahrs's Avatar
    i'm on my second HTC 8x and still have the same issue (try again). i tried the *TURN OFF INTERNATIONAL ASSIST* and still receive the same error message. in my case, message is successfully sent always on the 3rd re-try, so it works but annoying.
    In the last few days, I have been having success on the 3rd try, sometimes the 4th, but that is new. Usually I can't send until turning airplane mode on and off and restarting the thread. But I am going to look into upgrading to the Icon this weekend
    02-22-2014 11:07 AM
  21. pedrag's Avatar
    I don't require any other action except hitting send 3x. I had 4 days left on my warranty and received my 2nd HTC 8x. I really wanted to upgrade to the Nokia ICON.
    03-06-2014 02:32 PM
  22. peacefulberry's Avatar
    The 8x is the most beautiful phone i have ever owned, but...

    This is a known (and extremely annoying) issue with the 8x. The other issue is the SIM card error. I wish I would have known about this before hand. The only fixes are a soft reset, phone restart, or to keep trying again and again (usually at least 3-4 times) before it corrects itself.

    The SIM card issue is the more serious issue because it is not reliable in times of emergency. This is the only reason why I am looking for a new phone. Because if I can't use my phone as a phone first, it has to go! LOL! Wish HTC could have fixed this. :(
    03-06-2014 09:53 PM
  23. rdlm's Avatar
    I have to agree the SMS problem is HORRIBLE. I keep hoping a fix will be made available, but no luck so far. Sometimes it works great, sometimes I have to press Send 3 or 4 times, sometimes I have to turn airplane mode on/off or reboot, sometimes deleting the offending message and trying again works, and sometimes it just won't work for hours on end.

    As for peacefulberry's SIM card issue, I take it adding a little scotch tape to the top of the SIM doesn't help (http://forums.windowscentral.com/htc...rror-8x.html)? I started getting Invalid SIM errors, and this was an easy (though silly) fix that 100% cured my SIM card issues.
    peacefulberry likes this.
    03-09-2014 04:41 PM
  24. peacefulberry's Avatar
    As for peacefulberry's SIM card issue, I take it adding a little scotch tape to the top of the SIM doesn't help (http://forums.windowscentral.com/htc...rror-8x.html)? I started getting Invalid SIM errors, and this was an easy (though silly) fix that 100% cured my SIM card issues.
    Yeah I have read about that fix, however at this point I'm just going to get another phone. If the SIM card is fixed I'll still get the messaging error or the double notifications (recent issue), not to mention the stuttering sound issue that's been there since day 1. I just wish HTC would have fixed this.
    03-10-2014 02:35 PM
  25. Judge_Daniel's Avatar
    Everyone needs to know that you can toggle your airplane mode in order to fix the problem. Don't bother restarting the phone. I, sadly, have an airplane mode live tile for such a situation. Oh, and you will have to copy the text into a new text simply by pressing and holding on the failed text. It saves a lot of time, even though it shouldn't be a problem in the first place.
    romant56 and Joseph Lewkovich like this.
    03-20-2014 06:45 PM
74 123

Similar Threads

  1. Problem With Audio out/Microfone in surface rt
    By ManVSKing in forum Microsoft Surface for Windows RT
    Replies: 3
    Last Post: 02-16-2015, 09:38 PM
  2. Want to buy Lumia 720, had L720 user got a problem?
    By frenzyvanrafi in forum Nokia Lumia 720
    Replies: 16
    Last Post: 12-26-2013, 06:08 AM
  3. Replies: 37
    Last Post: 10-15-2013, 06:56 AM
  4. O2 Internet Problems
    By acousticpoem in forum Nokia Lumia 820
    Replies: 2
    Last Post: 10-10-2013, 01:25 PM
  5. Replies: 1
    Last Post: 10-10-2013, 06:21 AM
LINK TO POST COPIED TO CLIPBOARD