1. trystan robbers's Avatar
    So i plugged my phone into the charger and when i came back my dog had chewed the charger cord. I tried turning on the phone but it didnt turn on. So i took it to my comp and plugged it in. It would vibrate and turn on to the boot screen but then turn rite back off. The phone does not even boot unless it is plugged in and once it is plugged in it does as described. What does this mean and what can i do to fix it?
    11-16-2013 04:31 AM
  2. mtiede's Avatar
    I'd guess it needs charging. Odd though that plugging in to USB doesn't get it charged. Maybe it doesn't have enough power to get USB going.
    11-16-2013 04:54 AM
  3. trystan robbers's Avatar
    It charges other phones and i dont think it needs charged. Do you think it could have fried my phone by the dog chewing up the cord while it was plugged in? Or maybe shorted my battery?
    11-16-2013 05:10 AM
  4. trystan robbers's Avatar
    Just plugged it into the wall and now all it does is just a faster virsion of what it did threw usb. It simply flashes the boot screen and turns off over and over again.
    11-16-2013 05:54 AM

Similar Threads

  1. Strange Skype camera problems
    By Bigfireq in forum Microsoft Surface Pro 2
    Replies: 3
    Last Post: 11-27-2013, 11:27 AM
  2. Skype on HTC 8X and its problems
    By serdard in forum HTC 8X
    Replies: 3
    Last Post: 11-16-2013, 10:42 AM
  3. Shortcut to Start screen
    By Slaytor Z in forum Windows 8
    Replies: 2
    Last Post: 11-16-2013, 04:49 AM
  4. Lumia 920 heating and screen problems
    By Renato Llozhi in forum Windows Phone 8
    Replies: 2
    Last Post: 11-16-2013, 03:20 AM
  5. Replies: 1
    Last Post: 11-15-2013, 08:39 PM
LINK TO POST COPIED TO CLIPBOARD