1. rahilsayed's Avatar
    I am having tremendous loss in battery,never happened to me before.Like if my phone is at 50% after restart it gives me 40%...i m not understanding what to do.
    Please help and even after charging it to 100%,a restart changes it to abround 95%....i disabled all the background tasks,still it continues.
    Let me tell you that i dropped it in water few weeks ago and repaired it from HTC centre and after that facing such issues.
    12-19-2013 10:13 AM
  2. Nathaniel Whittingham's Avatar
    I'm no technological genius, but i have reasons to believe that the dropping of your phone in water may be the cause of your problems. I have the same issue however. i didn't drop my phone, i only got it this Christmas and have downloaded a tonne of Xbox games. My battery seems to be draining rapidly even when it's in standby. My battery app tells me that i'm losing 8% per hour even when i'm not using it. I've set all background applications to off and have lowered my screen brightness as well as turning on battery saver mode. Help would be appreciated. Cheers.
    12-28-2013 09:25 PM
  3. stickyshocker's Avatar
    I am having tremendous loss in battery,never happened to me before.Like if my phone is at 50% after restart it gives me 40%...i m not understanding what to do.
    Please help and even after charging it to 100%,a restart changes it to abround 95%....i disabled all the background tasks,still it continues.
    Let me tell you that i dropped it in water few weeks ago and repaired it from HTC centre and after that facing such issues.
    If it is causing you issues i would book in for repair and get them to change the battery, its not good after being away already but im guessing it maybe something they didn't check for
    12-28-2013 09:30 PM
  4. Eric J F's Avatar
    Did you try restarting your phone? On both our 8X and Lumia 521 we'll occasionally get very rapid discharges (15%!) but a soft restart always fixes it. I assume some app or process goes nuts and uses up the battery.
    12-29-2013 08:31 AM
  5. Akash Thomas's Avatar
    i am pretty sure that it's because of the restart, restarting a device is power consuming affair, but if there are other issues such as: flickering screen, unresponsive buttons etc, then the water could have done some damage.
    12-29-2013 05:15 PM
  6. rahilsayed's Avatar
    Thank you all but i got it fixed by a repair and now i have no issues.Have a good time. :)
    12-30-2013 04:31 AM

Similar Threads

  1. Nokia Lumia cellular No services issue
    By KINGINI LABS in forum Nokia Lumia 920
    Replies: 1
    Last Post: 12-27-2013, 11:25 PM
  2. Going From 920 to 1020. Setup Issue
    By jbjtkbw007 in forum Nokia Lumia 1020
    Replies: 7
    Last Post: 12-19-2013, 07:58 AM
  3. Other storage issues
    By cesar ruiz1 in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 12-18-2013, 10:44 PM
  4. Battery Live Tile Editor V3
    By xtrose in forum Developers Corner
    Replies: 1
    Last Post: 12-18-2013, 04:40 PM
LINK TO POST COPIED TO CLIPBOARD